Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Implementing QoS on 3750 using MQC

Hi all,

I'm attempting to configure Classification and Marking on our access switches using the MQC model. The Switches are 3750's running IPBase Version 12.2(35)SE. For some reason when I activate the policy-map on an interface, no traffic is being tagged, i've used the 3750 QoS configuration examples (

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml) for reference and can't see where I'm going wrong, wondered if anyone can see where I've gone awry?

The requirement at the moment is just to mark Citrix Packets as AF31 (no policing is required at this point). I've copied the relevant bits of the config below (Sensitive data removed):

---------

mls qos

ip access-list extended CITRIX_NACL

permit tcp any any eq 2598

permit tcp any any eq 1494

class-map match-any MATCH_AF31

  match access-group name CITRIX_NACL

!

!

policy-map MARK_TRAFFIC

  class MATCH_AF31

   set dscp af31

!

!

interface FastEthernet2/0/1

description TestPort_PC

switchport access vlan 10

switchport mode access

service-policy input MARK_TRAFFIC

!

----------

That port has a PC plugged into it, which is accessing Citrix and running a continual ping to a device on another subnet. The output from a show policy-map int FA2/0/1 is below:

sh policy-map int fa2/0/1

FastEthernet2/0/1

  Service-policy input: MARK_TRAFFIC

    Class-map: MATCH_AF31 (match-any)

      0 packets, 0 bytes

       offered rate 0 bps, drop rate 0 bps

      Match: access-group name CITRIX_NACL

        0 packets, 0 bytes

         rate 0 bps

    Class-map: class-default (match-any)

      0 packets, 0 bytes

       offered rate 0 bps, drop rate 0 bps

      Match: any

        0 packets, 0 bytes

         rate 0 bps

As you can see no traffic is marked as AF31, but also no traffic is shown in the default-class either suggesting it's probably not just that I've put a typo in the ACL. An upstream packet capture shows that the packets are definately not being tagged.

Can anyone see where I've messed up?

Regards,

Paul

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Implementing QoS on 3750 using MQC

Hi Paul,

2 quick comments:

1. Can you check if you have "no mls qos rewrite ip dscp"  in your config? If yes can you remove it (mls qos rewrite ip dscp ).

2. From interface notation I see that you have switches in a stack. Is switch 2 a slave switch by any chance? if yes can you try the same config on the master switch instead?

Riccardo

5 REPLIES
Purple

Implementing QoS on 3750 using MQC

Hi,

even if you can type this command it won't give you any useful information as the interface command is not supported.

you should use sh mls qos interface f2/0/1 statistics instead

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: Implementing QoS on 3750 using MQC

Alain,

Thanks for that, hadnt realised it was unsupported as it just takes the command without complaint.

Cisco Employee

Re: Implementing QoS on 3750 using MQC

Hi Paul,

2 quick comments:

1. Can you check if you have "no mls qos rewrite ip dscp"  in your config? If yes can you remove it (mls qos rewrite ip dscp ).

2. From interface notation I see that you have switches in a stack. Is switch 2 a slave switch by any chance? if yes can you try the same config on the master switch instead?

Riccardo

New Member

Re: Implementing QoS on 3750 using MQC

Riccardo,

Step one got it thanks very much!

For reference was configuring via Telnet, so I assume it probably uses the stack master to process the vty line input, just guessing though don't have any evidence to back that up, worked happily enough in any event.

Cisco Employee

Re: Implementing QoS on 3750 using MQC

I am glad to read 

the command you had in the config, as you would have certanly understood by now, was disabling the capability to write the dscp field.

Riccardo

463
Views
13
Helpful
5
Replies
CreatePlease to create content