Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Initial Ping Response is a bit high ?

Hello expert,

I was put up with a strange question by my lead and i couldnt reply him back. Could you please help me out.

The destination im trying to rach is only 2 hops away. The First ping response took 25ms , second and further responses are only 1ms, why there is a delay in the first response of the ping ? and  by this inturn affecting the total 5 ping response average to 6ms ?

Please find below with the Ping and Traceroute.

C:\Users\srikanth.athelly>ping 10.24.24.2

Pinging 10.24.24.2 with 32 bytes of data:
Reply from 10.24.24.2: bytes=32 time=25ms TTL=255
Reply from 10.24.24.2: bytes=32 time<1ms TTL=255
Reply from 10.24.24.2: bytes=32 time<1ms TTL=255
Reply from 10.24.24.2: bytes=32 time<1ms TTL=255

Ping statistics for 10.24.24.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 25ms, Average = 6ms

C:\Users\srikanth.athelly>tracert 10.24.24.2

Tracing route to 10.24.24.2 over a maximum of 30 hops

  1     6 ms    <1 ms    <1 ms  10.24.64.3
  2    <1 ms    <1 ms    <1 ms  10.24.24.2

Trace complete.

20 REPLIES

Initial Ping Response is a bit high ?

Does this 'higher' RTT happen every time you ping the device or did it just happen the once?

Community Member

Initial Ping Response is a bit high ?

Everytime I Ping the First  response is between 10-25ms .. second and further responses are 1ms constantly.

Appreciate your help.

Thanks

Initial Ping Response is a bit high ?

Login to the first hop Router and ping from there, is the result the same?

Sometimes the first ping is dropped whilst an ARP is completed but this should not happen the second time as your device caches the MAC address of your default gateway.

Do an arp -a on your device, is the MAC of your default gateway shown?

Community Member

Initial Ping Response is a bit high ?

As said earlier

Everytime I Ping the First  response is between 10-25ms .. second and further responses are 1ms constantly.

This is not for the single destination 10.24.24.2, but it is same to all the destination(out of the subnet of the PC) when im trying to ping for ex: 10.24.64.1

------------------

Ping Avg. from the next hop router to 10.24.24.2 is 1 Ms.. Yes the mac address is learnt in arp table of the PC.

 

000001#sh ip arp | IN 10.24.24.2

Internet  10.24.24.2            139   e05f.b99f.1bbf  ARPA   Vlan24

 

000001#ping 10.24.24.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.24.24.2, timeout is 2 seconds:
!!!!!
000001#

 

 

PC- Pinging

C:\Users\srikanth.athelly>arp -a

Interface: 10.24.64.28 --- 0xa
  Internet Address      Physical Address      Type
  10.24.64.1            00-00-0c-07-ac-40     dynamic
  10.24.64.3            e0-5f-b9-9f-1a-ff     dynamic

 

C:\Users\srikanth.athelly>tracert 10.24.24.2

Tracing route to 10.24.24.2 over a maximum o

1     6 ms    <1 ms    <1 ms  10.24.64.3
  2    <1 ms    <1 ms    <1 ms  10.24.24.2

 

 

C:\Users\srikanth.athelly>ping 10.24.64.1

Pinging 10.24.64.1 with 32 bytes of data:
Reply from 10.24.64.1: bytes=32 time=7ms TTL=255
Reply from 10.24.64.1: bytes=32 time<1ms TTL=255
Reply from 10.24.64.1: bytes=32 time<1ms TTL=255
Reply from 10.24.64.1: bytes=32 time<1ms TTL=255

 

 

Thanks,

Initial Ping Response is a bit high ?

What I am getting at is, this issue seems to be pinging any destination IP address from the same PC correct?

The issue does not occur if you ping from others machines?

Community Member

Initial Ping Response is a bit high ?

Yes from the same PC, the other PC's are pinging in 1ms.

Thanks,

Community Member

Initial Ping Response is a bit high ?

Could some one help me on this, pls..

Thanks

Community Member

Initial Ping Response is a bit high ?

Hello Experts need you inputs on this. Im awaiting for your reply..

I appreciate your time on this.

Community Member

Initial Ping Response is a bit high ?

Hi Srikanth,

The first package has to find the entry in the ARP table.

You can try pinging from the switch that the host is connected to, which should give you an idea if there is an issue there.

Community Member

Initial Ping Response is a bit high ?

from the next hop router of the PC. the ping response is of average 4ms for 5 ping responses.

1. ping response of 4ms. for the destination which is on cloud is acceptable right.?

2. My lead really want to know why the single PC is responding slow.

Community Member

Initial Ping Response is a bit high ?

Just try the following steps;

1.run the command "clear arp-cache" on the router, then check the ping response

if issue still not resolved then

2. change ip address of your pc and check the result.

Initial Ping Response is a bit high ?

If its just a single PC then that narrows things down a bit.

I am not sure why a 'lead' would be concerned about a single PC but if you really need to know then try a wireshark on the PC and run the ping again and then analyse the packets.

My bet is on ARP so clear the cache on the PC by running the following in a CMD window:

netsh interface ip delete arpcache

Community Member

Initial Ping Response is a bit high ?

Hello ,

Now its affected to all PC's . the First ping response is reaching to 15 ms. but the next response is just 1ms-2ms.

I have cleared the cache to all the PC's. its still the same.

I stucked here. Kindly, help me on this.

Thanks,

Srikanth

Initial Ping Response is a bit high ?

Whats your topology, what devices u have and wat kind of links.

Jawad

Jawad

Initial Ping Response is a bit high ?

Run wireshark on one for the PC's and run the ping again, see what the packets say.

Community Member

Initial Ping Response is a bit high ?

Topology

PC -----> L2Switch------->L3Core (10.24.24.2)---------->Internet

From PC to 10.24.24.2 the first Ping response is high/

i will run the wireshark and produce the log file here.

Thanks,

Cisco Employee

Initial Ping Response is a bit high ?

Srikant,

what platform is this?

Richard

Community Member

Re: Initial Ping Response is a bit high ?

Cisco devices  2960, 6500 series switches..

1.Can you say me what are the possibilities which would affect computer to behave in this odd way. that too only first ping jumps to high value.

2. the ping from L2switch to Core switch is good. the first hop looks fine too. the CPU process is not more than 10% in core and L2 switches. What would be the points i should consider in troubleshooting this in the perspectivies of cisco switches.

Thanks,

Cisco Employee

Re: Initial Ping Response is a bit high ?

From the switch perspective the ping packets are processed in CPU whether it is to the switch or from the switch.If you dont have high CPU the next thing that you need to check  Take simultaneous captures on the switch and at the PC. Observe if you see the ping packets and see if there is any delay. To me this looks like some kind of malware effects in the PC. Try to check if you have any anti-virus program running. Disable everything and run it again. Hope there is no DNS resolve too

Richard

Community Member

Re: Initial Ping Response is a bit high ?

Oh thanks, Richard will collect some logs and see what it says.

2190
Views
3
Helpful
20
Replies
CreatePlease to create content