Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

input drops on trunk due to keepalives

we have a setup 6500-------> 2970

Not much traffic on a trunk but we have quite a lot of input drops on 2970

but the input drops dissapears if i disable keepalives

can someone help me out with this ?

6506 interface :

interface FastEthernet3/15

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 45

switchport mode trunk

switchport nonegotiate

no ip address

no logging event link-status

load-interval 30

speed 100

duplex full

no snmp trap link-status

FastEthernet3/15 is up, line protocol is up (connected)
  Hardware is C6k 100Mb 802.3, address is 0012.dafe.85be (bia 0012.dafe.85be)
  Description: SRC=VL-MO-RI009-Fas3-15, DST=VL-DV-SG001-Gig0-24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is unsupported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:32, output 00:00:01, output hang never
  Last clearing of "show interface" counters 2w3d
  Input queue: 0/2000/165204/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     809897 packets input, 478719601 bytes, 0 no buffer
     Received 50975 broadcasts (37132 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     3045538 packets output, 247983738 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


2970 configuration:




interface GigabitEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 45

switchport mode trunk

switchport nonegotiate

no ip address

duplex full

speed 100

no mdix auto


GigabitEthernet0/24 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0011.92c6.e498 (bia 0011.92c6.e498)
  Description: SRC=VL-DV-SG001-Gig0-24, DST=VL-MO-RI009-Fas3-15
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     2806097 packets input, 228508296 bytes, 0 no buffer
     Received 2430932 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 2212762 multicast, 0 pause input
     0 input packets with dribble condition detected
     762370 packets output, 463878259 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
2 REPLIES
Cisco Employee

input drops on trunk due to keepalives

Please clear the counters once and run the command 'sh int fa3/15" few times to see if the input queue drops increment. From the output

Input queue: 0/2000/165204/0 (size/max/drops/flushes); Total output drops: 0

there seems to be no packet clogged in the queue currently.

The system counts input queue drops if the number of packet buffers       allocated to the interface is exhausted or reaches its maximum  threshold. You       can increase the maximum queue value with the hold-queue command for each interface       (the queue length value can be between 0 and 4096. The default value  is       75).

Refer to this link as well. This will highlight more on the input queue drops.

http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094791.shtml

Cheers

Sweta

Please rate the useful posts.

New Member

input drops on trunk due to keepalives

Thanx for getting back to me Sweta

The thing is there is no traffic passing through the interface so there should not be any input Queue and there should not be any input drops and the input drops dissappear when i disable keepalives.

By default keepalives are for 10sec and for ethernet interfaces, keepalives are sent to the same interface to check if the interface is alive and for every 1 min i see 6 input drops which represents that all the keepalives are dropping.

and i see drops only on 6500 end not on 2970.

309
Views
0
Helpful
2
Replies