Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Input errors (runts) on 2620xm router | 3524xl switch and cable modem

Hello everyone:

I have a problem that i can not seem to figure out. What I basically have is a Comcast cable modem connected to a 3524xl switch port that is trunked. I then have a 2620xm w/ 1FE port that is plugged into another trunked port on my 3524xl switch. Both trunked ports are using dot1q encapsulation and i am able to communicate w/ my LAN and the Internet. My problem is that i am getting an increasing amount of input errors coming across the port on my switch that the router is plugged into. The input errors exactly match the same amount of runts on this interface. Where are these runts coming from and how do I stop this? Below is my configuration for both my router and switch and a copy of the "sh int fa0/2" of my switch port that my router is plugged into where these errors are most prominent.  Please help me on this as I am at my wits end and have not been able to find resolution on this problem.

ROUTER CONFIG:

version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
logging monitor errors
enable secret 5 $1$IVfA$6EO.HQbeqXKcHsN9Lpg1u.
!
no aaa new-model
clock timezone Eastern -4
clock save interval 8
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef   
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1
ip dhcp excluded-address 192.168.10.1 192.168.10.12
!
ip dhcp pool HOME
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 192.168.10.4 68.87.75.198 68.87.64.150
   domain-name brennanahaines
   lease 0 12
!
!
ip flow-cache timeout active 2
no ip bootp server
ip domain name brennanahaines.com
ip host Svr2k3 192.168.10.6
ip name-server 192.168.10.4
ip name-server 192.168.10.5
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip ddns update method HOME
DDNS both
!
vpdn enable
!        
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username todd privilege 15 password 7 06342F2F4B4B1B4957
!
!
ip tcp synwait-time 10
ip ssh version 2
!
!        
!
!
!
interface FastEthernet0/0
ip address 192.168.11.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
ip route-cache same-interface
ip route-cache policy
ip route-cache flow
no ip split-horizon
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.10.1 255.255.255.0
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
no ip split-horizon
no cdp enable
!        
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no cdp enable
!
interface FastEthernet1/0
no mop enabled
!
interface FastEthernet1/1
speed 100
spanning-tree portfast
!
interface FastEthernet1/2
speed 100
spanning-tree portfast
!
interface FastEthernet1/3
speed 100
spanning-tree portfast
!
interface FastEthernet1/4
speed 100
spanning-tree portfast
!
interface FastEthernet1/5
no switchport
no ip address
speed 100
no cdp enable
!
interface FastEthernet1/6
speed 100
spanning-tree portfast
!
interface FastEthernet1/7
speed 100
spanning-tree portfast
!
interface FastEthernet1/8
speed 100
spanning-tree portfast
!
interface FastEthernet1/9
speed 100
spanning-tree portfast
!
interface FastEthernet1/10
speed 100
spanning-tree portfast
!
interface FastEthernet1/11
speed 100
spanning-tree portfast
!
interface FastEthernet1/12
speed 100
spanning-tree portfast
!
interface FastEthernet1/13
speed 100
spanning-tree portfast
!
interface FastEthernet1/14
speed 100
spanning-tree portfast
!
interface FastEthernet1/15
vlan-range dot1q 1 4
  exit-vlan-config
!
!
interface GigabitEthernet1/0
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0.2
peer default ip address pool VPN
no keepalive
ppp encrypt mppe auto
ppp authentication ms-chap ms-chap-v2
!
interface Vlan1
no ip address
!
interface Async1
no ip address
encapsulation slip
!
router ospf 1
log-adjacency-changes
network 192.168.10.0 0.0.0.255 area 0
network 192.168.11.0 0.0.0.255 area 0
!
router rip
version 2
network 192.168.10.0
network 192.168.11.0
network 192.168.13.0
!
ip local pool VPN 192.168.20.1 192.168.20.5
ip forward-protocol nd
!
ip flow-top-talkers
top 10
sort-by bytes
!
no ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0.3 overload
ip nat inside source static udp 192.168.10.11 88 interface FastEthernet0/0.3 88
ip nat inside source static udp 192.168.10.11 3074 interface FastEthernet0/0.3 3074
ip nat inside source static tcp 192.168.10.11 3074 interface FastEthernet0/0.3 3074
ip nat inside source static udp 192.168.10.11 53 interface FastEthernet0/0.3 53
ip nat inside source static tcp 192.168.10.11 80 interface FastEthernet0/0.3 80
!
ip access-list extended Inside_Going_Out
remark Contains rules about what is permitted out
deny   ip host 255.255.255.255 any
deny   ip 127.0.0.0 0.255.255.255 any
permit ip any any
ip access-list extended Outside_Going_In
remark Contains rules on what is allowed in
permit tcp any any established
deny   ip 192.168.0.0 0.0.255.255 any
deny   ip 10.0.0.0 0.255.255.255 any
deny   ip 172.16.0.0 0.15.255.255 any
deny   ip host 255.255.255.255 any
deny   ip 127.0.0.0 0.255.255.255 any
permit udp any eq bootps any eq bootpc
permit icmp any any echo-reply
permit icmp any any time-exceeded
permit icmp any any unreachable
permit tcp any any
permit udp any any
remark Contains rules on what is allowed in
permit udp host 68.87.75.198 eq domain any
permit udp host 68.87.64.150 eq domain any
deny   ip 61.163.0.0 0.0.255.255 any
deny   ip 122.102.0.0 0.0.255.255 any
deny   ip 216.0.0.0 0.255.255.255 any
!
logging trap alerts
logging 192.168.10.4
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
access-list 100 permit tcp any any eq 3389
snmp-server community HOME RW
snmp-server community public RO
snmp-server host 192.168.10.6 version 2c HOME
snmp-server host 192.168.10.6 version 2c public
no cdp run
!
!
!
control-plane
!
!
!
!
!
!
!
!        
!
!
line con 0
exec-timeout 20 0
line 1
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
login local
transport input telnet ssh
line vty 5
login
transport input telnet ssh
!
ntp clock-period 17179971
ntp server 192.5.41.209

SWITCH CONFIG:

version 12.0
no service pad
service timestamps debug datetime localtime
service timestamps log datetime
no service password-encryption
!
hostname S1
!
logging buffered 51200 warnings
logging console emergencies
logging monitor informational
enable password R@nger02
!
username todd privilege 15 password 0 R@nger02
!
!
!
!
clock timezone Eastern -4
spanning-tree uplinkfast
!
spanning-tree vlan 1 priority 1
no spanning-tree vlan 1
no spanning-tree vlan 3
ip subnet-zero
ip tcp timestamp
!
!
!
interface FastEthernet0/1
description WAN
duplex full
speed 100
switchport trunk encapsulation dot1q
switchport mode trunk
no cdp enable
!
interface FastEthernet0/2
description ROUTER PORT
duplex full
speed 100
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3,1002-1005
switchport mode trunk
no cdp enable
!
interface FastEthernet0/3
description CABLE MODEM
duplex half
speed 100
switchport access vlan 3
no cdp enable
!
interface FastEthernet0/4
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/5
duplex full
speed 100
no cdp enable
!
interface FastEthernet0/6
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/7
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/8
no cdp enable
!
interface FastEthernet0/9
description DOWNSTAIRS LAN
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/10
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/11
description NETGEAR WIRELESS ROUTER "G" Michigan
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/12
description XBOX-360
duplex full
speed 100
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/13
description POWEREDGE LAN 1 (INSIDE)
duplex full
speed 100
port monitor FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
no cdp enable
!
interface FastEthernet0/14
description POWEREDGE LAN 2 (OUTSIDE)
duplex full
speed 100
switchport access vlan 2
spanning-tree portfast
no cdp enable
!
interface FastEthernet0/15
description SVR2K3
duplex full
speed 100
switchport access vlan 2
spanning-tree portfast
no cdp enable
!
interface FastEthernet0/16
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/17
no cdp enable
!
interface FastEthernet0/18
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/19
no cdp enable
!
interface FastEthernet0/20
description FAST ETHERNET - 1751V ROUTER
no cdp enable
!
interface FastEthernet0/21
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/22
switchport access vlan 2
no cdp enable
!
interface FastEthernet0/23
no cdp enable
!
interface FastEthernet0/24
switchport mode trunk
no cdp enable
!
interface GigabitEthernet0/1
no cdp enable
!
interface GigabitEthernet0/2
no cdp enable
!
interface VLAN1
no ip address
no ip directed-broadcast
no ip route-cache
shutdown
!        
interface VLAN2
ip address 192.168.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.10.1
ip http authentication local
logging trap critical
logging 192.168.10.4
no cdp run
snmp-server engineID local 0000000902000002B9365900
snmp-server community HOME RW
snmp-server community public RO
snmp-server host 192.168.10.6 trap version 2c HOME
snmp-server host 192.168.10.6 trap version 2c public
!
line con 0
transport input none
stopbits 1
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
login
!
ntp clock-period 11259638
ntp server 192.5.41.209
end

INTERFACE STATS:

FastEthernet0/2 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0002.b936.5902 (bia 0002.b936.5902)
  Description: ROUTER PORT
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 223/255, txload 20/255, rxload 19/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters 00:02:22
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 7793000 bits/sec, 758 packets/sec
  5 minute output rate 7873000 bits/sec, 1133 packets/sec
     238521 packets input, 318281313 bytes
     Received 12 broadcasts, 118005 runts, 0 giants, 0 throttles
     118005 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 12 multicast
     0 input packets with dribble condition detected
     362525 packets output, 321037769 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Thanks everyone.

10 REPLIES

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

From the first point i can see the following...

FastEthernet0/2 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0002.b936.5902 (bia 0002.b936.5902)
  Description: ROUTER PORT
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 223/255, txload 20/255, rxload 19/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters 00:02:22
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 7793000 bits/sec, 758 packets/sec
  5 minute output rate 7873000 bits/sec, 1133 packets/sec
     238521 packets input, 318281313 bytes
     Received 12 broadcasts, 118005 runts, 0 giants, 0 throttles
     118005 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 12 multicast
     0 input packets with dribble condition detected
     362525 packets output, 321037769 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

The reliability of the interface is lower then 255 which indicates that there is a physical layer issue. Change the cable and hardcorde the duplex and speed on both sides.

HTH

Hitesh Vinzoda

Pls rate useful posts.

New Member

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Hitesh--

I have hardcoded all ports 100/full and have changed the patch cable with brand new cat 6 cable. The cable modem tho i can not hardcode the setting on. I am still showing incrementing runts and input errors. This I have tried before but to no avail. Thanks for the help tho.

Todd

Cisco Employee

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Hello,

Please set duplex/speed to auto on both ends. That way, both devices will

negotiate the physical layer parameters.

Hope this helps.

Regards,

NT

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Normally you would look to a faulty NIC or NIC driver as the cause of runts but that is not the case here. I also see you hard set the speed and duplex but if it were a duplex mismatch you would see other errors and not just runts. I have seen/heard of this before and I think in ended up being a bug in the IOS. I will do some searching and see if I can find the info. I would try this in the mean time as it could be something wrong with on of the ports themselves, can you checnge the ports and see if the errors continue.

Mike

New Member

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Mike--

I can reconfigure one of my ports on the switch just to make sure its not the switch port but i can not do it on the router as i only have 1 FE port on it. I am hoping its not the router FE port. Thanks for the info. I am willing to try anything.

Todd

Cisco Employee

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Hello,

Have you tried speed/duplex settings to auto? Typically that helps.

Regards,

NT

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

NT,

Correct me if I am mistaken but if this were a duplex mismatch you would see other errors such as collisions and CRC errors wouldn't you? Runt as I understand it is that it is a good frame just too small ( under 64 bytes). In fact in some cases such with ATM frame can have a 48 byte info field and a 5 byte header and the result is a 53 byte frame and by defination this is a runt but is perfectly ok.

Mike

Cisco Employee

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Hello,

You are correct.. I am still in my sleep :).. I did not notice the runts

part but read the input errors part..

We can conveniently ignore runts as the Cisco devices will forward the

traffic without any issue but just update the counter for accounting

purposes.

Regards,

NT

New Member

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Nagaraja and Mike-

So basically the runts that i am seeing accumulating on my switch port is nothing to be concerned about then? All responces i have tried and still show the runts accumulating. If this is the case then that is good. My network dont seem to suffer from it and i have no lag (latency) at all. Thanks again everyone.

Todd

Cisco Employee

Re: Input errors (runts) on 2620xm router | 3524xl switch and ca

Hello,

You need not be concerned about runts. It is just an accounting parameter.

But the switch will still forward the packet without any issues.

Regards,

NT

2042
Views
0
Helpful
10
Replies