Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Installing C3560 and 3750 switches

Hi, I am upgrading from Catalyst 2950's.  I have 2 questions.

1.  QOS - We are running nortel phones.  They use dscp CS5 and EF.  Here is the config for each switchport I have and it all works well.

interface GigabitEthernet0/2
description PC-PORTS
switchport voice vlan 256
priority-queue out
mls qos trust dscp

switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable

I was wanting to create a policy and apply it then if anything hits that policy to send it out in the priority queue.  I want to do this for my own knowledge and develop a standard across all my branches.  QOS on the routers are in effect.

I have created the below class

class-map match-any NORTEL
  match ip dscp ef
  match ip dscp cs5
!
policy-map VOICE
  class NORTEL
   set dscp ef

2.  General Config

Here is the basic config for my switch.  Can anyone recommend adding anything that would be beneficial?

mls qos
!
!
macro global description cisco-global
errdisable recovery cause link-flap
errdisable recovery interval 60
no file verify auto
!
spanning-tree mode pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!

  • LAN Switching and Routing
2 REPLIES

Re: Installing C3560 and 3750 switches

Regarding the general settings; you need to add the following line:

mls qos map cos-dscp 0 10 18 26 34 46 48 56

This binds dscp EF (46) to cos5.

Otherwise, I do not see any big issues with the proposed setup.

regards,

Leo

New Member

Re: Installing C3560 and 3750 switches

cool !

here is my updated configuration:

mls qos map cos-dscp 0 10 18 26 34 46 48 56
mls qos
!
!
macro global description cisco-global
errdisable recovery cause link-flap
errdisable recovery interval 60
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 256
name VOICE
!
class-map match-all VOIP
  match ip dscp ef
class-map match-all SIGNAL
  match ip dscp cs5
!
!
policy-map VOICE
  class VOIP
   set dscp ef
  class SIGNAL
   set dscp ef

!
interface GigabitEthernet0/1
description PC-PORTS
switchport mode access
switchport voice vlan 256
priority-queue out
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input VOICE

Just for clarification.

1.  Nortel uses DSCP 40 for signalling and 46 for voice.

2.  Switchports go to the IP pPhone first then from the phone they go to the PC vlan 1.

Would it be beneficial to set any of the

mls qos srr-queue input priority-queue or bandwidth numbers

or in the interface the srr-queue shape or share commands?

233
Views
0
Helpful
2
Replies
This widget could not be displayed.