Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inter-VLAN Multicast IP Routing using a 3560x Switch

Hello All,

Could use some more help here:

1)  When setting up VLANS to route multicast data between two separte devices do you need one ip address for

each physical port that is to receive multicast data AND one for each VLAN that has same physical port assigned to it?

Researching for answers has not helped.

This is what I am trying to do:

I am only using ONE switch in a LAN configuration.

I have two source conversion units that converts serial data to ip multicast data.  One is configured to output an address of

239.1.1.3 and the other.239.1.1.4.  I want to be able to route both ip multicast data streams to two destination conversion units.

These units are capable of receiiving BOTH ip multicast data streams at the same time.

Researching on how to do it and several attempts to configuring the switch has not been succesful.

Please, I am learning and do not have much experince with networking but have had success with Multicast Vlan Registration (MVR).

Now that I have a L3 switch I would like to use standard VLANS with Routing.  Could use some helpful information on writing the

configuration for the switch.

Thanks.

Regards,

Jeff

14 REPLIES
Cisco Employee

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hello Jeff,

Perhaps an example is simpler than lengthy explanations.

If both the sender and the receiver are in the same VLAN then the configuration shall look as follows (an example):

ip igmp snooping querier

!

interface FastEthernet0/1

! Multicast source is connected here

switchport mode access

switchport access vlan X

!

interface FastEthernet0/2

! Another multicast source is connected here

switchport mode access

switchport access vlan X

!

interface FastEthernet0/3

! Multicast receiver is connected here

switchport mode access

switchport access vlan X

!

interface FastEthernet0/4

! Another multicast receiver is connected here

switchport mode access

switchport access vlan X

!

interface Vlan X

ip address 192.0.2.1 255.255.255.0

In fact, the only special command here is the ip igmp snooping querier - this allows the switch itself to send IGMP Membership Query messages to ask for multicast groups the receivers are subscribed into, and to build a list of outbound switchports through which the multicast shall be switched out. Otherwise, there is absolutely no special configuration required.

If the sender and receiver are in different VLANs then the configuration would look as follows:

ip multicast-routing ! or ip multicast-routing distributed - depends on your switch platform

!

interface FastEthernet0/1

! Multicast source is connected here

switchport mode access

switchport access vlan X

interface FastEthernet0/2

! Another multicast source is connected here

switchport mode access

switchport access vlan X

interface FastEthernet0/3

! Multicast receiver is connected here

switchport mode access

switchport access vlan Y

!

interface FastEthernet0/4

! Another multicast receiver is connected here

switchport mode access

switchport access vlan Y

!

interface Vlan X

ip address 192.0.2.1 255.255.255.128

ip pim dense-mode

!

interface Vlan Y

ip address 192.0.2.129 255.255.255.128

ip pim dense-mode

Here, you first need to activate the support for multicast routing. Then, SVIs for VLANs where multicast sources and destinations are located are configured for PIM Dense Mode operation (this is the simplest way of running multicast routing). The IGMP Snooping Querier is not required in this setting because the activation of the PIM Dense Mode also causes the switch to start sending IGMP queries automatically.

Notice that with particular regard to IP addressing, there is absolutely nothing different here from ordinary unicast routing. The only assigned IP addresses are used on SVIs.

Feel welcome to ask further!

Best regards,

Peter

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

This is great!!.  I needed to see an example and now I can compare to what I have written and

hopefully see what is wrong.

Your second example is what I am searching for and actually is what I attempted to write

using PIM.  In my configuration I am using "pim-sparse-dense-mode".  I believe your second method

is the way to go because I want to have one source/receiver group each in separate VLANs.  Since the receiver units

are programmed to receive both multicast data streams (239.1.1.3 & 239.1.1.4) I want to have both receivers

receive both data steams.

My goal then is to wriite a script where a executed command will select only one data stream that will pass from

a switch port to any selected receiver.  This is what I did using MVR on a 2950.  Now that I have a L3 switch

I want to use standard VLANs and route data.

Like I said I do not have much experience but I want to learn!!  I will examine what you have written and try

things out.

Thanks.

Regards,

Jeff

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

This is my second reply to your first.

It works!  However, I have a couple of questions.

1)  I was not able to put in "ip prim" after entering the ip address.  Below is the partial configuration for

     one of the port groups:

#Created one VLAN and assigned two ports to it (one source/destination group)

cisco4(config)#iip multicast-routing distributed
cisco4(config-if)#interface gi0/1

cisco4(config-if)#switchport mode access

cisco4(config-if)#switchport access vlan 5

cisco4(config-if)#exit

cisco4(config)#interface gi0/5

cisco4(config-if)#switchport mode access

cisco4(config-if)#switchport access vlan 5

cisco4(config-if)#exit

cisco4(config)#interface vlan 5

cisco4(config-if)#iip address 192.0.2.1   255.255.255.128

# I was not able at this point to put in pim
cisco4(config-if)#exit

#Repeated for the second source/receiver group with another VLAN and IP address.

Now this configuration works.  I was able to route from one source to the other reciever by just changing

the "switchport access vlan #" line for the port number.

Do not understand why I was not able to put in "pim" but it did not stop from routing the data.

2)  From my first reply I wanted to have both receivers receive BOTH multicast data at the same time.

     Then through a script program would be able to select which multicast data would be passed through

     a switch port.

I have done some research on whether you can have two VLANS assigned to one port with the idea

in my case, that now both multicast data streams would be at the port to the receiver.  It appears that

this can not be done unless a trunk is used with another device, is this true or is there a way with one switch?

Good progress today!!

Thanks.

Regards,

Jeff

Cisco Employee

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Jeff,

1)  I was not able to put in "ip prim" after entering the ip address. 

Hmm... Perhaps this is just a typo in your transcript but it should have been ip pim and not ip prim. In any case, did you also have the ip routing configured?

Do not understand why I was not able to put in "pim" but it did not stop from routing the data.

This is very strange because without proper PIM configuration on interfaces, your switch is not supposed to route multicast streams at all. In other words, it should not have worked. Can you post its exact configuration please? Remove sensitive information but otherwise keep the configuration unmodified.

2)  From my first reply I wanted to have both receivers receive BOTH multicast data at the same time.

     Then through a script program would be able to select which multicast data would be passed through

     a switch port.

I have done some research on whether you can have two VLANS assigned to one port with the idea

in my case, that now both multicast data streams would be at the port to the receiver.  It appears that

this can not be done unless a trunk is used with another device, is this true or is there a way with one switch?

Without a trunk, it is indeed impossible to lead two distinct VLANs to a connected device. However, I am not sure if I understand why you would want to do that. With multicast traffic, it is irrelevant in which VLANs are the sources and receivers placed. If a receiver in any particular VLAN subscribes to two distinct multicast groups, the multicast routing function will make sure that it will receive all subscribed traffic, regardless of the VLAN where the traffic originated and where the receiver is located. You should not be trying to extend two or more VLANs to the receiver because it does not make any sense. Have the receiver in any VLAN you want it to be, because if it subscribes to multiple multicast groups, their traffic will be routed (and replicated) into this VLAN as well.

Once again - unlike IP subnets in unicast routing that are tied to VLANs in an 1:1 fashion, there is no such relation between VLANs and multicast groups in multicast routing.

Best regards,

Peter

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

You have been really good on helping me out.

On the way home I was thinking.  I messed up, it is not routing multicast data.

I simply changed the VLAN associated to the port so of coarse the other multicast data would go to this port!!

Not clear on what you mean by ip routing configued, maybe this is why "ip pim" was not enabled?

This is how you learn.......by getting involved!!  Try again tomorrow.

Thanks.

Regards,

Jeff

Cisco Employee

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Jeff,

Not clear on what you mean by ip routing configued

I apologize. It is also necessary to enter the ip routing global configuration command to actually make the switch activate the routing functions. My second example would therefore look as follows:

ip routing
ip multicast-routing ! or ip multicast-routing distributed - depends on your switch platform ! interface FastEthernet0/1 ! Multicast source is connected here switchport mode access switchport access vlan X interface FastEthernet0/2 ! Another multicast source is connected here switchport mode access switchport access vlan X interface FastEthernet0/3 ! Multicast receiver is connected here switchport mode access switchport access vlan Y ! interface FastEthernet0/4 ! Another multicast receiver is connected here switchport mode access switchport access vlan Y ! interface Vlan X ip address 192.0.2.1 255.255.255.128 ip pim dense-mode ! interface Vlan Y ip address 192.0.2.129 255.255.255.128 ip pim dense-mode

Afterwards, if the ip pim dense-mode command is still not accepted on interface Vlan then please post a snapshot of your screen that shows how exactly the switch complains about the command.

I also kindly ask you to post the entire configuration of your switch in its current form (just please remove the passwords and other sensitive information but otherwise please do not remove any line from the configuration - anything might be important at this point).

Best regards,

Peter

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

Here are the two snap shots; show config and a point where pim is not enabled.

Thanks.

Regards,

Jeff

Cisco Employee

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Jeff,

This is strange - it appears as if the switch did not currently support the PIM, or had a reason not to allow you to configure it.

Can you please post the complete output of these commands?

show version

show license feature

show license all

show sdm prefer

show ip route

show ip mroute

show ip pim interface

Thank you!

Best regards,

Peter

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

Here is what you requested.  To let you know I started from scratch and ran through the Setup Program

and loaded in the configuration steps.  Still have the same issue with PIM.  The files are after I repeated the

whole process.  Can only send 5 at a time.  Next post has the rest.

Thanks.

Regards,

Jeff

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

Here are the other two.

Regards,

Jeff

Cisco Employee

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Jeff,

Okay, I see the problem. Full IP multicast routing on your switch is available only with activated IPSERVICES license. Currently, you are running the IPBASE only. Do you have an option of upgrading to IPSERVICES for your device?

You can also try to activate the evaluation IPSERVICES license but that one will expire after a number of days. You can do experiments with it but it is not a lasting solution.

Best regards,

Peter

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter,

I received this switch from a IT gentlemen who knows I have an interest in networking. He would

have the authority to upgrade, if this is possible.

In the mean time this has not been a waste of time but has been a learning experience!

For this Peter, thanks!!

Regards,

Jeff

Cisco Employee

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Jeff,

It has been a pleasure for me as well. Please keep me informed about any advance in this issue.

Best regards,

Peter

New Member

Re: Inter-VLAN Multicast IP Routing using a 3560x Switch

Hi Peter

It has been awhile but I finnaly got the 3560x switch updated with the ipservices license to do Inter-VLAN IP Multicast Routing. 
Since you have helped me and have requested that I keep you informed on this matter I will offer the following for your feedback.

Based on what you have provided on this matter I have made an attempt to configure my LAN setup to test this out.  I have provided

two documents: a block diagram of the configuration and the configuration steps entered.

My steps are to take two serial inputs, convert them both to multicast data with ip addresses each of 239.1.1.3 & 239.1.1.4.
The first conversion unit combines the multicast output to one single data stream.  My first hurdle was how to separete the data

stream into separte multicast data and put them in differnet VLANs in the 3560.  Since I have used MVR (Multicast VLAN Registration)

in the past this is what I used.  I do not know at this time on another way.

This worked with 239.1.1.3 in Vlan 5 and 239.1.1.4 in VLAN 10 in the 3560X switch.  Based on what you have provided, I was able to have

both multicast data streams in both VLANs.  This is exaclty what I wanted to be able to achieve in this process; have separte VLANs and

route data between them.  I have verified the path using Wireshark (verifying that I have only a single multicast data entering the 3560 at the

two ports) and with using a decoder device to process the data into a readable format and display it on a terminal. The readable format included

both the original serial input messages!! 

I have questions, but first one did I do this right and did I achieve on what I am trying to do with VALNs and routing?

Thanks for any help and comments!

Regards,

Jeff

3116
Views
0
Helpful
14
Replies
CreatePlease login to create content