Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

Hi,

I need pointers in using one of my Cisco router as an inter VLAN router routing between VLAN's on HP Procurve Switch. Any documentation would really help

6 REPLIES
Hall of Fame Super Blue

Re: Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

Which router model ?

New Member

Re: Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

1760 is the current router employed at the remote site but i got a spare 1841 and a 2600

Hall of Fame Super Blue

Re: Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

Okay, you can use routing-on-a-stick. Basically you configure the port on the Procurve that the router connects to as a trunk and then you configure the subinterfaces for the vlans on the router.

Have a look at this link which gives you a basic config to get you started -

http://www.tech-recipes.com/rx/1853/Cisco_switch_802_1q_trunk_to_router_on_a_stick/

Jon

New Member

Re: Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

Thanks for your reply. Link helps. Do you have any cisco documentation on inter vlan routing between Cisco and other brand switch - in my case Cisco and HP Procurve switches

New Member

Re: Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

Finally figure this out. On the HP switch port where the router is connected I have to untagged the management VLAN and tagged the other VLAN's.

Thank you all

New Member

Re: Inter VLAN Rotuing - Cisco Router and HP Procurve Switch

For those who works with cisco and HP this is how I did it:

Here is what I did it:

Cisco Router

------------

interface FastEthernet0/0

description MMGNT

ip address 192.168.11.1 255.255.255.0

ip helper-address 192.168.10.3

ip nbar protocol-discovery

ip route-cache flow

duplex auto

speed auto

!

interface FastEthernet0/0.1

description SRV-PRT-CLNT

encapsulation dot1Q 2

ip address 192.168.10.253 255.255.255.0

!

interface FastEthernet0/0.2

description VoIP

encapsulation dot1Q 3

ip address 192.168.62.1 255.255.255.0

ip helper-address 192.168.10.3

HP 2510 Switch

--------------

Running configuration:

; J9019A Configuration Editor; Created on release #Q.11.07

hostname "CETC-OFFICE"

interface 25

speed-duplex 1000-full

exit

ip default-gateway 192.168.11.1

snmp-server community "public" Unrestricted

vlan 1

name "MMGNT"

untagged 24

ip address 192.168.11.3 255.255.255.0

tagged 25-26

no untagged 1-23

exit

vlan 2

name "SRV-PRT-CLNT"

untagged 1-23

no ip address

tagged 24-26

exit

vlan 3

name "VoIP"

no ip address

tagged 24-26

voice

exit

management-vlan 1

7152
Views
3
Helpful
6
Replies