Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inter VLAN Routing and VTP between 3750 series and 3750Gseries

Hi All,

I have 5 switches on LAN side configs are attached connected with router then the WAN, 4switches are stacked and 5th switch is not part of stack because of no space.

4 stack switch say switch1 are CISCO 3570 series 12.1 version and 5th switch is CISCO 3570Gseries ver 12.2

switches are in 1 default VLAN connected with the router . router have MPLS cloude

I write the proposed configs below, could you please check if I am missing something here

IP for the 4 stacked switches: 10.6.1.10

IP for the non stack switch: 10.6.1.11

Propose VLAN Configurations on CISCO Switches:

VTP and Encapsulation Configuration

StackSwitch1#

Vtp mode server

Vtp domain abcd

interface FastEthernetx/x/x

switchport mode trunk

switchport trunk encapsulation dot1q

end

Switch2#

Vtp mode client

Vtp domain abcd

interface GigabitEthernetx/x/x

switchport mode trunk

switchport trunk encapsulation dot1q

--------------------------------------------

To Create VLANs

#Vlan database

#vlan 62 name ICT

#vlan 63 name Voice

#vlan 64 name VC

#vlan 65 name Printers

--------------------------------------------

Assigning IP Address on VLANs

int vlan 62

Description *** Users***

Ip address 10.6.2.1 255.255.255.0

No shut

Ip helper-address 10.1.1.50, 10.1.1.51, 10.1.1.56

int vlan 63

Description *** Voice ***

Ip address 10.6.3.1 255.255.255.0

No shut

Ip helper-address 10.1.1.50, 10.1.1.51, 10.1.1.56

int vlan 64

Description *** Video Conferencing***

Ip address 10.6.4.1 255.255.255.0

No shut

Ip helper-address 10.1.1.50, 10.1.1.51, 10.1.1.56

int vlan 65

Description *** Printers***

Ip address 10.6.5.1 255.255.255.0

No shut

Ip helper-address 10.1.1.50, 10.1.1.51, 10.1.1.56

--------------------------------------------

Configuration on Ports for VLAN 62

interface FastEthernetx/x/x

switchport mode access

switchport access vlan 62

--------------------------------------------

Configuration on Ports for VLAN 63

interface FastEthernetx/x/x

switchport mode access

switchport access vlan 63

--------------------------------------------

Configuration on Ports for VLAN 64

interface FastEthernetx/x/x

switchport mode access

switchport access vlan 64

------------------------------------------

Configuration on Ports for VLAN 65

interface FastEthernetx/x/x

switchport mode access

switchport access vlan 65

--------------------------------------------

IP route , default gateway and Inter VLAN routing

Ip routing

ip default-gateway 10.6.1.1

ip classless

ip route 0.0.0.0 0.0.0.0 10.6.1.1

no ip http server

and then Routes in the router for new subnets

Questions1 : is the config ok?

2- do I need to do any thing specific for 3750 fast ethernet and Gagbit ethernet trunks point of view or VLAN point of view

3- ip helper address command will take 3 ips for 3 dhcp servers or not?

4- If you see the config switch 5 is showing interface like gagabit interface 5/0/1 which is not part of stack any idea why?

Please advise , your help and support will be highly appreciated

Config for switch 2

Switch2#sh run

Building configuration...

Current configuration : 2496 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname LeedsSwitch2

!

enable secret 5 .

!

no aaa new-model

clock summer-time UTC recurring last Sun Mar 1:00 last Sun Oct 2:00

switch 5 provision ws-c3750g-48ts

system mtu routing 1500

ip subnet-zero

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

vlan internal allocation policy ascending

interface GigabitEthernet5/0/1

interface GigabitEthernet5/0/2

interface GigabitEthernet5/0/3

interface GigabitEthernet5/0/4

!..

....

interface GigabitEthernet5/0/52

interface Vlan1

ip address 10.6.1.11 255.255.255.0

ip default-gateway 10.6.1.1

ip classless

ip http server

7 REPLIES
Hall of Fame Super Silver

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Hello Sohail,

some details are to be refined:

inter-vlan routing requires you to enable

ip routing

ip default-gateway is not needed when ip routing is enabled

ip route 0.0.0.0 0.0.0.0 10.6.1.1

is fine.

second switch may be configured as VTP server too for redundancy.

if the switch is standalone it should show its ports as 1/0/x.

have you connected it to the stack for some time?

you may need some action to have the ports numbered normally

Hope to help

Giuseppe

New Member

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Hi Giuseppe,

Thansk for your reply, and much appreciate your help..you're a start and always help me..

yes switch2 was part of stack ages ago, but its a standalone now and still showing Gagetherx/x/x, can I resolve this issue?

Can I make switch 1 as a vtp server instead of switch 2?

any idea about my other questions?

1- is rest of the config OK?

2- do I need to do any thing specific for 3750 fast ethernet and Gagbit ethernet trunks point of view or VLAN point of view or normal config will work ???

3- ip helper address command will take 3 ips for 3 dhcp servers or not?

Please could you answer all the questions if possibel please.?

Hall of Fame Super Silver

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Hello Sohail,

3) you need three distinct lines for helper address one for each server

or you can use the directed broadcast if the three servers are in the same IP subnet

1) yes

2) nothing special is needed I think unless you want to do an etherchannel for connecting switch2 to two ports in two different stack members.

this can be seen as a meaningful improvement

I would suggest LACP bundles

channel-group x mode active

all member links have to be configured in the same way.

about VTP: you can configure BOTH as VTP servers

about numbering of interfaces I will look

something like

switch member 1

could work

(to be checked)

Hope to help

Giuseppe

New Member

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Hi Giuseppe,

Thank You so much for your support, I am almost there now to digest everything you suggest, can you give me favor please, DHCP servers are in same subnet can you tell me what will be the command for the the directed broadcast please,

I'll configure both switches as a vtp server, and for the switch as per my understanding I only need to do 2 things:

vtp mode server

int gint f0/0/0

switchport mode trunk

switchport trunk encap dot1q

and that's it ..I am done (I hope)??

finally last question: in switch2's config

spanning-tree mode pvst

spanning-tree extend system-id

vlan internal allocation policy ascending

is it something I need to look at??will it not give me any problem?

I know i need lots of study but guys like you always help people like us when needed...

Regards

Jag

Hall of Fame Super Silver

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Hello Jag,

if the subnet is 10.10.10./24 the directed broadcast is 10.10.10.255

it is the last address in subnet that with all 1s in the host part.

>> spanning-tree mode pvst

spanning-tree extend system-id

vlan internal allocation policy ascending

these should be defaults

spanning-tree extend system-id:

causes STP bridge id to be made of:

base priority + Vlan#

the stack may have an older IOS where this is not enabled

Hope to help

Giuseppe

New Member

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Thank you soo much Giuseppe,

This all make sense now. God Bless you.

I might nudge you again if I find any diffculty, :-)

Thanks Again.

regards

New Member

Re: Inter VLAN Routing and VTP between 3750 series and 3750Gseri

Hi Giuseppe,

How are you, further to our discussion I am having dificuties and I thought to nudge you again for help.

I am attaching my current and proposed diagram for new VLANs, which we agreed. But our service provider is not agree with this, as you see the diagram,  they are proposing to create a link between leeds router which is currently 10.6.1.0/24 to 172.16.2.1/30 where 172.16.2.1 will be assign on router interface and 172.16.2.2 on switch intrface, delete routes for the onsite firewall from the router and place these routes in the 3750 switch which is currently working on default vlan with IP 10.6.1.10.

As per Service Provider we cannot add routes in the router for the MPLS or i actually missunderstand what he was saying and trying to convince me to add all routes in the switch.

I was thinking is it a good practise to do this as they are saying. or force them to add routes for new vlans on the mpls cloude.

is this all making any sense to you?

if yes then please could you give me any example?..if we agreed to service provider...please include voice traffic also in the scenario..

1881
Views
0
Helpful
7
Replies