Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inter VLAN Routing confusion

***Disclaimer*** I am studying for my CCENT and consider myself a complete novice. I have no idea what I'm doing but really want to figure this out. I hope that my excitement overcomes my incompetence. ***Disclaimer***

That being said, I have a cable modem that I plug a NetGear WNDR3700 Wireless Router into. I plugged a Catalyst 3560 8-port switch into that and recently got a used 2611 Router from a friend. I live with roomates & I don't want to bring down the entire house so I want to see if I can put the router on it's own VLAN from the switch in order to not cause a disruption in service. I configured VLANs on Switch port 1 (VLAN10) & 2 (VLAN20) and am trying to configure intervlan rounting between them. I have a maintenance vlan (VLAN1) for using Putty (Telnet) to get into the switch that is on 192.168.1.98. I have assigned IP Addresses to the VLANs (VLAN10 192.168.2.1) (VLAN20 192.168.3.1) but I do not know how to get them to "speak" to each other in order for both of them to communicate / route.

What I would like to do is plug the 2611 Router into 1 of the VLANs for testing purposes and my main PC into the other VLAN. How do I do that? I have included my running-config & VLAN info if that helps.

RUNNING CONFIG:

Current configuration : 1198 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname catalyst3560

!

enable secret 5 $1$krHA$********6isz0uJy.

enable password m******3

!

no aaa new-model

clock timezone UTC -5

clock summer-time UTC recurring

system mtu routing 1500

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface GigabitEthernet0/1

!

interface Vlan1

ip address 192.168.1.98 255.255.255.0

!

interface Vlan10

ip address 192.168.2.1 255.255.255.0

!

interface Vlan20

ip address 192.168.3.1 255.255.255.0

!

ip default-gateway 192.168.1.1

ip classless

ip http server

!

!

control-plane

!

!

line con 0

line vty 0 4

password m*******3

login

length 0

line vty 5 15

password m*******3

login

!

end

VLAN INFO:

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Gi0/1
10 home-external active Fa0/1
20 home-router2611 active Fa0/2
99 VLAN0099 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
99 enet 100099 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------

I really hope someone will please help me, I am really excited to see if this can work so I can start my Routing section for the CCENT. Thank you so much in advance, I really appreaciate any help that can be given.

Thank you,

Mark

1 REPLY

Re: Inter VLAN Routing confusion

Plug the router into a port in VLAN 1.

On the router put in the following commands.

Interface FastEthernet 0/0
IP address 192.168.1.97 255.255.255.0

IP route 0.0.0.0 0.0.0.0 192.168.1.98

This will make the router manageable from any of the networks on the 3560.

You will still need to setup the router to accept telnet or ssh and configure an enable secret.

Sent from Cisco Technical Support iPhone App

248
Views
0
Helpful
1
Replies
CreatePlease login to create content