Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Help!!!

Hi all,

Just configured a 3750x switch as a DHCP server for some vlans and even though the ip routing is enabled, I am unable to route between vlans.

Note that the 3750x serves as a core switch that connects through trunking to 2960s accesss switches. VTP v3 is enabled, as well as VTP pruning, all SVIs configured. DHCP gives the respective SVI as gateway for the PCs. The computers connect through IP phones so the ports on the 2960S are on multi-vlan access mode.

I am wondering why I am unable to route between my vlans as I can see all subnets on respective SVIs in the routing table of the switch. I also used the default gateway comand on the 2960S switches so they are able to ping all the SVIs but the PCs on the access ports are not able to do the same and possibly exchange information with each other on different networks.

Thanks in advance for your help.

Regards,

Igor

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Inter-vlan routing not working on the C3750X Layer 3 Switch.

Have you run the debug ip icmp command on the 3750-X, as per Karsten's suggestion yesterday? Depending upon the situation, it might be best to ensure that you only send output to your log, not the command line interface. Setup the debug and then jump onto one of the clients and run a ping to an SVI on the 3750-X. If the 3750-X receives the ICMP requests, then you'll see them in the log (one for each echo request.)

Testing the other way can be done by running wireshark on a client. Then jump onto the 3750-X and source a Ping from another network (either the VLAN ID or SVI IP address): -

ping x.x.x.x source vlan xx

ping x.x.x.x source x.x.x.x

I would also connect a client machine directly to the switch, in case the problem is related to the IP phones. Amend the switchport config accordingly.

29 REPLIES
VIP Purple

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Can you reach the default-gateway address from the PCs?

If not, are all needed VLANs allowed on the trunk? Are the VLANs really availabe on the Access-switch (or is VTP really working)?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Thanks for your answer,

Yes the PCs are able to ping their respective default gateways.

for now all VLANs are allowed on the trunk, as I am receiving all of them through VTP v3 on the access switches.

The access switches are able to ping all SVIs but the devices connected to them are not. Only their default gateways.

VIP Purple

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

If you run a "debug ip icmp" on the 3750X and ping a IP of the switch that is not the DG of the PC (pinging from the PC), do you see any output?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

do traceroute from PC to IP. does this reach your default gateway?

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

No please, the traceroute dies at the default gateway.

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

When I ping my default Gateway I see the debuging packcets but when I ping an external network, nothing shows.

VIP Purple

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Have you double-checked the IP-settings that the PC learns? Escpecially that there is no typo in the Default-Gateway?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
VIP Purple

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

There is also no output if you ping 192.168.10.254 from the PC?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Can you share route print from PC ? I am suspecting subnet mask configured on your system

Silver

Re: Inter-vlan routing not working on the C3750X Layer 3 Switch.

I know you can ping the local default gateway from each client machine, but has DHCP correctly learned a default gateway address?

Any ACLs configured?

Any permenant routes configured on the client machines that might be preferred over the DHCP-learned default route?

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

I have not configured any route yet, nor any access lists. I just uploaded the configuration on the core switch to the discussion. If anyone spot an error, I will be so pleased.

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

The configuration is as follow:

Current configuration : 5284 bytes

!

! Last configuration change at 00:50:41 UTC Mon Mar 1 1993

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxxx

!

boot-start-marker

boot-end-marker

!

!

!

username admin privilege 15 password 7 xxxx

no aaa new-model

switch 1 provision ws-c3750x-24

system mtu routing 1500

ip routing

!

ip dhcp excluded-address 192.168.30.1 192.168.30.50

ip dhcp excluded-address 192.168.30.254

ip dhcp excluded-address 192.168.40.1 192.168.40.50

ip dhcp excluded-address 192.168.40.254

!

ip dhcp pool DATA

   network 192.168.30.0 255.255.255.0

   default-router 192.168.30.254

   domain-name xxxx

   dns-server 4.2.2.2

!

ip dhcp pool PHONE

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.254

   domain-name xxxx

   dns-server 4.2.2.2

!

!

ip domain-name xxxx

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

!

interface GigabitEthernet1/0/1

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/2

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/3

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/4

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/5

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/6

description ### CONNECTIONS TO SERVER LAN PORTS ###

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/7

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/8

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/9

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/10

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/11

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/12

description ### CONNECTION TO STORAGE AND SERVER iSCSI PORTS ###

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet1/0/13

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/14

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/15

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/16

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/17

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/18

description ### DOWNLINK TO ACCESS SWITCHES ###

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

description ### UPLINK TO INTERNET ROUTER ###

switchport access vlan 90

switchport mode access

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface TenGigabitEthernet1/1/1

!

interface TenGigabitEthernet1/1/2

!

interface Vlan1

no ip address

!

interface Vlan10

description ### FOR SERVER LAN DATA TRAFFIC ###

ip address 192.168.10.254 255.255.255.0

!

interface Vlan20

description ### FOR iSCSI SAN TRAFFIC COMMUNICATIONS ###

ip address 192.168.20.254 255.255.255.0

!

interface Vlan30

description ### FOR END-USER WIRED LAN TRAFFIC ###

ip address 192.168.30.254 255.255.255.0

!

interface Vlan40

description ### FOR IP TELEPHONY TRAFFIC ###

ip address 192.168.40.254 255.255.255.0

!

interface Vlan50

description ### FOR DMZ SERVER TRAFFIC ###

ip address 192.168.50.254 255.255.255.0

!

interface Vlan60

description ### FOR IN-BAND MANAGEMENT TRAFFIC ###

ip address 192.168.60.254 255.255.255.0

!

interface Vlan90

description ### UPLINK FROM CORE SWITCH TO INTERNET ROUTER ###

ip address 192.168.90.254 255.255.255.0

!

!

ip http server

ip http secure-server

!

!

logging esm config

!

!

!

line con 0

logging synchronous

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

end

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

I am begining to wonder if there is not a default command somewhere that needs to be changed or soemthing of that sort that is specific to 3750x switches.

Cisco Employee

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Hi,

Can we try removing the command

system mtu routing 1500

and verify

Regards

Partha

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Thanks for your reply but:

This command from what I checked is not concerned by SVI interfaces and also affect only 10/100 interfaces and I am using gigabit interfaces. It was configured  int the device by default and I read that 3750x switches find it difficult to route packet that exceed the MTU.

https://supportforums.cisco.com/thread/2067727

Please can someone confirm that removing the command

system mtu routing 1500

can solve my issue???

Thanks.

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Can you post the output of 'show ver' and 'show sdm prefer' ?  It sounds almost like you have a 3750X with the LANBASE featureset (which IIRC doesn't support IP routing).

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Hi Reuben

Please here are the show commands you requuested.

VIP Purple

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

So it's IPServices with the default-template. That really should work with your routing-needs.

Can you please answer the following question with "debug ip icmp" enabled on the switch?

There is also no output if you ping 192.168.10.254 from the PC?

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Update on the issue:

I connected a router to a port of the 3750x, and from the pc on the access switches, am able to ping the SVI of the vlan for the router but am not able to ping the router itself. Even though the core switch itself is able to ping the router.

New Member

Elom, 

Elom, 

Do you just have one 3750 and one 2960 router or one 3750 connecting to several 2960 routers ? If its of one single 3750 router then is that 3750 connected through one physical link connection to 2960 router ? please share the Network topology for better understanding

Purple

Re: Inter-vlan routing not working on the C3750X Layer 3 Switch.

    So  the pc's are pulling an address in the correct subnet with the correct gateway ?  Little unclear from previous posts.  Also any host ports should have portfast turned on .  Do a show vlan and make sure all vlans are active and the ports show assigned into the correct ports.  Do a ipconfig on the pc's and make sure addresses on devices look correct .  Any pc devices you are trying to ping make sure all windows firewalls are "off" .  Besides that , the config looks ok and see no reason it shouldn't work unless it's an issue with the phones themselves . 

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Thanks for your response.

The PCs are receiving proper configurationm I doubled checked, and firewall too are disabled as I am able to ping the PCs from the 3750x switch. There is no phone currently installed on the ports at the access switch level. The PCs are directly plugged in. Also portfast was enabled by default on my switches so am good there too. All SVIs are showing UP UP when I do a "show ip interface brief".

Me too I am wondering why it is still not working.

I need a CCIE here.

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

Also have you created the VLANs in the switch itself?  I'm not referring to the Layer 3 interfaces but the actual VLANS in the vlan database.  These are missing from your switch config (I guess it's possible your switch has populated the vlan database via VTP though).

Please post "show vlan" output as this will confirm this.

We should be able to solve this without a CCIE, this is CCNA level stuff ;-)

New Member

Inter-vlan routing not working on the C3750X Layer 3 Switch. Hel

@Reuben I did a show vlan and am able to see the vlans created on the core switch and even the ports that are assigned to them. I was suprised to see that they do not show in the running config.

I am guessing... could it be the fact that I am using vtp v3, as i had to go to enable mode and do "vtp primary vlan" command before I was able to create the vlans.

I have passed two of the CCNP exams myself already and I don't remember anything in my reading that tells me of such a problem... even in the TSOOT book that I am currently reading.

This issue is making me feel as if am not a good network engineer.

Silver

Re: Inter-vlan routing not working on the C3750X Layer 3 Switch.

Have you run the debug ip icmp command on the 3750-X, as per Karsten's suggestion yesterday? Depending upon the situation, it might be best to ensure that you only send output to your log, not the command line interface. Setup the debug and then jump onto one of the clients and run a ping to an SVI on the 3750-X. If the 3750-X receives the ICMP requests, then you'll see them in the log (one for each echo request.)

Testing the other way can be done by running wireshark on a client. Then jump onto the 3750-X and source a Ping from another network (either the VLAN ID or SVI IP address): -

ping x.x.x.x source vlan xx

ping x.x.x.x source x.x.x.x

I would also connect a client machine directly to the switch, in case the problem is related to the IP phones. Amend the switchport config accordingly.

New Member

Re: Inter-vlan routing not working on the C3750X Layer 3 Switch.

Just solved the issue. Steps followed:

- do a no ip routing
- save the config
- backup config to flash
- erase startup config
- reload the 3750x switch
- copy config from flash to run
- enter command ip routing

And here I was with everything running smoothly. Thanks all for all your help. Apparently there was a glitch somewhere. Gotta go finish the ACLs and NAT.

Regards,
IGOR.

Sent from Cisco Technical Support iPad App

New Member

hi 

hi 

sorry my english is not very good

i have the same problem with my C3850  , so if we put static route between vlans it will work ??

and if you can assist me with some ACLs and NAT configuration

Thanks you 

Christopher 

New Member

share output for below

share output for below command

sh ver

New Member

sh_ver.png

6800
Views
21
Helpful
29
Replies