Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Inter VLAN routing on Catalyst 3750

I am new to Vlans so any help is greatly appreciated. I am wondering how I can route between two vlans on the same switch. I created a vlan (500) and assigned two ports to it. The vlan 500 ip address is 10.0.101.2/24. The vlan 1 ip address is 192.168.0.30/24. When I am consoled into the switch I can't ping the vlan 500 interface. So I obviously I can't ping the 10.0.101.2 interface from the 192.168.0.0/24 subnet. I plugged a computer directly into the switch and was able to ping the vlan1 interface(192.168.0.30). I also added a route to the computer to go 192.168.0.30 if it wants to get the 10.0.101.0 network. I've tried to add routes on the switch to each subnet but it didn't seem to work.

Here is what my config looks like.

interface GigabitEthernet1/0/1

switchport access vlan 500

switchport mode access

!

interface GigabitEthernet1/0/2

switchport access vlan 500

switchport mode access

interface Vlan1

ip address 192.168.0.30 255.255.255.0

!

interface Vlan500

ip address 10.0.101.2 255.255.255.0

I was doing research and was finding different things about trunking, but is that really necessary when the two vlans are on the same switch?

Thanks in advance to any help.

9 REPLIES

Re: Inter VLAN routing on Catalyst 3750

Your configuration looks okay. However, have you enabled routing? Is your IOS EMI model? Execute "ip routing" in configuration mode.

Download this Cisco Catalyst 3750 configuration guide book for 12.2(35)SE http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_guide_book09186a0080763466.html

Here's all the configuration guide for different IOS feature set, pick your IOS trail (SE, SEE, SED, ...) http://www.cisco.com/en/US/products/hw/switches/ps5023/products_installation_and_configuration_guides_list.html

It has everything from stacking, configuring VLAN, STP, QoS, HSRP, Troubleshooting, IPv6, etc...

New Member

Re: Inter VLAN routing on Catalyst 3750

Thanks for the help. Yes I do have IP routing enabled. Here is something from the config file..

no aaa new-model

switch 1 provision ws-c3750g-24ts

ip subnet-zero

ip routing

Thanks again.

Green

Re: Inter VLAN routing on Catalyst 3750

You dont need to add routes to the switch as they are directly connected.

Re: Inter VLAN routing on Catalyst 3750

don't forget "ip classless" as well and make sure vlan interfaces is up by executing "no shut" in the vlan interface config mode, vlan interfaces are shutdown by default :)

New Member

Re: Inter VLAN routing on Catalyst 3750

Confirm if int vlan 500 is up(sh int vlan 500),if not do a no shut on the interface,then plug ur machine on to interface GigabitEthernet1/0/1(a member of vlan 500) ,give it an ip like 10.0.101.2 /24 then give it a default gateway of 10.0.101.2/24....then get back to me

Cisco Employee

Re: Inter VLAN routing on Catalyst 3750

Please paste the output of " show vlan " and " "show interface vlan 500".

-amit singh

Purple

Re: Inter VLAN routing on Catalyst 3750

Verify you created your layer 2 vlans "show vlan" or "show int status" and the ports show assigned to the vlans you want them in .

New Member

Re: Inter VLAN routing on Catalyst 3750

Yes you need a router to route between VLANs.

Router work on Layer 3 of the OSI Model.

Switches work on Layer 2 of the OSI Model.

VLANs seperate broadcast domains (subnets).

You have two options on the router.

1. You can use two ports on the router, one for each subnet.

2. Setup trunking on one of the routers subinterfaces (physical interfaces broken nto into multiple logical interfaces).

New Member

Re: Inter VLAN routing on Catalyst 3750

Things are getting a bit muddy here. The switch that is referenced in the original post is a 3570. The 3570 is an L3 switch meaning it is capable of doing both L2 Switching and L3 Routing (essential and Ethernet router). The 3570 with baseIPServices should support IP routing with STATIC ROUTES and EIRGP-STUB Routing (Receive ONLY updates). If you are using IP Advanced Services image then the unit will support quite a bit more.

We use a lot of these type of L3 switches to accomplish your overall goal which is to route between multiple VLANs.

The basics are as follows;

1. Create your VLANs; Do this using the VLAN database command or VLAN commands from global config mode

2. Assign IP addresses (gateway address's) for each of your networks to their VLAN Interface in interface config moe (ie. interface vlan 100). This give your devices default gateway's through which they can communicate with other devices through routing.

3. do a no shut on each vlan

4. If your just using this one switch assign VLAN's to ports on it. If your using other switches configure your Trunks (Thats another discussion) then make sure you have active clients on the vlans.

5. Enable routing in global config mode.

6. do a "sh ip route" to ensure that your 3570 is seeing the connected networks.

Lots more could go into this but these is the basics. If you go to this link

http://www.staticnat.com/WP/configs/3550/3550-48-emi-vlan/

You will find a sample config of this from a 3550 running EMI. This config is running EIGRP as well as Multicast routing. There are a total of 16 VLANs plus VLAN 1 which is disabled. You will still need to create the vlans in VLAN Database or config mode but overall this should help clear things up.

Good luck.

http://www.staticnat.com

2059
Views
5
Helpful
9
Replies