Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Inter Vlan Routing Problem

Hello,

I do have a strange inter vlan routing problem - or I am only blind to see the mistake!

I do have a router and a switch. The router is doing inter vlan routing and the switch do have a vlan interface I want to reach from the router - or other way round.

### router ###

interface Ethernet0/0

description ** Trunk to SW0 ++

no ip address

full-duplex

!

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.6.1 255.255.255.248

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 10.1.6.9 255.255.255.248

!

interface Ethernet0/0.3

encapsulation dot1Q 3

ip address 10.1.6.17 255.255.255.248

!

interface Ethernet0/0.4

encapsulation dot1Q 4

ip address 10.1.6.26 255.255.255.248

### switch ####

interface FastEthernet0/5

description ** Access to R2 **

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4

switchport mode trunk

speed 10

duplex full

!

The links are all up and the router learns - from the rest of the network - connected to the switch on other interfaces - OSPF updates and creates neighborships.

But a ping to 10.1.6.2 is not working - I do not understand that - actually

The hardware I use is a 3640 Router with 12.4(21) and the switch is a 3550 using 12.2(25)

Thanks for all tipps and your help to figure that out.

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Inter Vlan Routing Problem

Hi,

Trunking is supported on the 3600.  Can you make sure your interface is 10/100?

http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921e4.html

HTH

14 REPLIES
VIP Super Bronze

Inter Vlan Routing Problem

Hi,

But a ping to 10.1.6.2 is not working - I do not understand that - actually

where are you pinging from and where is 10.1.6.2?

The router is 10.1.6.1

HTH

Community Member

Inter Vlan Routing Problem

Hi, sorry, I missed an important part!

The switch also do have a interface. I corrected the config and what I want to do is ping from router to switch or from switch to router.

ping 10.1.6.2 ist not working. also defining a soure interface to ping 10.1.6.2 source eth 0/0.1 is not making any difference.

nevertheless I tried to delete all subinterfaces and set up the ip address 10.1.6.1 directly on the eth 0/0 and ping works.

so why, where is the problem ?! I cannot figure that out.

### router ###

interface Ethernet0/0

description ** Trunk to SW0 ++

no ip address

full-duplex

!

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.6.1 255.255.255.248

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 10.1.6.9 255.255.255.248

!

interface Ethernet0/0.3

encapsulation dot1Q 3

ip address 10.1.6.17 255.255.255.248

!

interface Ethernet0/0.4

encapsulation dot1Q 4

ip address 10.1.6.26 255.255.255.248

### switch ####

interface FastEthernet0/5

description ** Access to R2 **

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4

switchport mode trunk

speed 10

duplex full

!

interface Vlan1

ip address 10.1.6.2 255.255.255.248

end

Inter Vlan Routing Problem

Hi,

Check the both end physical interfaces settings like speed and duplex.
What is the VLAN state is it up and up?
Did you assign that vlan to any port and check?


Please rate the helpfull posts.
Regards,
Naidu.

VIP Super Bronze

Inter Vlan Routing Problem

can you define a default-gateway on your switch?

ip default-gatewat 10.1.6.1 (routers interface)

If this does not help, can you remove

switchport trunk allowed vlan 1-4 from the switch and test again (removing this will all vlans)

Are all the layer-2 vlans (vlan 2,3,4) have been defined on the switch?

provide sh run from the switch

HTH

Inter Vlan Routing Problem

Hello,

    Please post "show version". Seems you need atleast "IP PLUS" for 802.1Q.

HTH,

Toshi

Community Member

Inter Vlan Routing Problem

hi,

i have set the default gateway, but if I do ping within the same subnet - that means from 10.1.6.1 to 10.1.6.2 there is no need for the ip default gateway on the switch.

also tried to allow all vlans - changed nothing - also do not understand why this should change something.

nevertheless - attached the sh. version, but if I can configure dot1q - it should be supported isn't it ?

Cisco IOS Software, 3600 Software (C3640-IK9S-M), Version 12.4(21), RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 10-Jul-08 04:59 by prod_rel_team

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

R2 uptime is 3 weeks, 4 days, 22 hours, 51 minutes

System returned to ROM by reload

System image file is "flash:c3640-ik9s-mz.124-21.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 3640 (R4700) processor (revision 0x00) with 118784K/12288K bytes of memory.

Processor board ID 19702460

R4700 CPU at 100MHz, Implementation 33, Rev 1.0

2 Ethernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

thanks

Purple

Inter Vlan Routing Problem

Hi,

ethernet interfaces and Dot1q shouldn't be working according to Cisco Doc and it surely is version dependant like answered before and also hardware dependent. I couldn't make it work on a 2600 serie but succeeded on a 3660 but on GNS3.

Regards.

Alain

Don't forget to rate helpful posts.
Community Member

Inter Vlan Routing Problem

Hi,

but it is a 3600 series device I use (which are properly good routers supporting most of the features needed) and a newer 3550 switch.

also dot1q is a basic feature I would assume, so there must be something else making problems - but I havent found it yet.

cheers

Purple

Inter Vlan Routing Problem

Hi,

the problem is surely ethernet interface because even with the correct IOS it can be problematic unlike on Fastethernet or Gigabit.

Have you tried putting the vlan 1 under the interface and not under a subinterface ?

Regards.

Alain.

Don't forget to rate helpful posts.
VIP Super Bronze

Inter Vlan Routing Problem

Hi,

Trunking is supported on the 3600.  Can you make sure your interface is 10/100?

http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921e4.html

HTH

Community Member

Inter Vlan Routing Problem

Hi,

I tried to configere the ip address from subinterface 0.1 onto the physical 0/0 interface and delete all the others - working perfect.

After that I created the first sub interface 0/0.1 and setup the ip address es mentioned - one time with the native statement and one time without the native statement (also changed it on the switch side).

Still no ping possible.

And no - there is now chance to exchange the physical interface from ethernet to fastethernet!

Therefore speed is set to 10 as well es duplex to full manually

Community Member

Inter Vlan Routing Problem

hi,

ok figured it out the

FRU Part Number     NM-2E2W=

interface I do use is not supporting dot1q - that s...

nevertheless - thanks for the great and fast help

cheers

Community Member

Inter Vlan Routing Problem

Hello,

after playing around and reading documentation - I found out that also (despite what cisco says) the NM-2E2W Module within a 3600 router is able to do dot1q.

Only think you have to be aware of is - that the native vlan (whatever vlan it will be) is configured on the ethernet 0/0 (not subinterface) or any other physical interface on the router.

all the other tagged vlans have to be created within a subinterface on the physical - than everything is working fine

therfore despite documentation about the hardware AND recommendation of cisco not to configure the native vlan on the ethernet interface itself - it is working in the way it was donne years in the past and is now considered bad habit (I asume)

Purple

Inter Vlan Routing Problem

Hi,

this is what I had suggested above:

Have you tried putting the vlan 1 under the interface and not under a subinterface ?

Regards.

Alain

Don't forget to rate helpful posts.
1531
Views
0
Helpful
14
Replies
CreatePlease to create content