Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

inter vlan routing svi interfaces

hello,

i have the following setup
1 router connected to two access switches.

to configure inter vlan routing, can i do the following ?

1- configure svi on the router for each vlan ( int vlan 1,etc..)
2- configure links between the router and switches as trunks

 

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Does your router support SVIs

Does your router support SVIs ?  If yes, just connect  your switches via trunks to EHWIC 8. And configure IPs and IP helpers on SVI..

12 REPLIES
VIP Super Bronze

Hi,On the router, you usally

Hi,

On the router, you usally can't configure SVIs, unless it is a switch/route combined e.g cisco 3560, 3750, etc..

If your device is just router and you have multiple vlans on each switch, then you need to configure the router with sub-interfaces for each vlan and also trunk the connection from each switch to the router.  If each of your access switches only carry one vlan, then you can simply have a access port form each switch to the router and use a regular interface and no need for Sub-interfaces.

here is an example of sub-interface config on the router for vlan 15

 

interface gi0/1.15
 description data VLAN 15
 encapsulation dot1Q 15
 ip address 192.168.15.1 255.255.255.0

 

and here is an examle if your switches carry only one vlan (15)

interface gi0/1
description data VLAN 15
ip address 192.168.15.1 255.255.255.0

 

HTH

New Member

I cant configure int vlan 2

I cant configure int vlan 2 for example with an ip address under a subinterface and int vlan 2 with an ip in the same subnet as the first under another subinter.
New Member

Hi Asus, You should configure

Hi Asus,

 You should configure  different VLANs per subinterface. Could we see yours topology, how the switches are connected to the router ? And how VLANs are assigned on the switches?

If you have etc two same VLANS configured on two switches the topology should be something like this. You cannot use two physical interfaces  configured with subinterfaces for same VLAN on the router.
 
        trunk          trunk
[ R ] -----> [SW1]----->[SW2]
             

By the way , what hardware are you using ?

New Member

If i decide to configure

If i decide to configure different vlans on the switches ( vlan 1-2 on sw 1 and rest on switch 2 ), what about the mgt vlan and default gateway ? I want the router tobe the default gateway and and dhcp helper for each vlan how do i do this Can i configure int vlan 10 on all switches with ips in the same subnet?
New Member

CISCO 3560 supports inter

CISCO 3560 supports inter vlan routing you do no need a router to do this.. Just connect them both via trunk, configure an HSRP on the switches and connect to the router via L3 links. If you want use a router as a DHPC server, you should configure an ip helper under each SVI on the switches..

Example of SVI  & HSRP cfg :

 

On SW1

Switch(config)# ip route
Switch(config)#interface Vlan10
Switch(config-if)#ip address x.x.x.x +mask
Switch(config-if)#ip helper-address x.x.x.x
Swtich(config-if)# standby10 ip [ virtual IP for VLAN10]
Swtich(config-if)# standby 10 priority 105
Swtich(config-if)# standby 10 preempt
Switch(config-if)#no shutdown

Switch(config)#interface Vlan20
Switch(config-if)#ip address y.y.y.y + mask
Switch(config-if)#ip helper-address x.x.x.x
Swtich(config-if)# standby 20 ip [ virtual IP for VLAN20]
Switch(config-if)#no shutdown

on SW2

Switch(config)# ip route
Switch(config)#interface Vlan10
Switch(config-if)#ip address z.z.z.z +mask
Switch(config-if)#ip helper-address x.x.x.x
Swtich(config-if)# standby 10 ip [ virtual IP for VLAN10]
Switch(config-if)#no shutdown

Switch(config)#interface Vlan20
Switch(config-if)#ip address n.n.n.n + mask
Switch(config-if)#ip helper-address x.x.x.x
Swtich(config-if)# standby 20 ip [ virtual IP for VLAN20]
Swtich(config-if)# standby 20 priority 105
Swtich(config-if)# standby 20 preempt
Switch(config-if)#no shutdown


 

New Member

It is a fixed setup so i cant

It is a fixed setup so i cant change it. The switches are only connected to the router . What is the best way with this setup ? also i have EHWIC 8, how the ehwic will help me configure a svi ?
New Member

Does your router support SVIs

Does your router support SVIs ?  If yes, just connect  your switches via trunks to EHWIC 8. And configure IPs and IP helpers on SVI..

New Member

thabk you very much, i guess

thabk you very much, i guess i should ve mentioned i have ehwic. One laat request, could you confirm the following ? On the switches i will configure the vlans and int vlan mgt and default gateway pointing to the ip of the mgt vlan
New Member

Yes, default gateway is

Yes, default gateway is needed only for management purposes on L2 switches.

291
Views
0
Helpful
12
Replies
This widget could not be displayed.