Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inter VLAN Routing with MUltiple Routers

In a typical case if you have 3or 4 swicthes and one router then you can do Inter VLAN routing through  sub interfaces i-e int fao/1.1 . But what if you have 6or 8 swicthes and 3 or 4 routers then how do you do INter VLAN Routing.                   

2 REPLIES
Hall of Fame Super Silver

Inter VLAN Routing with MUltiple Routers

To perform inter VLAN routing it is important to have at least one layer 3 router (or a layer 3 switch acting as a router). When you have more than one router then you have redundancy. How you would set them up would depend somewhat on they physical arrangement, which switches connect to which routers. There are several options you could consider. Perhaps one router routes for a few  VLANs, a second router routes for a few other VLANs, a third router routes for a few other VLANs, and so forth. But if it was my network I would probably have each router do routing for all VLANs. Then you could have some clients use one router as their default gateway while some other clients used another router for their default gateway, etc.

HTH

Rick

New Member

I realize this blog is over

I realize this blog is over four years old, so I'm still searching for solid advice to resolve my questions concerning this particular issue.

My particular scenario is similar to this blog

https://supportforums.cisco.com/discussion/11547731/hsrp-over-intervlan-routing

However, I have already figured out how to get two routers successfully configured using HSRP, and I'm using sub-interfaces gi5/0.10 & gi/0.20 on one router and subif gi2/0.10 & gi2/0.20 on the other for VLANs 10 and 20. All is working beautifully. My DHCP server is leasing the correct IPs for each separate VLAN. Great so far, right...

However, I do not wish to use ROAS exclusively, which only uses one single physical interface. I desire to use sub-interfaces on my gi5/0 and gi6/0 on LAX and gi2/0 and gi3/0 to accomplish FHRP load balancing across four different interfaces using two routers for my two VLANs VLAN10 and VLAN20. Attached is a screen capture of my GNS3 Topolgy and I will paste my config below.

I'm really curious on how to accomplish what I'm thinking in my brain. Thanks so much for All your expertise and assistance with my problem here.
------------------
HSRP ERROR - My Problem
----------
LAX(config-subif)#ip address 10.1.1.4 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

LAX(config-subif)#enc
LAX(config-subif)#encapsulation dot1q
% Incomplete command.

LAX(config-subif)#encapsulation dot1q ?
<1-4094> IEEE 802.1Q VLAN ID

LAX(config-subif)#encapsulation dot1q 10
LAX(config-subif)#ip address 10.1.1.4 255.255.255.0
% 10.1.1.0 overlaps with GigabitEthernet5/0.10
====================================================
My Current Operational Config (Irrelevant Config Output Ommitted)
-----------------------------
=============================
Router 1 Config - LAX
=============================
LAX#sho run
Building configuration...

!
ip dhcp excluded-address 10.1.1.1 10.1.1.99
ip dhcp excluded-address 10.1.1.151 10.1.1.254
ip dhcp excluded-address 10.1.2.1 10.1.2.99
ip dhcp excluded-address 10.1.2.151 10.1.2.254
!
ip dhcp pool VLAN10_IPs
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
dns-server 8.8.8.8 4.2.2.2
!
ip dhcp pool VLAN20_IPs
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
dns-server 8.8.8.8 4.2.2.2
!
!
!
!
!
interface GigabitEthernet4/0
ip address 188.23.163.177 255.255.255.248
ip nat outside
ip virtual-reassembly
negotiation auto
!
interface GigabitEthernet5/0
no ip address
ip nat inside
ip virtual-reassembly
negotiation auto
!
interface GigabitEthernet5/0.10
encapsulation dot1Q 10
ip address 10.1.1.3 255.255.255.0
standby 0 priority 115
standby 0 preempt
standby 1 ip 10.1.1.1
standby 1 priority 115
standby 1 preempt
!
interface GigabitEthernet5/0.20
encapsulation dot1Q 20
ip address 10.1.2.3 255.255.255.0
standby 2 ip 10.1.2.1
standby 2 priority 115
standby 2 preempt
!
interface GigabitEthernet6/0
no ip address
ip nat inside
ip virtual-reassembly
negotiation auto
!
interface GigabitEthernet6/0.10
encapsulation dot1Q 10
!
interface GigabitEthernet6/0.20
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 188.23.163.178
no ip http server
no ip http secure-server
!
!
ip nat pool OUTSIDE_IP 188.23.163.177 188.23.163.177 netmask 255.255.255.248
ip nat inside source list NAT_ADDRESSES pool OUTSIDE_IP overload
!
ip access-list standard NAT_ADDRESSES
permit 10.1.1.0 0.0.0.255
permit 10.1.2.0 0.0.0.255
!
-------------------------------------------
LAX: HSRP (Show) Output
-------------------------------------------
LAX#sho standby
GigabitEthernet5/0.10 - Group 1
State is Active
2 state changes, last state change 07:17:23
Virtual IP address is 10.1.1.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.152 secs
Preemption enabled
Active router is local
Standby router is 10.1.1.2, priority 100 (expires in 9.184 sec)
Priority 115 (configured 115)
Group name is "hsrp-Gi5/0.10-1" (default)
GigabitEthernet5/0.20 - Group 2
State is Active
2 state changes, last state change 07:15:38
Virtual IP address is 10.1.2.1
Active virtual MAC address is 0000.0c07.ac02
Local virtual MAC address is 0000.0c07.ac02 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.408 secs
Preemption enabled
Active router is local
Standby router is 10.1.2.2, priority 100 (expires in 9.088 sec)
Priority 115 (configured 115)
Group name is "hsrp-Gi5/0.20-2" (default)
=====
================================
Router 2 Config - GLBP_RTR
================================
GLBP_RTR#sho run
Building configuration...
!
!
!
!
interface GigabitEthernet2/0
no ip address
negotiation auto
!
interface GigabitEthernet2/0.10
encapsulation dot1Q 10
ip address 10.1.1.2 255.255.255.0
standby 1 ip 10.1.1.1
!
interface GigabitEthernet2/0.20
encapsulation dot1Q 20
ip address 10.1.2.2 255.255.255.0
standby 2 ip 10.1.2.1
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 188.23.163.177
ip route 0.0.0.0 0.0.0.0 10.1.1.1
no ip http server
no ip http secure-server
!
!
-------------------------------------------
GLBP_RTR: HSRP (Show) Output
-------------------------------------------
GLBP_RTR(config)#do sho standby
GigabitEthernet2/0.10 - Group 1
State is Standby
1 state change, last state change 04:43:11
Virtual IP address is 10.1.1.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.048 secs
Preemption disabled
Active router is 10.1.1.3, priority 115 (expires in 10.272 sec)
Standby router is local
Priority 100 (default 100)
Group name is "hsrp-Gi2/0.10-1" (default)
GigabitEthernet2/0.20 - Group 2
State is Standby
1 state change, last state change 04:41:01
Virtual IP address is 10.1.2.1
Active virtual MAC address is 0000.0c07.ac02
Local virtual MAC address is 0000.0c07.ac02 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.392 secs
Preemption disabled
Active router is 10.1.2.3, priority 115 (expires in 9.280 sec)
Standby router is local
Priority 100 (default 100)
Group name is "hsrp-Gi2/0.20-2" (default)
=====

1004
Views
0
Helpful
2
Replies
CreatePlease login to create content