Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Inter-vlan routing

Hey everyone,

I have been messing with GNS trying to figure out router on a stick and ran into some trouble. I can ping from the router acting as the core to any address within every vlan. The problem exists when I try to ping from an ip within lets say an ip in vlan 10 to an ip in vlan 20.

Basically Ive set up 3 different vlans 192.168.10.0/24, 192.168.20.0/24 and 192.168.30.0/24. Withing those three vlans there are 2 "PC's" each with the following addresses : 192.168.10.0/24 (192.168.10.2, and 192.168.10.3), 192.168.20.0/24 (192.168.20.4, and 192.168.20.5), and 192.168.30.0/24 (192.168.30.6, and 192.168.30.57).

Because I do not have switches I've been using a cicso 3660 with a 16esw slot to act as one.

I have set up port f1/0 on the "switch" as a trunking port and also added the vlans to the database. Port f0/0 on the router core is sub interfaced  f0/0.1 for vlan 10, f0/0.2 for vlan 20 and f0/0.3 for vlan 30. I also didnt assign an address to f0/0 but brought it up so it was active.

Could there be something I am doing wrong that is obvious? Ill include my topology and configs for any extra information. I am thinking there may be something wront with my route, due to the fact the router core is conencted to all the vlans.

Please help!

6 REPLIES
Purple

Inter-vlan routing

  Sounds right off the top of my head.  Posting the switch config along with a show vlan might help. Make sure both sides are using the same native vlan . 

New Member

Inter-vlan routing

Thank you for the response! Posted below is the info you asked about.

Config file for 3660 acting as switch:

!

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

switchport mode trunk

!

interface FastEthernet1/1

!

interface FastEthernet1/2

switchport access vlan 10

!

interface FastEthernet1/3

switchport access vlan 10

!

interface FastEthernet1/4

switchport access vlan 20

!

interface FastEthernet1/5

switchport access vlan 20

!

interface FastEthernet1/6

switchport access vlan 30

!

interface FastEthernet1/7

switchport access vlan 30

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

!

no ip http server

no ip http secure-server

ip forward-protocol nd

!

!

!

!

!

!

control-plane

! !
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport mode trunk
!
interface FastEthernet1/1
!
interface FastEthernet1/2
switchport access vlan 10
!
interface FastEthernet1/3
switchport access vlan 10
!
interface FastEthernet1/4
switchport access vlan 20
!
interface FastEthernet1/5
switchport access vlan 20
!
interface FastEthernet1/6
switchport access vlan 30
!
interface FastEthernet1/7
switchport access vlan 30
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!

This a look at my topology.

When I do sh vlans, from enable mode it says no virtual lans configured even though I added them to the vlan database...

hope that helps some.

Inter-vlan routing

Hi,

The problem that ping for intervlan does not work is that you have to add a default route to the "PCs" R2-R7.

For instance you have to add ip route 0.0.0.0 0.0.0.0 192.168.10.1

Or a static route for the subnets that you created

You have only  configured to the R2 PC, but you have to correct the mask.

Hope that helps

Vasilis

Please rate the useful posts

New Member

Inter-vlan routing

Big thanks, that was exactly what the problem was....Been working on this for hours. I appreciate the time everyone took in looking at this for me!:)

Inter-vlan routing

You are welcome.

Continue labing and testing....

Please, feel free to request help for any problem you may face

Inter-vlan routing

Kindly close the thread, if you think your concern is answered, so that other community members

don't have to come to this thread and then find it already to be answered..

327
Views
5
Helpful
6
Replies
CreatePlease to create content