Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Interface hangs/stucks after few hours

Hello everybody.

we're facing a weird issue lately with a Cisco 2821.

An interface stops responding after a few hours.

The only way to bring it 'up' again is:

Hardcode: duplex or speed

or

shutdown -> no shutdown

there are no errors in the "sho interface" and no errors or entries in the log.

FastEthernet0/0/0 is up, line protocol is up

  Hardware is Fast Ethernet, -

  Description: Infopoint

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 22:20:19, output never, output hang never

  Last clearing of "show interface" counters 3d23h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     158377 packets input, 13566230 bytes, 0 no buffer

     Received 20036 broadcasts (3176 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     310913 packets output, 72379459 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     2 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

Any idea why this is happening?

17 REPLIES
Cisco Employee

Interface hangs/stucks after few hours

Hello,

Do you see packet count growing? I refer to these counts:

158377 packets input, 13566230 bytes, 0 no buffer

310913 packets output, 72379459 bytes, 0 underruns

Also see if this commands works for you:

show int fa0/0/0 count detail

Nik

New Member

Interface hangs/stucks after few hours

Hi Nikolay,

yes its growing. Right now its stucks again, but the 2 counters still increase (eventho' its small).

show int fa0/0/0 count detail does not work. i only have:

sho int fa0/0/0 count ?

  broadcast  Show interface broadcast suppression discard counters

  errors     Show interface error counters

  protocol   interface protocol counters

  trunk      Show interface trunk counters

  |          Output modifiers

Interface hangs/stucks after few hours

Hi,

We to faced the same issue before , after chaging the uplink from Fast Ethernet interface to Gigabit Interface the issue is not encountering again.Try this if you have Gigabit interface

Cisco Employee

Interface hangs/stucks after few hours

If the packet counter growing slowly then it is expected to see rate as 0 as you have an average for 5 minutes there and average can be very close to 0 thus rounded up to it.

Do you see any problem due to this interface? Or you just worry of a counter - can you do any packet test (e.g. ping) which will flow through this interface? You can vary packet size and see if you get differencies with a rtae. Other thing is just reducing rate calculation time to 30 sec with "load-interval 30" in interface mode.

Hope this helps,

Nik

New Member

Interface hangs/stucks after few hours

The problem is, that i can't ping the host on this interface anylonger.

what also resolves the problem is, when i unplug the ethernet cable and plug it back in.

i can ping it right away after this.

Interface hangs/stucks after few hours

Hi

is the otherside of the cable managed?

What  says the log ?

Cheers

Patrick

New Member

Interface hangs/stucks after few hours

Hi Patrick,

no host side is not managed.

Unfortunately the log does not say anything about it.

Interface hangs/stucks after few hours

Hi,

Do you have other interfaces , are you able to access other interface.

If you have spare interface please change the interface and observe

New Member

Interface hangs/stucks after few hours

can you please monitor if the CPU and Memory too gets chocked during certain times..?

does this happen to all interfaces or just a single interface?

waiting for the revert !

Regards,

Parvesh

New Member

Interface hangs/stucks after few hours

Hello everybody.

I changed the interface - it did not happend since.

Thanks everybody for the hints and tips.

New Member

Interface hangs/stucks after few hours

Hi, Kakados2000 and everybody else, I'm a network adminstrator in my company, and I have been experiencing the same problem (gigabit Ethernet interface stucks after few hours), with the same cisco router (2821). I tried everything possible (except changing the built-in gigabit ethernet interfaces, of course) but the router keeps having the same problem after 3, or sometimes 5 or even 10 hours. And the only solution is to restart the router through the ON/OFF button or reload through a console session with the router (during that problem, connection through console is OK!) And you said that u solved the problem by changing the interface. You must therefore be my only way out of my router interface-related problem. I would like you to give me details about the pocedure u used to solve your problem. I'll be impatiently waiting for an answer. In the mean time, I'm stuck with restarting the router every 4, 5 or 8 hours, to restore the service.

Thanks

Hall of Fame Super Gold

Interface hangs/stucks after few hours

Think about upgrading the IOS.  This looks like an IOS bug.

New Member

Interface hangs/stucks after few hours

Hi, thanks for answering, I've been watching for some help coming up in this forum. Ok, I already did an upgrade of the IOS. Actually, it was a replacement of the existing IOS with a new one with the same version. What I did, was uploading a copy of the IOS from another faultless 2821 cisco router  (which has been working for months now without being restarted), on a tftp server, then I downloaded the IOS onto the router flash. I deleted the old IOS and booted from the new IOS. I did this because we don't own a SERVICE CONTRACT from cisco, to download a recent IOS from their site.

The following is the output of the "sh vers" command.

ROUTER_TO_SITCOM#sh vers
Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(3i), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 28-Nov-07 21:09 by stshen

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ROUTER_TO_SITCOM uptime is 1 hour, 12 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-ipbase-mz.124-3i.bin"

Cisco 2821 (revision 53.50) with 251904K/10240K bytes of memory.
Processor board ID FCZ125171JK
2 Gigabit Ethernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Notice the "uptime is 1 hour, 12 minutes", this means that I had to restart the router just 1 hour and 12 minutes ago to restore the service. This IOS had caused no problem on the router I uploaded it from. So I doubt it's the IOS-related problem. Anyway I'm open to suggestions. I wish I could know how  kakados2000 "changed the 2 built-in gigabit ethernet interfaces to solve his problem (The exact problem I've been seeking to solve for 1 month now.

PS: The suggestion of buying a new better cisco router to replace the misbhaving one has already been made by me to my Company, but they said I should find out a way to resolve the problem of the existing router. Otherwise, I'll have to keep restarting the router to restore the service until they buy a new router.


Hall of Fame Super Gold

Interface hangs/stucks after few hours

HI Allen,

Are you still getting the same issues?

New Member

Interface hangs/stucks after few hours

Hi Leo, unfortunately yes, I'm still getting the same issues. Matter of fact, the internet just went down because of this problem with the router. I just had to restart it some 10 minutes ago to restore the service.

Hall of Fame Super Gold

Interface hangs/stucks after few hours

Hmmmm ... You wouldn't happen to have a 2960, 3560G or a 3750G nearby would you?

New Member

Interface hangs/stucks after few hours

lol, Nope. Unfortunately the 2821 happens to be the only better router available now. I did already suggest to my company to buy one of the routers u suggested but they said, I'm a network adminstrators and I have to come up with a way to solve  the problem of this router, that's why I've been looking for alternative ways to avoid having to restart the router every 4, 5 or 8 hours. The surprising thing though, is that for the first time the router has been up for 11h now. Ok maybe some few more details will help understand better my situation:

We have the same 2821 router with 2 gigabit ethernet interfaces and 1 HSSI interface. The 2 LAN interfaces connect to LANS in our office and the HSSI connect to a comtech modem and to the internet via satelite. This router has been up for the past 5 months with no problem. Now, The router giving me tough time (located in another department) is another same 2821 but with only 2 gigabit ethernet interfaces. The gigabit ethernet 0/0  connects to our LAN and the 0/1 connects to an optical fiber converter (OP-108) in our office, and to a remote OP-108 on our ISP side , then to a router then to internet via optical fiber. And so my problem is that this later router works for few hours and then suddenly its interfaces stop responding. U can can easly setup a console session with the router but the interfaces would not respond until u restart the router to restore the service.

992
Views
0
Helpful
17
Replies
CreatePlease login to create content