Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

Internal eigrp ,external eigrp

Hi everybody!

I have few questions about eigrp.

My book says eigrp(internal) has AD=90

and eigrp(external) has AD=170

what is external eigrp?

thanks a lot!

4 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: Internal eigrp ,external eigrp

Zeeshan

An EIGRP external route is a route that was redistributed into EIGRP.

If the route was learned from a network statement then it is internal. And if it was learned from redistribution then it is external.

HTH

Rick

Hall of Fame Super Silver

Re: Internal eigrp ,external eigrp

Perhaps we need to be careful about exactly what the book says and the context in which it says it. It has been quite a while since I have used IGRP but my memory is that redistribution was not automatic. But what was automatic was the metric used.

In general when you redistribute into EIGRP or IGRP you need to specify a default metric since the metrics in IGRP/EIGRP are not compatible with metrics of other protocols and there is not an automatic default metric (as there is in OSPF for example). But the metrics of IGRP and of EIGRP are compatible (not the same but compatible) and so if you configure redistribution between an IGRP process and an EIGRP process then there is no requirement to specify a default metric.

Perhaps you can describe exactly how you set up your test and what you did observe in the test?

HTH

Rick

Hall of Fame Super Blue

Re: Internal eigrp ,external eigrp

Sarah

For automatic redistribution to work you need to run the same AS for EIGRP and IGRP on the SAME router. So in your case what you are seeing is correct.

Try this on rd

interface Ethernet0

ip address 199.199.199.4 255.255.255.0

!

interface Serial0

ip address 200.200.200.4 255.255.255.0

!

interface Serial1

ip address 201.201.201.4 255.255.255.0

!

router eigrp 1

network 199.199.199.0

!

router igrp 1

network 200.200.200.0

network 201.201.201.0

What you should then see is the 199.199.199.0 network should appear on ra and rb.

Jon

Hall of Fame Super Blue

Re: Internal eigrp ,external eigrp

Actually a better setup would be

ra (192.168.1.1/30) -> EIGRP -> (192.168.1.2/30) rb -> (192.168.2.1/30) IGRP -> (192.168.2.2/30) rd

ra

===

int s0

ip address 192.168.1.1 255.255.255.252

int loopback10

ip address 210.210.210.1 255.255.255.0

router eigrp 1

network 192.168.1.0

network 210.210.210.0

no auto-summary

rb

===

int s0

ip address 192.168.1.2 255.255.255.252

int s1

ip address 192.168.2.1 255.255.255.252

router eigrp 1

network 192.168.1.0

no auto-summary

router igrp 1

network 192.168.2.0

no auto-summary

rd

==

int s1

ip address 192.168.2.2 255.255.255.252

int loopback10

ip address 180.180.180.1 255.255.255.0

router igrp 1

network 192.168.2.0

network 180.180.180.0

no auto-summary

Jon

9 REPLIES
Hall of Fame Super Silver

Re: Internal eigrp ,external eigrp

Zeeshan

An EIGRP external route is a route that was redistributed into EIGRP.

If the route was learned from a network statement then it is internal. And if it was learned from redistribution then it is external.

HTH

Rick

Bronze

Re: Internal eigrp ,external eigrp

Hi Rick!

if you don't mind could you explain the following:

My book says auto redistribution occurs between igrp and eigrp if they have same AS.

However, when i performed a lab i did not find any auto matic redistribution between igrp and eigrp having same AS.

thanks a lot!

Hall of Fame Super Silver

Re: Internal eigrp ,external eigrp

Perhaps we need to be careful about exactly what the book says and the context in which it says it. It has been quite a while since I have used IGRP but my memory is that redistribution was not automatic. But what was automatic was the metric used.

In general when you redistribute into EIGRP or IGRP you need to specify a default metric since the metrics in IGRP/EIGRP are not compatible with metrics of other protocols and there is not an automatic default metric (as there is in OSPF for example). But the metrics of IGRP and of EIGRP are compatible (not the same but compatible) and so if you configure redistribution between an IGRP process and an EIGRP process then there is no requirement to specify a default metric.

Perhaps you can describe exactly how you set up your test and what you did observe in the test?

HTH

Rick

Bronze

Re: Internal eigrp ,external eigrp

I will run the test again and post the output tomorrow . You guys have a good weekend!

thanks a lot!

Hall of Fame Super Blue

Re: Internal eigrp ,external eigrp

Sarah

I'd be interested to see your lab results as well as Rick as everything i have read suggests redistribution is automatic if the same AS number is used eg.

http://www.cisco.com/en/US/docs/internetworking/design/guide/nd2017.html#wp3426

Jon

Bronze

Re: Internal eigrp ,external eigrp

Hi every body!

Here is my lab set up.

Three routers( 2500 series), rb,ra,rd are connected in triangular fashion.

ra is connected to rd via s1(200.200.200.1)

ra is connected to rb via s0 (202.202.202.1

-------------------------------

rb is connected to ra via s0,202.202.202.2

rb is connected to rd via s1 201.201.201.2

------------------------------------

rd is connected to rb via s1 201.201.201.4

rd is connected to ra via s0 , 200.200.200.4

please view the attached file for configurations.

Hall of Fame Super Blue

Re: Internal eigrp ,external eigrp

Sarah

For automatic redistribution to work you need to run the same AS for EIGRP and IGRP on the SAME router. So in your case what you are seeing is correct.

Try this on rd

interface Ethernet0

ip address 199.199.199.4 255.255.255.0

!

interface Serial0

ip address 200.200.200.4 255.255.255.0

!

interface Serial1

ip address 201.201.201.4 255.255.255.0

!

router eigrp 1

network 199.199.199.0

!

router igrp 1

network 200.200.200.0

network 201.201.201.0

What you should then see is the 199.199.199.0 network should appear on ra and rb.

Jon

Bronze

Re: Internal eigrp ,external eigrp

Thanks jon! Very much indeed 199.199.199.0 appeared in routing tables on ra and rb.

Thanks and have a nice weekend!

Hall of Fame Super Blue

Re: Internal eigrp ,external eigrp

Actually a better setup would be

ra (192.168.1.1/30) -> EIGRP -> (192.168.1.2/30) rb -> (192.168.2.1/30) IGRP -> (192.168.2.2/30) rd

ra

===

int s0

ip address 192.168.1.1 255.255.255.252

int loopback10

ip address 210.210.210.1 255.255.255.0

router eigrp 1

network 192.168.1.0

network 210.210.210.0

no auto-summary

rb

===

int s0

ip address 192.168.1.2 255.255.255.252

int s1

ip address 192.168.2.1 255.255.255.252

router eigrp 1

network 192.168.1.0

no auto-summary

router igrp 1

network 192.168.2.0

no auto-summary

rd

==

int s1

ip address 192.168.2.2 255.255.255.252

int loopback10

ip address 180.180.180.1 255.255.255.0

router igrp 1

network 192.168.2.0

network 180.180.180.0

no auto-summary

Jon

5652
Views
0
Helpful
9
Replies
CreatePlease to create content