Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Internet 2 Multicast Streaming just stopped working

Good Evening,

This morning when I went to multicast an I2 stream I discovered somehow my multicast is broken to my perimeter router. I can receive SAP announcements, IGMP memberships establish and PIM joins look good. By all accounts it should work.

I spent 14 hours working on this today and am extremely frustrated. I also contacted my local loop provider. Everything seems ok but except for one multicast stream that for some un-explainable reason works… no other multicast streaming works. I have tried multiple laptops on the right on the perimeter router, outside all firewalls. Also tried rebooting my router. I spanned my Internet 2 port to another port and put Wireshark on it. The one stream that works shows up plain as day in Wireshark. All the other streams I try don't show up anywhere in Wireshark. Internet 2 sees the traffic increase on their interface to me when I start a stream. My local loop provider also sees the increase in traffic but I don't seem to receive it on my router.

When I compare my router config to my backup from the Presidential Inauguration when I last personally used it...none of the changes made since then affect the I2 connection in any way. Unicast routing works fine. I am completely stumped on this. Has anyone ever seen anything like this on their end? Can someone offer up some advice please.



Hall of Fame Super Silver

Re: Internet 2 Multicast Streaming just stopped working

Hello Joe,

a possible reason could be an RPF check failure:

a multicast stream that is not received on the interface on the best path to the source is dropped

So focus on multicast stream sources and verify with

sh ip rpf

see the following example

sh ip rpf

RPF information for ? (

RPF interface: TenGigabitEthernet7/1

RPF neighbor: ? (

RPF route/mask:

RPF type: unicast (isis)

RPF recursion count: 0

Doing distance-preferred lookups across tables

if multicast traffic sourced by arrives on a different interface then te7/1 it is dropped

to be noted that this check doesn't allow parallel links:

unicast routing may support them but RPF takes only one path as best (highest ip address on interface)

Hope to help


CreatePlease to create content