Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Internet - 3550 - Vlans

Hi,

I'm playing with a 3550 switch.

I have created several vlans and can ping between those.

If I go onto the switch I can ping the gateway and the internet.

If I go on to a host connected to one of the vlans and try and ping the internet I get nothing.

The switch is attached to a router with the ip address 192.168.0.1. I've done the no switchport command on the interface and again I can ping anything from the switch I just can't ping from a host through the switch.

What have I done wrong?

Thanks.

3550#show run

Building configuration...

Current configuration : 3707 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3550

!

enable secret 5 $1$YB2k$xsUyU5VDRZiEEaMgew45W0

!

username libby password 0 libby

no ip subnet-zero

ip routing

!

ip dhcp pool wireless

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   domain-name wireless

   dns-server 8.8.8.8

!

ip dhcp pool vlan3

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   domain-name accounts

   dns-server 8.8.8.8

!

ip dhcp pool vlan4

   network 192.168.4.0 255.255.255.0

   default-router 192.168.4.1

   dns-server 8.8.8.8

   domain-name marketing

!

ip dhcp pool vlan5

   network 192.168.5.0 255.255.255.0

   default-router 192.168.5.1

   dns-server 8.8.8.8

!

ip domain-name test

!

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

spanning-tree vlan 1 priority 24576

!

!

!

!

!

interface FastEthernet0/1

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 4

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/8

switchport access vlan 4

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/9

switchport access vlan 5

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/10

switchport access vlan 5

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/11

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/12

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/13

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/14

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/15

switchport mode dynamic desirable

spanning-tree portfast

!        

interface FastEthernet0/16

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/17

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/18

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/19

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/20

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/21

switchport mode dynamic desirable

spanning-tree portfast

!

interface FastEthernet0/22

switchport mode dynamic desirable

bandwidth 10

spanning-tree portfast

!

interface FastEthernet0/23

switchport access vlan 6

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/24

no switchport

ip address 192.168.0.2 255.255.255.0

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport mode dynamic desirable

!

interface GigabitEthernet0/2

switchport mode dynamic desirable

!

interface Vlan1

ip address 10.0.1.234 255.255.255.0

!

interface Vlan2

ip address 192.168.2.1 255.255.255.0

!

interface Vlan3

ip address 192.168.3.1 255.255.255.0

!

interface Vlan4

ip address 192.168.4.1 255.255.255.0

!

interface Vlan5

ip address 192.168.5.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip http server

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Internet - 3550 - Vlans

Can you set the static routes on your router? If not, can a routing procotocol be configured on this router? Unless the router knows how to get to these subnets, it wont be able to forward the traffic towards 3550.

The only way you can make it work either

1. Have the static routes on the router for the subnets configured on the 3550 switch?

2. Run a routing protocol between 3550 and the router and include the subnets that you ahve configured on the 3550 under the routing proctocol config.

3. Have a single vlan configred and have all the hosts connected to this vlan only.

Hope this helps.

-amit singh

10 REPLIES
Cisco Employee

Internet - 3550 - Vlans

Hi Andrew,

What is the Default Gateway on the host? Have you checked that the correct gateway is assigned?

Does you router has reverse static routes towards 3550 switch to reach the subnets configured on the 3550?

Also, Please could you paste " show ip route " from both the 3550 and router.

-amit singh

Internet - 3550 - Vlans

Thanks for the reply. The default gateway on the host is set by the dhcp as per the show run. The hosts seem to be able to communicate between each other fine, ping the switch etc.

The router is just a home router so can't post the config.

I think you are on to something re the reverse routes. I don't have any! I just plugged the home router into fa0/24, can I not do that?

Will post show ip route etc in a bit.

Thanks

Internet - 3550 - Vlans

Did you set the def gw on the host correctly?

regards,

Leo

Internet - 3550 - Vlans

where is you NAT configuration ? post router config as well.

Purple

Internet - 3550 - Vlans

Hi,

He can't have a NAT configuration on a 3550  He must be doing the NAT on the router

Regards.

Alain

Don't forget to rate helpful posts.

Internet - 3550 - Vlans

Agree i asked for router config only .

where is you NAT configuration ? post router config as well.

Cisco Employee

Internet - 3550 - Vlans

Can you set the static routes on your router? If not, can a routing procotocol be configured on this router? Unless the router knows how to get to these subnets, it wont be able to forward the traffic towards 3550.

The only way you can make it work either

1. Have the static routes on the router for the subnets configured on the 3550 switch?

2. Run a routing protocol between 3550 and the router and include the subnets that you ahve configured on the 3550 under the routing proctocol config.

3. Have a single vlan configred and have all the hosts connected to this vlan only.

Hope this helps.

-amit singh

Internet - 3550 - Vlans

Thanks very much for your quick reply.

I will take a look at that in a bit.

Internet - 3550 - Vlans

It was the routes on the other router. I was being a moron and over looked the simply stuff.

Thanks again!

Cisco Employee

Internet - 3550 - Vlans

No worries Andrew. Glad it worked. Thank you for using the rating system and marked the post as answered.

Please feel free to post any questions that you have doubts on.

Cheers,

-amit singh

665
Views
0
Helpful
10
Replies
CreatePlease login to create content