Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Internet connection with Router 877

Dear all ,

We have a new internet connection from DSL cisco router 800 Series (877).

You has been delivered it to us with Cisco Router 800 series (Ver 877), when we connect it to the PC directly it’ll work fine with the static IP.

We configured the OSPF between the Switch and the Router. and we can reach to the DSL router IP from our LAN any where.

but we can't exit from the router to the internet.

Please i need your advice

DSL router 877 ---------------> Core Switch 6509 ----> PC

Router 877 (DSL):

-----------------

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Lotfy

!

boot-start-marker

boot-end-marker

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

  pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $Internet$

ip address 96.25.31.81 255.255.255.248

ip nat inside!23

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname xxxxxxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxx

!

router ospf 1

log-adjacency-changes

network 96.25.31.80 0.0.0.7 area 0

default-information originate

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.10.10.0 0.0.0.7

no cdp run

!

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

privilege level 15

password 7 130C04

login local

!

scheduler max-task-time 5000

end

Core Switch 6509:

------------------

interface GigabitEthernet8/25

switchport

switchport access vlan 777

switchport mode access

!

!

interface Vlan777

ip address 96.25.31.82 255.255.255.248

end

!

!

interface Vlan510

description SW_to_internet

ip address 10.170.10.250 255.255.255.0

end

!

interface GigabitEthernet8/26

switchport

switchport access vlan 510

switchport mode access

!

router ospf 1

log-adjacency-changes

network 10.170.10.0 0.0.0.255 area 0

network 96.25.31.80 0.0.0.7 area 0

default-information originate

!

ip classless

ip route 0.0.0.0 0.0.0.0 96.25.31.81

===============================================

Verify:

Lotfy#ping 10.170.10.250

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.170.10.250, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

DC-BB16509#ping 96.25.31.81

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 96.25.31.81, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

DC-BB1#traceroute 4.2.2.2

Type escape sequence to abort.

Tracing the route to 4.2.2.2

  1 96.25.31.81 4 msec 0 msec 0 msec

  2  *  *  *

  3  *  *  *

  4  *  *  *

  5  *  *  *

5 REPLIES
Cisco Employee

Internet connection with Router 877

I see some problem wiht the NAT configuration. You have defined the inside interface and the outside interface but haven;t actually performing the NAT translations.

Also can you pls let me know the following details...

1. Which port on the switch is connected to the DSL Router?

2. Does all your PC's on the switch in the same Vlan? if not, the link connecting the switch and the rotuer should be a trunk link.

-Vijay

New Member

Internet connection with Router 877

Thanks my brother for your reply.

For the first paragraph, please i need some explanation.

1. Which port on the switch is connected to the DSL Router?

as you'll see on the Switch configrations, the Inter gig 8/25 on switch is the port that connected to DSL router.

2. Does all your PC's on the switch in the same Vlan? if not, the link  connecting the switch and the rotuer should be a trunk link.

i'll check it now

Cisco Employee

Internet connection with Router 877

New Member

Internet connection with Router 877

2. Does all your PC's on the switch in the same Vlan? if not, the  link  connecting the switch and the rotuer should be a trunk link.

Sorry, it's not working totally , the DSL router 877 dosen't support the trunk mode

New Member

Internet connection with Router 877

Dear Brother Vijay,

It's working with me now, yes it was a NAT issue.

Thanks for your support, it was very useful for me.

Thanks again.

-Mohamed

485
Views
7
Helpful
5
Replies
CreatePlease login to create content