Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Internet not working on vlans that the DNS server is not installed on.

I have a 3550 running as a Layer 3 switch, connected to an 1841 Cisco router, that is connected to a Comcast modem with a DHCP address.

I have 2 VLANS created with all servers being on VLAN 40, 10.10.30.0/24 and Clients are on VLAN 20, 10.10.20.0/24

I have a DNS server with IP 10.10.30.4 and DHCP server with IP 10.10.30.14. whenever the clients are hooked up to vlan 40 the internet works fine. However, when I connect them to vlan 20 the internet works.

The clients are able to ping both servers and everything works finer internally. However none of the machines can go outside to the internet .

Any ideas?

Please let me know if you need any additional info.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: Internet not working on vlans that the DNS server is not ins

Make sure NAT is configured for Vlan 20 and the device doing the NAT has a route back to Vlan 20.

HTH,

__

Edison.

2 REPLIES
Hall of Fame Super Bronze

Re: Internet not working on vlans that the DNS server is not ins

Make sure NAT is configured for Vlan 20 and the device doing the NAT has a route back to Vlan 20.

HTH,

__

Edison.

Community Member

Re: Internet not working on vlans that the DNS server is not ins

Spot on my friend, thank you very much. :)

158
Views
0
Helpful
2
Replies
CreatePlease to create content