Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Internetwork expert workbook lab 2

Hi,

I have attached a diagram of the topology.

I suppose I am having a problem with routing loop but I cannot figure out how is it occuring and the solution of course

This is the config of the routers as far as the redistribution is concerned. All connectivities are in place.

Router 1

router ospf 1

router-id 150.1.1.1

log-adjacency-changes

network 132.1.0.0 0.0.0.255 area 0

network 132.1.17.0 0.0.0.255 area 17

network 150.1.1.1 0.0.0.0 area 0

Router 2 -

router eigrp 10

redistribute ospf 1 metric 10000 100 1 255 1500

network 132.1.26.0 0.0.0.255

network 150.2.2.2 0.0.0.0

neighbor 132.1.26.6 Ethernet0/0

no auto-summary

eigrp router-id 150.2.2.2

router ospf 1

router-id 150.2.2.2

log-adjacency-changes

redistribute eigrp 10 metric 20 subnets

network 132.1.0.0 0.0.0.255 area 0

network 150.2.2.2 0.0.0.0 area 0

Router 3

router eigrp 10

router-id 150.3.3.3

redistribute ospf 1 metric 10000 100 1 255 1500

network 132.1.35.0 0.0.0.255

network 150.3.3.3 0.0.0.0

no auto-summary

!

router ospf 1

router-id 150.3.3.3

log-adjacency-changes

redistribute eigrp 10 metric 30 subnets

passive-interface Ethernet0/0

network 132.1.0.0 0.0.0.255 area 0

network 132.1.3.0 0.0.0.255 area 3

network 150.3.3.3 0.0.0.0 area 0

Router 4

router eigrp 10

redistribute ospf 1

network 132.1.45.0 0.0.0.255

no auto-summary

eigrp router-id 150.4.4.4

no eigrp log-neighbor-changes

!

router ospf 1

router-id 150.4.4.4

log-adjacency-changes

redistribute eigrp 10 metric 40 subnets

network 132.1.0.0 0.0.0.255 area 0

network 150.4.4.4 0.0.0.0 area 0

When I do not do the redistribution on router 4 then the network 132.1.35.0 is placed in all the other routers but 132.1.45.0 is not (it is in standby state)

When i break the R3-R5 frame realy connection the 132.1.45.0 is palced and the 132.1.35.0 vanishes.

When I connect the R3-R5 connection both the routres vanish from all the routers except for the connected ones.

Please help me understand the phenomenon.

3 REPLIES
Silver

Re: Internetwork expert workbook lab 2

Re: Internetwork expert workbook lab 2

Hi, 2 issues here. first you have 2 redistribution points so you may need to stop networks from being fed back into their originating IGP. Secondly on the routers running 2 IGP's you may need to alter admin distance for the redistributed routes to ensure traffic is routed correctly (eg when external eigrp routes are distributed into OSPF, the OSFP AD will be prefered over the AD of 170 for EIGRP externals).

for the first issue I normally use route-maps like below and uses them when doing redistribution.

route-map ospf-eigrp deny 10

match tag 90

route-map ospf-eigrp permit 20

set tag 110

route-map eigrp-ospf deny 10

match tag 110

route-map eigrp-ospf permit 20

set tag 90

New Member

Re: Internetwork expert workbook lab 2

thanx .I have understood the loop issue.

242
Views
0
Helpful
3
Replies
CreatePlease to create content