Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

intervaln routing on Core switch

here is the configuration

Core_Switch#sh run
Building configuration...

Current configuration : 4614 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Core_Switch
!
enable password Cisco123
!
username admin password 0 Cisco123
no aaa new-model
ip subnet-zero
ip routing
!
ip dhcp pool USERS
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-3
spanning-tree vlan 1-10,20 priority 4096
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
switchport access vlan 6
switchport mode dynamic desirable
!
interface GigabitEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
!        
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface GigabitEthernet0/29
!
interface GigabitEthernet0/30
!
interface GigabitEthernet0/31
!
interface GigabitEthernet0/32
!
interface GigabitEthernet0/33
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet0/34
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/35
!
interface GigabitEthernet0/36
!
interface GigabitEthernet0/37
!
interface GigabitEthernet0/38
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/39
!
interface GigabitEthernet0/40
!
interface GigabitEthernet0/41
!
interface GigabitEthernet0/42
!
interface GigabitEthernet0/43
!
interface GigabitEthernet0/44
!        
interface GigabitEthernet0/45
!
interface GigabitEthernet0/46
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/47
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/48
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/49
!
interface GigabitEthernet0/50
!
interface GigabitEthernet0/51
!
interface GigabitEthernet0/52
!
interface Vlan1
ip address 192.168.5.250 255.255.255.0
!
interface Vlan2
ip address 192.168.10.20 255.255.255.0
!
interface Vlan3
no ip address
!
interface Vlan6
ip address 192.168.6.1 255.255.255.0
!
interface Vlan7
ip address 192.168.7.1 255.255.255.0
!
interface Vlan8
description "Users VLAN"
ip address 192.168.8.1 255.255.255.0
!
interface Vlan20
no ip address
!
interface Vlan100
no ip address
!
interface Vlan700
no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.13
ip route 172.16.11.0 255.255.255.0 192.168.5.254
ip route 192.168.15.0 255.255.255.0 192.168.5.253
ip route 192.168.100.0 255.255.255.0 192.168.5.150
ip route 192.168.100.0 255.255.255.0 192.168.5.253
ip http server
!
logging 192.168.5.161
snmp-server community cisco RW
snmp-server community public RO
snmp-server community mds RW
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps cluster
snmp-server enable traps fru-ctrl
snmp-server enable traps entity
snmp-server enable traps cpu threshold
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps envmon
snmp-server enable traps mac-notification
snmp-server enable traps copy-config
snmp-server enable traps config
snmp-server enable traps hsrp
snmp-server enable traps rtr
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps vlan-membership
!
control-plane
!
!
line con 0
privilege level 15
login local
line vty 0 4
privilege level 15
login local
line vty 5 15
no login
!
end

Core_Switch#

not able to ping to different vlan .is there any thing wrong then let me know i dont fine any thing wrong

Thanks/Regards

10 REPLIES
New Member

Re: intervaln routing on Core switch

I am having the same problem. My configurations are similar and I am running a cisco 3560G switch. If anyone can help I will be very grateful.

Re: intervaln routing on Core switch

Hello,

There is a rule about which switch must do intervlan:

the distribution switch must do intervlan and core only switch paquets at hig speed.

However about your question:

  1. If the users are directly connected to the core switch, the physical port must be assigned to the respective Vlan, for example:
    • switchport mode access
    • swtichport access vlan 6
  2. then, the lan interface of each PC must be configured as follow:
    • ip address 192.168.6.2
    • mask: 255.255.255.0
    • default-gateway: 192.168.6.1
  3. you must do the same for all Vlans and PC´s users.
  4. enable: ip sef and ip routing at switch core

Waiting your feedback.

Roger Majo

New Member

Re: intervaln routing on Core switch

When i setup a new pc I can communiate with the default gateway (Vlan interface) and I can communicate with vlans on the same switch but I can not communicate with any other device that is not on the switch.

New Member

Re: intervaln routing on Core switch

ip routing is enable actually my core having ip inte rvaln 192.168.x.X  vlan created on database but users connected to access switches they can get ip from dhcp can go to internet but cant communicate each other

Re: intervaln routing on Core switch

Hi,

Can you confirm us if you have created all the vlans in the distribution and access switches ?

The database vlan must be identical regard all vlans.

Are you using encapsulation trunk dot1q in all trunk conecctions to the core switch?

Waiting your sooner asnwer.

Roger.

New Member

Re: intervaln routing on Core switch

For my case are already running a VTP domain. We already had a Vlan 30 (voice) and Vlan 50 (data). So I just created a new Vlan (Vlan 60 (guest)) on the vtp server, put ports inside the vlan, and  enabled ip routing. Ports inside their respective vlan can communicate with each other but they can not communicate with ports on the other vlan even tho they are on the same switch 

New Member

Re: intervaln routing on Core switch

@Rogers

yes i have created vlan on all core and access

Hall of Fame Super Blue

Re: intervaln routing on Core switch

Wow, this has become slightly complicated due to 2 posters trying to resolve different issues.

1) Dante - can you post your query as a new thread and we need a bit more than "i am having the same problem, please help"

So can you post -

1) config of 3560 switch

2) if some of the clients are another switch which it sounds like they are then please describe how it is connected to the 3560 ie. a trunk, an access link.

3) post config of other switch

4) When you say they cannot communicate can you -

i) tell us what you are using to try and communicate eg. ping ?

ii) the device you are pinging from - if a PC can you provide IP address details ie. IP/subnet mask/default-gateway

iii) the device you are pinging to - same info as ii)

that should give us enough to get started.

2) Faizan, similiar set of questions for you ie. you say you cannot ping but you don't tell us from where to where ?

So you have posted the 6500 relevant config. Can you post -

i) "sh ip int brief | inc Vlan" from the 6500

ii) tell us which device you are pinging from and provide IP/subnet mask/default-gateway

iii) tell us which device you are pinging to and provide same as ii) above

iv) the access-switches which the devices in ii) & iii) are connected to - can you provide from these access switches

a) "sh in trunk"

b) "sh vlan brief"

Jon

New Member

Re: intervaln routing on Core switch

@jon sorry for the confusion. i did set up a new thread it can be found here: https://supportforums.cisco.com/message/3220834#3220834 Or on the main page its called problem setting up new vlan.

Hall of Fame Super Blue

Re: intervaln routing on Core switch

Dante

No problem, i'll post into that thread.

Jon

239
Views
0
Helpful
10
Replies
CreatePlease login to create content