Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

InterVLAN Multicast

We have 2 VLAN's setup on a Cisco 4500 series switch that is running Cisco IOS. We are using Symantec Ghost and it is working fine on a single VLAN, however Multicast traffic is not crossing over to the other VLAN. Any links and/or pointers will be greatly appreciated. Thank you in advanced.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: InterVLAN Multicast

"I only enabled "ip pim spase-dense-mode" under VLAN 2 (sorry do I need to also enable it on the VLAN where the ghost server is?)"

Yes you do. All vlan interfaces that the multicast packets travel across need to have the pim configuration under the vlan interface.

Jon

15 REPLIES
New Member

Re: InterVLAN Multicast

You need to enable multicast routing with PIM on the two vlan interfaces. You probably need the IP Services image (or equivalent) to use PIM though. Ie.

interface vlan 100

ip pim sparse-dense-mode

Hall of Fame Super Blue

Re: InterVLAN Multicast

Things to check

1) Have you enabled multicast routing on the switch. If yes

2) Is the TTL of the multicast packet greater than 1

if not to 1 then

4500(config)# ip multicast-routing

and then on under each vlan interface you want to enable multicast on

int vlan

ip pim dense-mode

note you can use sparse-mode if you want but you need additional configuration. The above should at least let us know if the above is the problem.

Jon

New Member

Re: InterVLAN Multicast

Good catch on the TTL and enabling multicast routing if not already enabled.

New Member

Re: InterVLAN Multicast

Thank you for the reply, I did run the command to enable multicast on the switch how do I find out the TTL?

Hall of Fame Super Blue

Re: InterVLAN Multicast

The application itself sets the TTL - it may be an option in the app setup. Sorry not familiar with Ghost.

Edit - just found another thread that suggests that Ghost does indeed set to TTL to 1 by default so there must be an option to set it higher. If all devices are on the 4500 switch then a value of 2 will do. If some of the devices are hanging off access switches then you may want to look into sparse mode as apparently Ghost imaging generates a lot of traffic and you could overwhelm some of your links.

Jon

New Member

Re: InterVLAN Multicast

Thank you again for the reply so basically I should under each vlan run:

ip pim sparse-dense-mode

And that should let the multicast traffic go from one VLAN to the other correct?

Hall of Fame Super Blue

Re: InterVLAN Multicast

Only add it under vlan interfaces that have devices within that vlan that want to receive the multicast stream.

Jon

New Member

Re: InterVLAN Multicast

Thank you I just did that, eh but unfortunately will have to wait for our server guys to test it on Monday and let me know if it worked on not. I will update you guys on Monday. Thank you again and have a great weekend.

Hall of Fame Super Blue

Re: InterVLAN Multicast

No problem. But note that you still need to increase the TTL which i assume is something your server guys will have to do.

Hope it works.

Jon

New Member

Re: InterVLAN Multicast

Ok I have an update on this, after adding those options it is still not working. When I run ghost it can not find the clients on the other VLAN.

This is what "sh int vlan 2" gives me:

#sh int vlan 2

Vlan2 is up, line protocol is up

Hardware is Ethernet SVI, address is 0002.fc32.d7ff (bia 0002.fc32.d7ff)

Internet address is 10.5.9.1/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:08, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 55000 bits/sec, 16 packets/sec

5 minute output rate 161000 bits/sec, 17 packets/sec

L3 in Switched: ucast: 5826588 pkt, 1563654138 bytes - mcast: 719 pkt, 194230

bytes

L3 out Switched: ucast: 6554334 pkt, 4409882188 bytes - mcast: 0 pkt, 0 bytes

5827307 packets input, 1563848368 bytes, 0 no buffer

Received 12824 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

6554334 packets output, 114914892 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

Hall of Fame Super Blue

Re: InterVLAN Multicast

So to recap :)

1) Your switch has "ip multicast-routing" enabled.

1) Under each vlan interface you have

int vlan x

ip pim sparse-dense-mode

note - try changing this to just

ip pim dense-mode

as an additional test. We can change back later.

2) You have IGMP snooping configured in the switch

3) You have increased the TTL for the multicast Ghost packets to above 1. This figures needs to be equal to number of hops + 1. So if client vlan is another directly connected vlan on the 4500 then ttl would be 2.

What is the group membership address Ghost is using ?

Jon

New Member

Re: InterVLAN Multicast

1- Yes "ip multicast-routing" is enabled

1- I only enabled "ip pim spase-dense-mode" under VLAN 2 (sorry do I need to also enable it on the VLAN where the ghost server is?)

2- IGMP information:

#sh ip igmp groups

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter

239.255.255.253 Vlan2 3d20h 00:02:12 10.5.9.62

239.255.255.250 Vlan2 3d20h 00:02:09 10.5.9.62

224.0.1.40 Vlan2 3d20h 00:02:18 10.5.9.1

224.0.1.60 Vlan2 3d20h 00:02:19 10.5.9.57

-----------------------------------------------

#sh ip igmp snooping

vlan 1

----------

IGMP snooping is globally enabled

IGMP snooping TCN solicit query is globally disabled

IGMP snooping global TCN flood query count is 2

IGMP snooping is enabled on this Vlan

IGMP snooping immediate-leave is disabled on this Vlan

IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan

IGMP snooping is running in IGMP_ONLY mode on this Vlan

IGMP snooping report suppression is enabled on this Vlan

vlan 2

----------

IGMP snooping is globally enabled

IGMP snooping TCN solicit query is globally disabled

IGMP snooping global TCN flood query count is 2

IGMP snooping is enabled on this Vlan

IGMP snooping immediate-leave is disabled on this Vlan

IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan

IGMP snooping is running in IGMP_ONLY mode on this Vlan

IGMP snooping report suppression is enabled on this Vlan

Hall of Fame Super Blue

Re: InterVLAN Multicast

"I only enabled "ip pim spase-dense-mode" under VLAN 2 (sorry do I need to also enable it on the VLAN where the ghost server is?)"

Yes you do. All vlan interfaces that the multicast packets travel across need to have the pim configuration under the vlan interface.

Jon

New Member

Re: InterVLAN Multicast

Duh my bad sorry that was stupid of me :-(. But thank you so much you are a genius, it is working now :-).

Hall of Fame Super Blue

Re: InterVLAN Multicast

No problem. Glad you got it working.

Jon

1928
Views
4
Helpful
15
Replies