Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Intervlan Routing? Dot1q

I have been using a network simulator to work on creating VLANS and encapsulation dot1q.

I have a 2600 series router hooked up to a 2950 switch and two PCs conected to the switch. I have created two sub interfaces on the FastEthernet0/0 (.100 and .200 with VLANS 100 and 200).

The first pc has the VLAN 100 and ip 10.10.1.100 (255.255.255.0 10.10.1.1) and then the second pc VLAN 200 ip 10.10.2.100 (255.255.255.0 10.10.1.1).

I can't get them to communicate with eachother. I wish for the two vlans to be connected and I can not seem to find the right command to allow them to communicate with eachother.

Thanks in advance.

10 REPLIES
New Member

Re: Intervlan Routing? Dot1q

Can you post the config of the 2950 & 2600?

Purple
Bronze

Re: Intervlan Routing? Dot1q

Hi,

I noticed your default gateway you mentioned in your post for vlan 200 is 10.10.1.1. Shouldn't it be 10.10.2.1?

You need to ensure that the IP plus featureset is on the 2600 router - which supports vlan trunking.

Secondly, you need to do something like this below on the 2600:

c2600(config)#int fastEthernet 0/0

!configure physical parameters here only. Ensure no ip address is on this interface etc.

c2600(config)#int fastEthernet 0/0.1

c2600(config-subif)#encapsulation dot1q 1 native

c2600(config-subif)#ip address w.x.y.z

***Note the above is for the native vlan which does not tag the frames. I would use this for your management interface.

c2600(config)#int fastEthernet 0/0.100

c2600(config-subif)#encapsulation dot1q 100

c2600(config-subif)#ip address 10.10.1.1 255.255.255.0

c2600(config)#int fastEthernet 0/0.200

c2600(config-subif)#encapsulation dot1q 200

c2600(config-subif)#ip address 10.10.2.1 255.255.255.0

On the 2950,

2950(config)#int f0/1

2950(config)#switchport mode trunk

For a more comprehensive guide, see

http://cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

Hope this helps,

Michael

Cisco TAC - Australia

New Member

Re: Intervlan Routing? Dot1q

Thanks for all your help. I have attached both configs, the router and the switch. This is a basic, insecure setup as that it is just to show how a network can be split into vlans and then routed together (hence why I am keeping them in two vlans versus migrating users to one vlan).

Thanks alot!

Bronze

Re: Intervlan Routing? Dot1q

Hi,

Which port on the 2950 are you trying to trunk to the router?

If it's Fastethernet0/1, then this is configured as an access port. You will need to make it a trunk, by doing the following in interface config mode:

#switchport mode trunk

Hope this helps

Michael

New Member

Re: Intervlan Routing? Dot1q

port 1 on the switch is the trunk to the router. i added that command but what would i need to be able to communicate between vlans now?

Bronze

Re: Intervlan Routing? Dot1q

That should be it.

Have you set IP addresses on the PC's, and what is the default gateway setting on them?

The router will automatically route between the two networks, so it should be working.

If it's not working, I would try pinging each gateway interface from the PC's.

New Member

Re: Intervlan Routing? Dot1q

Yea. The IP and gateways are set to teh interface on the vlan of the router. I can ping both gateways from the PCs.

New Member

Re: Intervlan Routing? Dot1q

change the following config

interface FastEthernet0/1

switchport access vlan 200

switchport trunk allowed vlan 1-1005

switchport trunk encapsulation dot1q

to

interface FastEthernet0/1

switchport trunk allowed vlan 1-1005

switchport trunk encapsulation dot1q

New Member

Re: Intervlan Routing? Dot1q

When I dont have the trunk port in a vlan, i cant ping the gateway from the 200 vlan machine. If its in the 200 vlan, I can ping both machines gateways.

167
Views
0
Helpful
10
Replies
CreatePlease login to create content