Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

InterVLAN Routing en un Switch Catalyst 3560 L3

Hola a todos a ver si me pueden colaborar, tengo un sw con la siguiente configuracion.

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cisco

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$tDRV$ZukjERH2x/F/HH194E7ty1

enable password admin

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.3.1 192.168.3.40

ip dhcp excluded-address 192.168.10.1 192.168.10.20

ip dhcp excluded-address 192.168.20.1 192.168.20.20

ip dhcp excluded-address 192.168.30.1 192.168.30.20

ip dhcp excluded-address 192.168.40.1 192.168.40.20

!

ip dhcp pool vlan3

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 192.168.2.254

!

ip dhcp pool vlan10

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

   dns-server 192.168.2.254

!

ip dhcp pool vlan20

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

   dns-server 192.168.2.254

!

ip dhcp pool vlan30

   network 192.168.30.0 255.255.255.0

   default-router 192.168.30.1

   dns-server 192.168.2.254

!

ip dhcp pool vlan40

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.1

   dns-server 192.168.2.254

!

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface GigabitEthernet0/1

switchport access vlan 3

switchport mode access

!

interface GigabitEthernet0/2

switchport access vlan 3

switchport mode access

!

interface GigabitEthernet0/3

switchport access vlan 3

switchport mode access

!

interface GigabitEthernet0/4

switchport access vlan 3

switchport mode access

!

interface GigabitEthernet0/5

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet0/6

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet0/7

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet0/8

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet0/9

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet0/10

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet0/11

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet0/12

switchport access vlan 20

switchport mode access

!

interface GigabitEthernet0/13

switchport access vlan 30

switchport mode access

!

interface GigabitEthernet0/14

switchport access vlan 30

switchport mode access

!

interface GigabitEthernet0/15

switchport access vlan 30

switchport mode access

!

interface GigabitEthernet0/16

switchport access vlan 30

switchport mode access

!

interface GigabitEthernet0/17

switchport access vlan 40

switchport mode access

!

interface GigabitEthernet0/18

switchport access vlan 40

switchport mode access

!

interface GigabitEthernet0/19

switchport access vlan 40

switchport mode access

!

interface GigabitEthernet0/20

switchport access vlan 40

switchport mode access

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

no switchport

ip address 192.168.2.39 255.255.255.0

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

no ip address

shutdown

!

interface Vlan3

ip address 192.168.3.1 255.255.255.0

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

!

interface Vlan30

ip address 192.168.30.1 255.255.255.0

!

interface Vlan40

ip address 192.168.40.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.254

ip http server

!

!

control-plane

!

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

password cisco

login

!

end

Todo me funciona perfecto pero los equipos de mis vlan no pueden navegar, ni pueden hacer ping al 192.168.2.254 que es la ip de mi ruta estatica.

que estoy haciendo mal

Gracias

Everyone's tags (4)
4 REPLIES
Hall of Fame Super Bronze

InterVLAN Routing en un Switch Catalyst 3560 L3

This device (192.168.2.254) needs a route back to 192.168.3.0/24, 192.168.10.0/24, 192.168.20.0/24, 192.168.30.0/24 and 192.168.40.0/24 pointing to 192.168.2.39 as the gateway.

New Member

InterVLAN Routing en un Switch Catalyst 3560 L3

hi, The divice 192.168.2.254 is my firewall and my dns, this is the config:

ip:192.168.2.254

netmask: 255.255.255.0

Gateway: 192.168.2.254

DNS: 192.168.2.254

in this moment this is the gateway of my lan, how can i do to do when you say: a route back

Thanks

Hall of Fame Super Bronze

InterVLAN Routing en un Switch Catalyst 3560 L3

The FW is configured with a gateway to itself?

ip:192.168.2.254

netmask: 255.255.255.0

Gateway: 192.168.2.254

How the FW knows to send the packets towards the internet?

What kind of FW are you running (manufacturer)?

You will have to contact its vendor for instruction on how to configure routing in it.

Your FW needs to know about the subnets residing behind your 3560 switch.

Regards,

Edison

New Member

Re: InterVLAN Routing en un Switch Catalyst 3560 L3

My FW is a host linux with shorewall, dansguardian, squid, samba.

etho: WAN

eth1: 192.168.2.254/24 = LAN in 192.168.2.0

eth2: DMZ

Milton

PD: this is how i make de config:

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml

1159
Views
0
Helpful
4
Replies