Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

intervlan routing issue

hi

i have cisco 3750 with 2 VLAN's. Vlan1 (192.168.15.252/255.255.240.0)

and vlan10(10.0.0.1 255.255.0.0).when i ping from client PC(10.0.0.52/255.255.0.0) to

Vlan1 interface is working.but i am not able to ping the default gateway(it is configured

in cisco 3750 switch).

Please help me resolve this

8 REPLIES
Community Member

Re: intervlan routing issue

There is insufficient information here to help resolve your issue.

What is the default gateway you are pinging, where does this sit in relation to the client. DO you hve routing running on your 3750?

Steve

Community Member

Re: intervlan routing issue

my config

sh run

Building configuration...

Current configuration : 2069 bytes

!

! Last configuration change at 15:29:57 UTC Wed Sep 24 2008

! NVRAM config last updated at 15:30:08 UTC Wed Sep 24 2008

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WS3750

!

enable secret 5 $1$PTwR$kLMakrcL7.5rE0klpHqe2/

!

no aaa new-model

clock timezone UTC 5 30

switch 1 provision ws-c3750g-24t

system mtu routing 1500

vtp domain cisco

vtp mode transparent

ip subnet-zero

ip routing

ip dhcp excluded-address 10.0.0.1 10.0.0.50

!

ip dhcp pool wifiusers

network 10.0.0.0 255.255.0.0

domain-name **************

dns-server 218.248.240.24 218.248.240.23

default-router 10.0.0.1

lease 30

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10

name wifi

!

!

interface GigabitEthernet1/0/1

description collegeproxy

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/24

!

interface Vlan1

ip address 192.168.15.253 255.255.240.0

!

interface Vlan10

ip address 10.0.0.1 255.255.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip http server

!

!

!

control-plane

!

!

line con 0

logging synchronous

line vty 0 4

login

length 0

line vty 5 15

password *********

login

length 0

!

end

WS3750#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

10.0.0.0/16 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, Vlan10

S* 0.0.0.0/0 [1/0] via 192.168.0.1

C 192.168.0.0/20 is directly connected, Vlan1

WS3750#ping 10.0.0.52

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.52, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

WS3750#ping 192.168.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

WS3750#ping 192.168.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

WS3750#

Hall of Fame Super Gold

Re: intervlan routing issue

mohana

Thank you for providing the additional information. The config does not have any obvious errors. The ping output that you posted shows that there is access to the default gateway of 192.168.0.1. When you do the standard ping, as in your post, the switch will use as the source address the address of the outbound interface (in your case the address of vlan 1). I would suggest that you do an extended ping from the switch. In the extended ping specify the same destination of 192.168.0.1 but also specify that the source address is from vlan 10 (10.0.0.1). I suspect that the extended ping will fail. If it does fail it will demonstrate that the problem is not on this switch but the problem is that the gateway at 192.168.0.1 does not have a route for the 10.0.0.0/16 network pointing back to this switch.

HTH

Rick

Re: intervlan routing issue

i agree with rick check the gateway dose it have route to 10.0.0.0/16 through vlan 10 interface

if the router use static route should have somthing like

ip route 10.0.0.0 255.255.0.0 [vlan10 IP]

good luck

Community Member

Re: intervlan routing issue

hi all

thanks for the reply

my router ( 192.168.0.1 ) is linux proxy server.how to add route static in linux server

regs

S.Mohana sundaram

Re: intervlan routing issue

i have no idea but i now mostly the problem is there

good luck

Community Member

Re: intervlan routing issue

hi

i have add route manualy in gw 192.168.0.1.now its pinging.but i am unable to browse internet.

thanks in advance

regs

S.Mohana sundaram

Hall of Fame Super Gold

Re: intervlan routing issue

mohana

I am glad that our suggestions helped you to resolve your problem with pinging the gateway. You have not provided much for us to work with for this new problem. Based on what you have told us so far I would guess that the problem was that there is not address translation for the traffic from the switch going out to the Internet. Can you check and tell us whether there is translation for these addresses?

HTH

Rick

173
Views
7
Helpful
8
Replies
CreatePlease to create content