Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

InterVlan Routing On L3 Switch and NAT On another Router

Hi All,

Not sure if this can be done

ISP----------Router--<L3 Port>--L3 SW--------------------Intenal Network

Router Config:

access-list 1 permit 192.168.0.0 0.0.0.3

access-list 1 permit 10.0.0.0 0.0.0.255

ip nat inside source list 1 interface <WAN> overload

interface <WAN>

ip address 1.1.1.2 255.255.255.252

ip nat outside

no shut

interface <LAN>

ip address 192.168.0.1 255.255.255.252

ip nat inside

no shut

ip route 0.0.0.0 0.0.0.0 1.1.1.1

ip route 10.0.0.0 255.255.255.0 192.168.0.2

Switch Config:

ip routing

interface fa0/1

no switchport

ip address 192.168.0.2 255.255.255.252

no shut

interface VLAN 10

ip address 10.0.0.1 255.255.255.0

no shut

interface range fa0/2-24

switchport

switchport mode access

switchport access vlan 10

spanning-tree portfast

no shut

From the PC, I am not able to access the internet. nor can i do a NAT translation on WAN Router.

WHY?

btw, Layer 3 Switch does not allow us to configure NAT.

Help is greatly appreciated.

Regards

Yen Lung

7 REPLIES
Hall of Fame Super Blue

Re: InterVlan Routing On L3 Switch and NAT On another Router

Hi Yen

Do you have a deault route on your L3 switch pointing to 192.168.0.1 ?

Jon

New Member

Re: InterVlan Routing On L3 Switch and NAT On another Router

Oh yes, I had put it down in my config.

Still not working...

Re: InterVlan Routing On L3 Switch and NAT On another Router

Hi Yen.

- Can you do ping command from hosts to 192.168.0.1.

- Can you resolve names from the DNS server?

From hosts : C:\>nslookup http://www.google.com

Hopes that help

Thot

New Member

Re: InterVlan Routing On L3 Switch and NAT On another Router

i had forgetten the ip route on the above.

I had put that in in my L3 SW.

I could not test that, as it is a internal Lab.

but, from the PC, I am able to ping to the WAN Interface.

No NAT translation.

New Member

Re: InterVlan Routing On L3 Switch and NAT On another Router

Any one can help me with this?

It seem to be a simple problem. what am i missing?

Hall of Fame Super Blue

Re: InterVlan Routing On L3 Switch and NAT On another Router

Hi yen

Firstly are you sure packets are getting to the router from the switch.

if so, can you run a "debug ip nat" on the WAN router to see what is happening.

Be careful with debug commands as they can affect the performance of the router.

Jon

New Member

Re: InterVlan Routing On L3 Switch and NAT On another Router

Ok ... Problem solved,

One quick question...

When I ping the WAN Router Outside interface, from the Inside Interface, I get a NAT translation.

however, once i go to the l3 switch, and ping the WAN router outside interface, I do not get a NAT translation.

WHY?

173
Views
0
Helpful
7
Replies
CreatePlease to create content