cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1256
Views
0
Helpful
4
Replies

Intervlan routing using One L3 switch

prajithtr_2
Level 1
Level 1

haii everybody,

    Suppose we have two layer2 switches(2960) and one multi layer switch(catalyst3560) .These two layer2 switches carry 3 vlans (vlan20,vlan30,vlan40).and there is no router or other layer 3 device .with these devices is it  possible to set up intervlan routing.if possible could you pls give a sample configuration.

Thanks

1 Accepted Solution

Accepted Solutions

dschoolcraft
Level 1
Level 1

Configuration for the 3560
!
!
!enable ip routing on the 3560
!
ip routing
system mtu routing 1500
!
! Note the IP's Listed here would need to be your Default Gateways on the Hosts
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
!
interface vlan 10
ip address 192.168.2.1 255.255.255.0
!
!
interface vlan 20
ip address 192.168.3.1 255.255.255.0
!
!
!
!Enable a routing protocol for intervlan routing
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
!
! NOTE IF you have a non Gig switch it would be FastEthernet0/1 
!
interface GigabitEthernet0/1
description link to 2960 1
switchport trunk encap dot1q
switchport mode trunk


interface GigabitEthernet0/1
description link to 2960 2
switchport trunk encap dot1q
switchport mode trunk


#######################
2960 Configuration

interface GigabitEthernet0/1
description trunk to 3560 port g0/1
switchport trunk encap dot1q
switchport mode trunk


#######################

2960 2 config

interface GigabitEthernet0/2
description trunk to 3560 port g0/2
switchport trunk encap dot1q
switchport mode trunk

Then assign your switchports on the 2960's as needed

Interface GigabitEthernet0/Some number
switchport access vlan 20
switchport mode access
spanning-tree portfast

Substitute your interface names & IP's as necessary

View solution in original post

4 Replies 4

dschoolcraft
Level 1
Level 1

Configuration for the 3560
!
!
!enable ip routing on the 3560
!
ip routing
system mtu routing 1500
!
! Note the IP's Listed here would need to be your Default Gateways on the Hosts
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
!
interface vlan 10
ip address 192.168.2.1 255.255.255.0
!
!
interface vlan 20
ip address 192.168.3.1 255.255.255.0
!
!
!
!Enable a routing protocol for intervlan routing
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
!
! NOTE IF you have a non Gig switch it would be FastEthernet0/1 
!
interface GigabitEthernet0/1
description link to 2960 1
switchport trunk encap dot1q
switchport mode trunk


interface GigabitEthernet0/1
description link to 2960 2
switchport trunk encap dot1q
switchport mode trunk


#######################
2960 Configuration

interface GigabitEthernet0/1
description trunk to 3560 port g0/1
switchport trunk encap dot1q
switchport mode trunk


#######################

2960 2 config

interface GigabitEthernet0/2
description trunk to 3560 port g0/2
switchport trunk encap dot1q
switchport mode trunk

Then assign your switchports on the 2960's as needed

Interface GigabitEthernet0/Some number
switchport access vlan 20
switchport mode access
spanning-tree portfast

Substitute your interface names & IP's as necessary

hai,

   thank you...for  your immediate reply.your answar was defenitely helpfull.

glen.grant
VIP Alumni
VIP Alumni

  Yes a 3560 will do your intervlan routing and a lot faster than a normal router also .

Perform below configs

--------------------------------

L2 Switch
------------
1) Create L2 vlans
2) Configure default gateway as L3 switch
3) Create L2 trunk to the L3 switch

L3 Switch
------------
1) Create Vlan SVI, assign IP address
2) Create L2 trunk connecting to L2 Switch
3) Advertise the network under protocol in L3 switch

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card