Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS update licensing

Hi all,

I have a simple question:

I would like to install a new IOS on a 3750 switch, installed IOS version is 12.x, the actual version is 15.x.

I'm able to download the 15.x IOS software with my cisco account, but I am  entitled to install this IOS on my cisco switch without having a service  contract? Is this an update or an upgrade?

Where can I find any information about the IOS software licensing?

I have read the software download agreement - but I don't understand this.

Best Regards,

Michael

2 ACCEPTED SOLUTIONS

Accepted Solutions
Bronze

IOS update licensing

Michael,

The 3750E, 3750X series switches have a universal image, specific features are unlocked depending the license installed.

See this portion in the "show ver" output

License Level: ipbase

License Type: Permanent

Next reload license Level: ipbase

You can also verify this in "show license udi". If you have a higher

featureset, but not activated, we can activate that (by purchasing the correct license)

If you have a 3750G, 3750 switch you do not need any license to run any image that you require ,all you need to do is to download the image from CCO and run it onto the switch .

Licenses are required for 3750e, 3750x series switches whereon you run universal images and you require the licenses to unlock the particular feature on the universal image.

In summary only the device 3750X and 3750E will use a license, that is no necessary to download a license for his device.

E.g.

If you have a 3750x running universal image and lanbase and you downloaded an ipbase IOS. You did a reload.

The switch will keep the same feature set (lanbase) because it is restricted on the license level that has the switch.

Link

-----

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6406/white_paper_c11579326_ps10745_Products_White_Paper.html

Haihua

Bronze

IOS update licensing

Michael,

Correct url:

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6406/white_paper_c11-579326_ps10745_Products_White_Paper.html

Be carefull because some switches and 3750G-48s does not have 15.2.1E1. The lastes is 15.0(2)SE5

List:

3750G-24T  12.2.55-SE8(ED)

3750G-24TS-1U   15.0.2-SE5(ED)

3750G-16TD    12.2.55-SE8(ED) 

3750G-12S-SD  15.0.2-SE5(ED)

So the latest code that we can upgrade is 15.0(2)SE5 but if you have a 3750G-16TD, 3750G-24t a downgrade will be need it (12.2(55)SE8) on the 3750x stack.

Haihua

12 REPLIES
Hall of Fame Super Gold

IOS update licensing

You can upgrade the software if the feature set is the same:  12.2 IP Base to 15.0 IP Base.

New Member

IOS update licensing

Hi Leo,

thank you for this fast answer. But I have this same question addressed to the support and he said:

"I regret to inform you that I did not find a basis to entitle your request for downloading the particular software downloads that you requested...

Starting Nov 9, 2011, Cisco is enforcing software entitlement based on active contracts covered in profiles and will only allow you to download software for the active products covered in the contracts that are associated with your profile.

Based on the product information that is covered under the contracts associated with your Cisco.com profile, you are not entitled to the software that you have selected."

My problem is, that i cannot find any clear information about the licensing of the IOS software.

Regards,

Michael

Hall of Fame Super Gold

Re: IOS update licensing

Michael,

Can you specify if you are talking about a 3750/3750 or the 3750E/X? 

The error message you have posted means that your CCO login details do not have a valid Service Contract attached.  Service Contract is tied directly to the serial number(s) of any appliance your company owns where you are an employee. 

I think you need to talk to your authorized Cisco reseller and/or Cisco AM and get them to assist you.

Another thing, if you do have 3750/3750G, can I ask if you can verify, each and one of them, and make sure they have 16- or 32Mb flash memory.  This is because if your 3750/3750G has 16Mb memory, the highest IOS you can use is 12.2(55)SE8. 

Bronze

IOS update licensing

Michael,

The 3750E, 3750X series switches have a universal image, specific features are unlocked depending the license installed.

See this portion in the "show ver" output

License Level: ipbase

License Type: Permanent

Next reload license Level: ipbase

You can also verify this in "show license udi". If you have a higher

featureset, but not activated, we can activate that (by purchasing the correct license)

If you have a 3750G, 3750 switch you do not need any license to run any image that you require ,all you need to do is to download the image from CCO and run it onto the switch .

Licenses are required for 3750e, 3750x series switches whereon you run universal images and you require the licenses to unlock the particular feature on the universal image.

In summary only the device 3750X and 3750E will use a license, that is no necessary to download a license for his device.

E.g.

If you have a 3750x running universal image and lanbase and you downloaded an ipbase IOS. You did a reload.

The switch will keep the same feature set (lanbase) because it is restricted on the license level that has the switch.

Link

-----

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6406/white_paper_c11579326_ps10745_Products_White_Paper.html

Haihua

New Member

Re: IOS update licensing

Hi Leo, hi Haihua,

thank you for your answers.

Sorry that I don't have give you the complete information about my hardware. I have 3750X and 3750G, the output of "sh ver" and "sh licencense udi" are showing:

>> for 3750X, IOS 15.0(2)SE

License Level                   : ipservices

License Type                    : Permanent

Next reboot licensing Level     : ipservices

Device#   PID                   SN              UDI

-----------------------------------------------------------------------------

*1        WS-C3750X-48T-S       FDxxxxxxxxx     WS-C3750X-48T-S:FDxxxxxxxxx

2        WS-C3750X-48T-S       FDxxxxxxxxx     WS-C3750X-48T-S:FDxxxxxxxxx

>> for 3750G, IOS 12.2(50)SE3

No info about licensing level and no licensable UDI in the system.

So I think, that if I don't need a feature upgrade, I can download and install the IOS 15.2(1)E1 on both switches without having licensing problems. Is that correct?

@Leo

My last post was not a automatic answer at the cisco website, it was a answer from cisco employee and so, it was not a error message :-)

@Haihua

The link seems dont't work :-(

Regards

Michael

Hall of Fame Super Gold

IOS update licensing

I can download and install the IOS 15.2(1)E1 on both switches without having licensing problems. Is that correct?

Holy cr@P!  You really are looking for trouble. 

All I can say is be very careful and test 15.2(1)E1 very, very well before you push this into production.

Bronze

IOS update licensing

Michael,

Correct url:

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6406/white_paper_c11-579326_ps10745_Products_White_Paper.html

Be carefull because some switches and 3750G-48s does not have 15.2.1E1. The lastes is 15.0(2)SE5

List:

3750G-24T  12.2.55-SE8(ED)

3750G-24TS-1U   15.0.2-SE5(ED)

3750G-16TD    12.2.55-SE8(ED) 

3750G-12S-SD  15.0.2-SE5(ED)

So the latest code that we can upgrade is 15.0(2)SE5 but if you have a 3750G-16TD, 3750G-24t a downgrade will be need it (12.2(55)SE8) on the 3750x stack.

Haihua

Bronze

IOS update licensing

Michael,

3750G switches do not have 15.2(1)E1. Forgot to mention

Haihua

New Member

IOS update licensing

Hi Haihua and Leo,

thank for your's answers nad for the hint with the 3750G. I can see, that the latest release for such devices is 15.0.2-SE5 (ED) and I don't try the 15.2(1)E1.

I need this exatly informations, because an importand customer of our company wants from me the warranty that I have the authority to install new software on his switches.

And now I say thank you and wish you a merry christmas.

Regards,

Michael

Hall of Fame Super Silver

Re: IOS update licensing

Aside from which image should you run and how do universal image licenses work - all covered earlier - you do not seem to have yet had anyone address the entitlement issue.

You can install an image that will work on a given switch without being entitled to do so. For a while Cisco has been venturing into enforcing licensed version level on the device but customer outcry has mostly given them cause to retreat back from that position and leave customers to the "honor system" - i.e no enforcement on the device itself as long as you have the necessary image binary. Feature license level within a given image (e.g., lanbase, ipbase, ipservices) is generally still enforced with a license file tied to the Universal Device Identifier (UDI). That is distinct from staying with the same feature license but simply upgrading to a newer version.

There are several ways that one can have upgrade entitlement. Here are the most common ones:

1. The device has a current Smartnet support contract. You can verify by trying to open a support case on the device. If the devices is under Smartnet, even when not associated by your CCO userid being attached to the contract, you will be able to proceed through service request creation online up to the last step of submitting the request. You can also simply call the TAC and ask for the verification.

2. There is a documented PSIRT (security advisory) that affects the licensed version of software and for which the fix is to upgrade to a patched version. This is typically not a major version upgrade however and your will have to contact TAC to obtain entitlement for the specific device and download version.

3. You have one of the (few) proudcts Cisco offers with the "enhanced limited lifetime warranty". See this notice for more info on that.

Hope this helps and Merry Christmas to you as well.

Hall of Fame Super Gold

Re: IOS update licensing

I can see, that the latest release for such devices is 15.0.2-SE5 (ED) and I don't try the 15.2(1)E1.

I need this exatly informations, because an importand customer of our company wants from me the warranty that I have the authority to install new software on his switches.

Be responsible for what you are about to do.  Do more research on the IOS you want to load into your fleet, particularly 15.0(2)SE5. 

For the 3750-series switches, I would recommend either one of the following:

  • If your 3750 has 16 mb of flash, then use 12.2(55)SE8; or
  • If your 3750 has 32 mb of flash, then use  either 12.2(55)SE8 or 15.0(2)SE4.
Bronze

Re: IOS update licensing

Michael,

Wish you merry Christmas too and Happy New Year :-D

Haihua

516
Views
0
Helpful
12
Replies
CreatePlease login to create content