Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS upgrade on WS-C2950-24 running SI

I have 2 WS-C2950-24 switches which are using the Standard image IOS release

(c2950-i6q4l2-mz.121-22.EA2.bin).

I need to enable layer 3 QOS on these switches, is it possible to upgrade to the Enhanced Image IOS (12.1.22-EA9(ED),

or do I need to replace these switches?

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: IOS upgrade on WS-C2950-24 running SI

Disagree , no you can't upgrade I don't believe . The software recognizes what the hardware is and will only install the features that is included with that switch . So if the switch is a SI switch to begin that is all that you can get . You would have to upgrade the switch . Take a look at the images , the SI switches and the EI switches all run the same image so the features installed is done by the software which recognizes it as a SI or EI switch , sorry , always thought it was kind of strange that you couldn't upgrade it too but that is the way it is .

3 REPLIES
New Member

Re: IOS upgrade on WS-C2950-24 running SI

Yep fully possible

rate if it helps

Purple

Re: IOS upgrade on WS-C2950-24 running SI

Disagree , no you can't upgrade I don't believe . The software recognizes what the hardware is and will only install the features that is included with that switch . So if the switch is a SI switch to begin that is all that you can get . You would have to upgrade the switch . Take a look at the images , the SI switches and the EI switches all run the same image so the features installed is done by the software which recognizes it as a SI or EI switch , sorry , always thought it was kind of strange that you couldn't upgrade it too but that is the way it is .

New Member

Re: IOS upgrade on WS-C2950-24 running SI

Many thanks Guys,

I had a feeling that there was a hardware issue here, but was not sure.

Looks like a switch change is my only way.

453
Views
0
Helpful
3
Replies
CreatePlease to create content