Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP address

Hi,

If i enable voice and data VLAN in the same port how will the IP phones get an IP address from DHCP. MY current configuration is trunk for the phones. Will there be a performance issue on both the configurations. ( Trunk and voice VLAN). Which is the good practice.

Also a small query,

How the PC and phone will get a seperate IP if the PC is connected to the Phone, while the phone is configured to voice VLAN.

4 REPLIES
New Member

Re: IP address

Hi,

One more question:

Is there encapsulation happening for the voice packets if its under voice VLAN.

Re: IP address

If u define the same vlan for phones and PC they will in the same broadcast domain hence they will get the IP address from the same subnet.

If u r using a seprate vlan for voice then u can define a seprate subnet for phones.

The best practice is to have seprate vlans for pc and phones.

U r going to define the switch port in data vlan and voice vlan.The switch is going to sense the presence of the voice device and place it in the voice vlan defined on the port so as the vlan=broadcast domain it is going to get the ip from the specified subnet.

Thanks

Mahmood

Re: IP address

This is how our ports are configured....

interface GigabitEthernet1/4

switchport access vlan 124

switchport mode access

switchport voice vlan 224

qos trust cos

qos trust device cisco-phone

auto qos voip cisco-phone

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

spanning-tree portfast

service-policy output autoqos-voip-policy

Here is how our VLAN's are configured

interface Vlan124

description 24th Floor Workstations VLAN

ip address 192.168.124.1 255.255.255.0

ip helper-address 192.168.2.43

no ip redirects

ip pim sparse-mode

interface Vlan224

description VoIP 24th floor

ip address 192.168.224.1 255.255.255.0

ip helper-address 192.168.2.43

Hope this helps.

Burleyman

Re: IP address

Its good to have separate subnets for data & voice vlan. When you specify different vlans on switchport for voice & data then voip phone behaves as if the port was trunk & sends voice pkts as tagged. On the other hand, pc's in data vlan send its pkts untagged as in case of native vlan on trunk port.

Its preferred to keep the port as access port & configure it as in the above post.

119
Views
5
Helpful
4
Replies