Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IP based Quality of Service

Hello,

I wan't to configure my Catalyst 3750.

My network is: 10.1.0.0 /16

There 4 different sections

1. 10.1.1.0 - 255 for Server's

2. 10.1.100.0 - 255 for IPMI Interface's

3. 10.1.2.0 - 255 for Client's (1)

4. 10.1.3.0 - 255 for Client's (2)

I have created 4 ACL's

access-list 1 permit 10.1.1.0 0.0.0.255
access-list 2 permit 10.1.100.0 0.0.0.255
access-list 3 permit 10.1.2.0 0.0.0.255
access-list 4 permit 10.1.3.0 0.0.0.255

and 3 class-map's

class-map match-any remote
match access-group 1
match access-group 2

exit

class-map match-all software1
match access-group 3

exit
class-map match-all software2
match access-group 4

exit

and 1 policy-map

policy-map marker
class remote
set ip dscp 1
exit
class software1
set ip dscp 2
exit
class software2
set ip dscp 3
exit

I have add the policy-map to any Interface of the switch, because later I wan't that the clients

interface ....................
service-policy input marker

Now, all packets from the definied "areas" of my network are marked with a specific dscp value. But who can I configure Queues that match on the different dscp values?

My goal is that the Packets from Client's (1) always have 60% of the whole bandwidth guaranteed, Packets from Client's (2) 30%, and Packets from Server and IPMI 10% together. I also wan't, when the Client's(1) don't send packets, the other Applications(Server, IPMI, Client's(2)) have the full bandwidth and not only 30% or 10%. Clearly bandwidth guarantee and not a limitiation.

I hope you understand my question.

regards

peterderk

Everyone's tags (1)
1 REPLY
Community Member

Re: IP based Quality of Service

Oh there is a problem. When I give an interface the policy map then pop up a error.

QOSMGR-4-CLASS_NOT_SUPPORTED

That means, only one match per class-map is supported !
When I erase one of the entrys in class-map remote like:

class-map match-any remote
match access-group 1

Then is all Ok and the error are not pop up.

Inside the 3750 are only 2 Queues for QoS, but I need 4 different settings. Has anybody a Ideafor a solution?

regards

440
Views
0
Helpful
1
Replies
CreatePlease to create content