Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP connectivity between the Colo router interfaces

Hi All,

I am testing a colo router connectivity design as shown in the diagram.Everything is working fine,except the ping between the Gigabit interfaces 1/1.200 on Colo Router1 and Colo Router2.

(ie) Pinging between 200.0.0.2 and 200.0.0.3

Both the colo routers are running HSRP/EIGRP. There is a trunk link connection between the Colo Router1 and Colo Router2,Vlan 200 is allowed in this trunk.But still we are not able to ping between Gig interfaces 1/1.200

Note:

-----

Ping between Gig interfaces 1/2.190 is OK.

Can anybody advice me if I need any other specific configuration for this to work?

Thanks in Advance

6 REPLIES

Re: IP connectivity between the Colo router interfaces

from where you are initiating ping request? is it from customer network side or transit nw 1 or transit nw 2 or colo routers?

you can traceroute the IP from the device from which you expect to get ping reply and see at which hop it is getting timed out. then at the last good hop you can login and check the availability of route for the IP you are trying to ping or can check for ACLs which is blocking ICMP.

New Member

Re: IP connectivity between the Colo router interfaces

Thanks..

I would like to know how the HSRP is talking to each other in the customer Vlan 200.If they are talking to each other via the trunk link between the Colo Router1 and ColoRouter2,then I should be able to ping between the interfaces Gig 1/1.200?

Ping is intiated from the Colo Router1 and ColoRouter2 from the customer network side.

Any ideas ?

Re: IP connectivity between the Colo router interfaces

can u check on colo routers if HSRP is running for vlan 200?

issue "show standby vlan 200" on colo rtr 1 and colo rtr 2 and paste the output.

if HSRP has elected active and standby routers with IP 200.0.0.2 or 200.0.0.3 and virtual IP as 200.0.0.1, then it means HSRP is running fine and you should be able to ping IPs.

also check for interface status on colo rtr1 and colo rtr2 which are inter-connected and which are connected to customer equipment.

New Member

Re: IP connectivity between the Colo router interfaces

I think the point is that the basic connectivity from colo router 1 to colo router 2 on vlan 200 is not working over the trunk link. Before even getting into the HSRP configuration, we want to be able to ping 200.0.0.3 from colo router 1 and vice versa over the trunk. When this works, we should be easily add the HSRP configuration knowing that the hello packets can get back and forth over the trunk.

Yes, gig 1/1.200 on both routers are up/up.

A trace from ColoROuter1 to ColoRouter2 gives this:

Tracing the route to 200.0.0.3

1 200.0.0.3 0 msec * 0 msec

and vice versa.

But a ping fails.

The configuration of the trunk between ColoRouter1 and ColoROuter2 is as follows:

interface GigabitEthernet1/48

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

no ip address

no cdp enable

end

Any thoughts?

Thanks

Re: IP connectivity between the Colo router interfaces

from this trunk config, i can see that you are allowing only vlan 200, there is no native vlan. if you want multiple vlans to be allowed then you need to make port as a trunk port.

but in ur case i believe that you need only vlan 200 to pass through between colo rtr ports, so in that case you can config port as access port.

if possible, can u config port as access port on both colo rtr 1 and colo rtr 2.

interface GigabitEthernet1/48

switchport mode access

switchport access vlan 200

check interface status on both colo rtr and then try to ping IPs.

Purple

Re: IP connectivity between the Colo router interfaces

Verify the simple stuff like the layer 2 vlan for 200 was created on both sides , "show vlan" .If you don't plan to ever add anything else across that link make it an access port in vlan 200 . If you are trunking i prefer

switchport

switchport encapsulation dot1q

switchport trunk native vlan 200

switchport mode dynamic desirable

switchport trunk allowed vlan 200

675
Views
0
Helpful
6
Replies
CreatePlease login to create content