Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

ip helper-address in or out of a vrf

Hi!

I have a question regarding 6509 config:

interface Vlan33
ip vrf forwarding old_lan
ip address 10.4.2.1 255.255.255.0
ip helper-address 10.10.1.2
end

Should I configure the ip helper-address in a vrf or will it understand that the helper must look for the dhcp server in the vrf "old_lan"? I don't have an option to configure ip helper-address vrf xxx.

Best regards,

Roberts

3 REPLIES
Cisco Employee

Re: ip helper-address in or out of a vrf

ropakalns wrote:

Hi!

I have a question regarding 6509 config:

interface Vlan33
ip vrf forwarding old_lan
ip address 10.4.2.1 255.255.255.0
ip helper-address 10.10.1.2
end

Should I configure the ip helper-address in a vrf or will it understand that the helper must look for the dhcp server in the vrf "old_lan"? I don't have an option to configure ip helper-address vrf xxx.

Best regards,

Roberts


VRF-aware DHCP relay has been supported for quite sometime now. If your only requirement is to relay DHCP requests to a DHCP server within the VRF old_lan then you are ok with using the ip helper-address statement under the interface that is part of the VRF without using the VRF keyword. The vrf keyword is for 'VRF aware DHCP' feature which is not currently supported and is probably not what you need anyway.

Atif

New Member

Re: ip helper-address in or out of a vrf

Hi Atif!

Thank's for your reply!

Turns out that 6k supports only ip-helper in global table. I opened a TAC case and they told me that this won't work (server is in the old_lan vrf). So seems that with catalyst it requests the IP on the global routing table. I know that in a router configuration it would ask for an IP in the vrf, but this config has a different logic. So I need to find a workaround here...

Roberts

Cisco Employee

Re: ip helper-address in or out of a vrf

I am a bit confused here as to what you are trying to achieve. If the only requirement is to have devices part of the VRF be assigned an IP-Address by a DHCP server dedicated for this VRF and reachable within the VRF then this works with the configuration you have. Do you have a more elaborate requirement? Are you expecting to use a Central DHCP Server for all VRFs?

Atif

1916
Views
0
Helpful
3
Replies