Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP helper address stops working

Does anyone have any suggestions for debugging a problem with the ip helper address?

Twice in the last 24 hours, a C3560E, Version 12.2(44r)SE2 has stopped forwarding DHCP requests on a particular VLAN. In both situations, forwarding to the same DHCP server did continue to work fine from another VLAN.

The fix for the problem was to remove the ip helper address line from the config, wait 30 seconds and put exactly the same line back in again! What was also odd was if we put in a second helper, that got the DHCP requests without a problem while the original remained silent.

I have tried a 'debug ip dhcp server packets' and that suggests it is trying to forward to the correct address. Debugging output looks the same for both a good or bad period.

I'd appreciate any other debugging suggestions anyone has.

5 REPLIES

Re: IP helper address stops working

packet sniffer will be helpful here.

You can capture on this 3560E or a device between this one and DHCP server when the issue happens.

You can also ask server guys to check DHCP server to see if IP Pool for that VLAN is full.

New Member

Re: IP helper address stops working

Most likely the DHCP scope for this VLAN is out of the available addresses

New Member

Re: IP helper address stops working

Thanks for the responses.

Sniffing from the DHCP server confirms requests are not passed through. If we were out of addresses, that would be reported in the log.

Re: IP helper address stops working

Hi Dave,

Can you do a sniffing hop by hop to see if you could find where the DHCP packet is dropped?

Please let me know the software version so that I can look up for a bug.

By the way, "ip helper" configured under the other vlan interface on the same switch works OK. is that right?

New Member

Re: IP helper address stops working

Are there secondaries configured on this interface?

681
Views
0
Helpful
5
Replies