Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

IP helper problems

Hello,

I can't get IP Helper to work on my network. Setup:

Client Pc <> 2950 <> 3560 <> Server 2003

Client PC: Dhcp

2950:
!
vlan 2
name Management/Secretariaat
!
vlan 3
name DC
!
vlan 4
name Servers
!
vlan 5
name ICT
!
interface Vlan2
no ip address
no ip route-cache
shutdown
!
interface Vlan3
no ip address
no ip route-cache
shutdown
!
interface Vlan4
no ip address
no ip route-cache
shutdown
!
interface Vlan5
ip address 192.168.5.15 255.255.255.0
ip helper-address 192.168.4.6
no ip route-cache
!
interface FastEthernet0/1 # to client pc
switchport access vlan 3
switchport mode access
!
interface GigabitEthernet0/1 # to the 3560
switchport trunk allowed vlan 2-5
switchport mode trunk
!

3560:
!
vlan 2
name Management/Secretariaat
!
vlan 3
name DC
!
vlan 4
name Servers
!
vlan 5
name ICT
!
interface Vlan2
description Management/Secretariaat
ip address 192.168.2.2 255.255.255.0
!
interface Vlan3
description Management/Secretariaat
ip address 192.168.3.2 255.255.255.0
!
interface Vlan4
description Management/Secretariaat
ip address 192.168.4.2 255.255.255.0
!
interface Vlan5
description Management/Secretariaat
ip address 192.168.5.2 255.255.255.0
!
interface GigabitEthernet0/1 # naar de 2950
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-5
switchport mode trunk
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/13 # to windows 2003 dhcp server
switchport access vlan 4
switchport mode access
!

windows 2003
Own ip: 192.168.4.6
dhcp scopes for 192.168.2.x 3.x 4.x 5.x

Notes:

-I can ping from the 2950 to the windows 2003 dhcp server

-dhcp does work if i configure the client port in vlan 4 (dhcp server is also located in this subnet)

-windows server shows up in the mac table of  the 2950

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: IP helper problems

The 2950 switch is a L2 switch only so the vlan 5 interface on the 2950 switch is only used for managing the switch ie. it is not used for client traffic.

You need to add the ip helper-address to the vlan 5 interface on the 3560 instead ie.

interface Vlan5
description Management/Secretariaat
ip address 192.168.5.2 255.255.255.0

ip helper-address 192.168.4.6
!

Also the client default-gateway must be the vlan 5 address on the 3560 ie. 192.168.5.2 and not the vlan 5 address on the 2950 ie. 192.168.5.15 so you may need to update your DHCP scope on the windows server.

Jon

2 REPLIES
Hall of Fame Super Blue

Re: IP helper problems

The 2950 switch is a L2 switch only so the vlan 5 interface on the 2950 switch is only used for managing the switch ie. it is not used for client traffic.

You need to add the ip helper-address to the vlan 5 interface on the 3560 instead ie.

interface Vlan5
description Management/Secretariaat
ip address 192.168.5.2 255.255.255.0

ip helper-address 192.168.4.6
!

Also the client default-gateway must be the vlan 5 address on the 3560 ie. 192.168.5.2 and not the vlan 5 address on the 2950 ie. 192.168.5.15 so you may need to update your DHCP scope on the windows server.

Jon

Community Member

Re: IP helper problems

Thanks for the fast reply!

597
Views
0
Helpful
2
Replies
CreatePlease to create content