Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ip helper problems

I have a 2801 configured as a router on a stick.  It is working fine and sends dhcp address to the respective vlans.  It is connected a 2950 switch.  When I connect an 871 and configure the WAN port as a trunk and the ip helper on the LAN.  the LAN pc does not get a dhcp address. 

here is the config of the 871.  my dhcp scopes are10.105.vlan.0 /24  native vlan is 1

interface FastEthernet4.1

encapsulation dot1Q 1 native

ip address 10.105.1.253 255.255.255.0

!

interface Vlan1

ip address 192.168.105.254 255.255.255.0

ip helper-address 10.105.1.200

13 REPLIES
VIP Super Bronze

ip helper problems

So the end devices (PC laptop etc...) are connected to the 2950 or the 871 router?

can you provide a diagram on how everything is connected together?

Is 871 the router that connects to the Internet.

HTH

New Member

Re: ip helper problems

Internet -> 2801 -> 2950 -> (WAN) 871 (LAN) -> PC

plugging my pc/laptop into the 2950 I get the correct IP's from the respective VLAN's but when add the 871 in the picture it doesnt work.

Purple

ip helper problems

Hi,

sh cdp nei on the 2950  and sh int trunk then on the 2801 sh ip int br

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: ip helper problems

2801------------------------------------------------------------------------------------------------------------

sh ip int brief:

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES manual up                    up

FastEthernet0/0.1          10.105.1.200    YES manual up                    up

FastEthernet0/0.20         10.105.20.254   YES manual up                    up

FastEthernet0/0.30         10.105.30.254   YES manual up                    up

FastEthernet0/1            192.168.15.4    YES DHCP   up                    up

Serial0/1/0                unassigned      YES NVRAM  administratively down down

Serial0/2/0                unassigned      YES NVRAM  administratively down down

2950------------------------------------------------------------------------------------------------------------

sh cdp neighbors:

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

P_router         Fas 0/7            171         R S I     2801      Fas 0/0.1

router2          Fas 0/11           177         R S I     871       Fas 4.1

sh int trunk:

Port        Mode         Encapsulation  Status        Native vlan

Fa0/7       on           802.1q         trunking      1

Fa0/11      on           802.1q         trunking      1

Purple

ip helper problems

Hi,

on the 800 router can you do sh ip int br | in Vlan

if it is up/up then on the 2801 can you do debug ip dhcp server packet and on the pc do an ipconfig/renew

and post debug output

Regards.

Alain

Don't forget to rate helpful posts.
Hall of Fame Super Silver

ip helper problems

Joli

I am slightly confused about how the 871 is configured. In the original post you told us this

interface FastEthernet4.1

encapsulation dot1Q 1 native

ip address 10.105.1.253 255.255.255.0

!

interface Vlan1

ip address 192.168.105.254 255.255.255.0

ip helper-address 10.105.1.200

So is VLAN 1 10.105.1.253 or is it 192.168.105.254? Perhaps posting the output of show ip interface brief from the 871 would help us figure out what is the issue?

My guess is that the request sent by the helper address is using gateway address as 192.168.105.254 and that is why no addresses are assigned.

HTH

Rick

New Member

ip helper problems

Why are assign 2 subnets to the VLAN.

Sub int is on 10.105.1.x

Your SVI is on 192.168.105.x

Your DHCP relay will be sourced off the SVI and will not get you a offer on the the 10.105.1.x network.

Either re-addres that SVI or move the helper to the subinterface.

interface FastEthernet4.1

encapsulation dot1Q 1 native

ip address 10.105.1.253 255.255.255.0

!

interface Vlan1

ip address 192.168.105.254 255.255.255.0

ip helper-address 10.105.1.200

mike

New Member

Re: ip helper problems

I am not trying assigning two subnets to the vlan on the 871.  At least that is not my goal.  My goal is to place another 2950 on the LAN of the 871 and have the 2801 assign an ip depending on the vlan the second 2950 set on. 

right now the pc is directly connected to the LAN ports on the 871.

so basically i want the lan of the 871 ask for an ip address from the 2801.

New Member

Re: ip helper problems

In anycase the IP helper should be on the SVI interface that has the subnet you want to get a lease on. Is this the case?

You have  it on a interface with 192.168.105.x address. do you want a lease from this subnet?

New Member

Re: ip helper problems

yes i want to get a 10.105.vlan.0 address which is on the 2801.  the 871 has fa4 on that same subnet.  But then my question what ip do I give the 871 lan so that what ever i plug into its lan gets an ip from the 10 network?

New Member

Re: ip helper problems

Both routers can participate in dot1q trunks. Both routers can have sub-interfaces with different IP that exist on the same subnet. Do not recommend this but its possible.

Better design would be to connect the two switch interfaces - trunk interfaces on the switch and have 1 router do the L3 routing. IP helper would on SVI of the router that is doing the L3.

Mike

VIP Super Bronze

Re: ip helper problems

You realty don't need the 871.  You need to connect your PC to the 2900 switch, then the 2900 connects to the 2801. On the 2801 the other interface connects to the Internet.

PC------------2900---------2801---------Internet

The 2900 is layer-2 only with one or multiple vlans.  The route point or the default gateway for your laptop is the LAN interface of the 2801. You create one or multiple DHCP Scopes on the router.

HTH

Hall of Fame Super Silver

ip helper problems

Joli

You told us this:

yes i want to get a 10.105.vlan.0 address which is on the 2801

So now can you tell us what will be the vlan that the PCs will connect in? Is it part of 10.105.1 or is it some other vlan? If it is going to be part of 10.105.1 then I agree with Reza that you do not need the 871. If it is to be some different subnet then what subnet will it be? And is that subnet configured on the 871? (you have not shown that it is configured so I am assuming that it is not).

HTH

Rick

865
Views
0
Helpful
13
Replies