Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

IP-Helper

Hi All,

I have a dhcp server on w2k3 and one scope for one LAN .

I want to have another scope on the same dhcp server for a 2nd Vlan and I did the IP helper and ip broadcast on the 2nd Vlan interface but it is not working.

No PC gets IP in the second scope.

Thaks,

Vlad

27 REPLIES
Green

Re: IP-Helper

Please post your router config.

Thanks

Scott

Re: IP-Helper

Make sure that your vlan 2 SVI shows up and that the ports that the PCs are attached two are access ports of vlan 2. Otherwise, if this is the case, please do as Scott suggested and post the switch or router config.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: IP-Helper

I ve done all these ...and routing is also enabled.

No idea tho' what s wrong

Thx,

Vlad

New Member

Re: IP-Helper

Scott ,

this is what I ve configured

This is a L3 Switch 4507.

interface Vlan7

ip address 172.20.19.1 255.255.255.0

no ip unreachables

no ip proxy-arp

load-interval 30

end

#sh run int vlan 60

Building configuration...

interface Vlan60

ip address 172.16.6.254 255.255.255.0

ip helper-address 172.51.19.254

ip directed-broadcast

end

The DHCP server is in Vlan 7 and has a scope for Vlan 60.

There is no ACL anywhere that could block any tcp or udp traffic.

Thanks,

Vlad

New Member

Re: IP-Helper

sorry the ip helper is 172.20.19.254 not as I copy pasted it.

Re: IP-Helper

Make sure you have ip routing enabled. Can you ping VLAN 60 from a system in Vlan 7, like the DHCP server?

Oh, and is your scope enabled on the server?

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: IP-Helper

I can ping the SVI in 60 from the DHCP in 7 and scope is also active.

thx

Vlad

Hall of Fame Super Blue

Re: IP-Helper

Vlad

Can you post

"sh ip int brief"

"sh ip route"

sh int ?? where ?? is the interface that you have a PC plugged into on vlan 60.

Jon

New Member

Re: IP-Helper

Jon,

I assume this is what u are interested in:

172.16.0.0/16 is variably subnetted

172.16.6.0/24 is directly connected, Vlan60

Vlan60 172.16.6.254 YES manual up up

interface GigabitEthernet3/6

switchport access vlan 60

switchport mode access

switchport nonegotiate

load-interval 30

no snmp trap link-status

spanning-tree portfast

Thanks,

Vlad

Re: IP-Helper

Hello vlad

not sure why you need "ip directed broadcast" on vlan 60 interface ! ip helper actually converts your dhcp broadcasts to a unicast message.. in any case, run a sniffer on the PC, and see what happens.. See if you get any updates back from the dhcp server.. do you see any error logs on the server ? make sure you specify a dhcp exclude address for 172.16.6.254 , which is the vlan 60 SVI interface !

Raj

New Member

Re: IP-Helper

Hello Raj,

I know the ip-helper converts the broadcast to unicast , but I could not get it to work so I tried.

Anyway , if I hardcode an IP address on a PC in that Vlan I can ping the DHCP and viceversa.

I will wireshark it and let you know.

Thanks,

Vlad

Hall of Fame Super Gold

Re: IP-Helper

Vlad

If you take a PC in the subnet that is not getting addresses from the DHCP server and you hard code an IP address of that subnet on the PC, can the PC then ping the DHCP server?

HTH

Rick

New Member

Re: IP-Helper

Rick,

The server and the PC can ping one another.

I have wireshark it and I see the request from the PC but no arp from the DHCp server.

Anyway,

I dont know if I mentioned it , but on the same server I have another DHCP scope in vlan 7.

Thx,

Vlad

New Member

Re: IP-Helper

Vlad,

Same configuration made it in my lab its working fine . check changes what i made in configuration.

interface Vlan7

ip address 172.20.19.1 255.255.255.0

end

interface Vlan60

ip address 172.16.6.254 255.255.255.0

ip helper-address 172.20.19.254

no ip directed-broadcast

end

interface GigabitEthernet3/6

switchport access vlan 60

switchport mode access

sw host

Regards

Ram

New Member

Re: IP-Helper

Ram,

I did the same config you have and nothing.

This is also a lab I am trying on.

I changed the vlan, changed the ip addresses..still the same.

I see the request from the client but no offer from server.I am missing something and I dont know what.

The 2 swithes -- the ' core' and the access are doing VTP and I can ping from server to the client and viceversa.

Thanks,

Vlad

Hall of Fame Super Blue

Re: IP-Helper

Vlad

Perhaps the issue is not with the switch but the DHCP server itself. What is the default-gateway set to on the DHCP server ?

Jon

New Member

Re: IP-Helper

Jon,

The default-gateway for the 2nd scope is teh SVI 192.168.100.129/25.

I have changed the IP address and the scope in the DHCP from 172.16.6.0/24 to 192.168.100.128/25.

I have now vlan 7 with 172.20.19.0/24 and

vlan 18 with 192.168.100.128/25.

int vl 18

ip add 192.168.100.129/25

ip helper-add 172.20.19.254

no ip directed-broadcast

I was thinking that the problem in not with the switch also , but I cant get to understand what would the server problem be.

What could be wrong with the server?

The server sits in Vlan 7 and the scope in Vlan 7 works just fine.

Regards,

Vlad

Hall of Fame Super Blue

Re: IP-Helper

Vlad

I meant the default-gateway on the server under the network configuration ie. is it's default-gateway set to 172.20.19.1 ie. the L3 vlan interface on your switch ?

Jon

Hall of Fame Super Gold

Re: IP-Helper

Jon

In a previous post Vlad says that a PC with an assigned address in the VLAN can ping the server and the server can ping the PC. If that is true it indicates that it is not an issue with the default gateway on the server.

Vlad

It is helpful to know that the server and the PC can ping each other. This proves that it is not a basic IP connectivity issue that is preventing DHCP from working. You should not expect to see an ARP from the server in wireshark running on the PC. Since the server is in a different subnet, the server will send through its default gateway and will not arp for the PC.

I agree with the suggestion from Jon that the issue may be in the server or in its scope for vlan 60. Can you check the configuration of the scope and let us know its details.

HTH

Rick

Hall of Fame Super Blue

Re: IP-Helper

Rick

Good point, missed that one.

Jon

New Member

Re: IP-Helper

Rick, Jon-

Dont know if you checked my previous post,but just in case , I ve changed the IP and the vlan so I have now:

vlan 7 & vlan 18

int vl 7

ip add 172.20.19.1

int vl 18

ip add 192.168.100.129

ip help add 172.20.19.254

On the DHCP server( IP 172.20.19.254) I have 1 scope in vlan 7 ( the vlan that the DHCP sits in with default gateway 172.20.19.1) and 1 scope in vlan 18 as :

192.168.100.128

Server and Scope options:

IP excluded: 192.168.100.129

Router 192.168.100.129 and thats all.

With a hardcoded IP I can ping the server and the other way around.

Regards,

Vlad

New Member

Re: IP-Helper

Vlad,

Try this.

connect another switch2 and create dhcp scope address in SW2 after that check in your pc getting ip address or not .

Regards

Ram

New Member

Re: IP-Helper

Ram,

I had 3 scopes on the switch that the current DHCP server is connected to and they were working good.

I still have two scopes there -after I removed the scope for vlan 7 and put it on w2k3- and the PCs are getting IP with no problem from those 2 remaining pools.

Does not seem to be a switch issue.

I have even set-up bootp forward on the switch where teh SVI's are.

Regards,

Vlad

New Member

Re: IP-Helper

New Member

Re: IP-Helper

Ram,

To be honest , it does not really help.

I have the same thing set-up here.

Regards,

Vlad

New Member

Re: IP-Helper

Happy New Year all!

I just wanted to inform everybody that I finally found the problem for this and I will share it even if it sounds lame :)

The issue was that the L3 was not forwarding the DHCP relay , cos the "service DHCP" was NOT enabled.....

Anyway,

Thanks to all for help!

Vlad

Hall of Fame Super Gold

Re: IP-Helper

Vlad

I am glad that you found and corrected the problem. Thank you for posting back to the thread indicating that you had solved the problem and identifying what the problem turned out to be. This will help other people who read about this problem and now can see what the problem was.

HTH

Rick

289
Views
0
Helpful
27
Replies
CreatePlease to create content