Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP Phone 6921 voice vlan

I have CME on Router 2800 series, and switch 2960 PoE connected to this router.

On 2960 switch, there is existing 7945 IP Phone that already work properly and get IP 14.x.x.x from voice vlan 2.

Problem is when I add cisco 6921 IP Phone connect to 2960 switch, it get data vlan 10.x.x.x, not voice Vlan 14.x.x.x

I have check CDP and it use CDP v2

Config on 2960:

interface GigabitEthernet1/0/34  <--- this is connected to IP Phone 7945

switchport mode access

switchport voice vlan 2

spanning-tree portfast

!

interface GigabitEthernet1/0/35  <--- this is connected to IP Phone 6921

switchport mode access

switchport voice vlan 2

spanning-tree portfast

With same config and condition on port 2960, why the IP Phone 6921 can't get voice vlan 14.x.x.x,

whereas IP Phone 7945 can get voice vlan 14.x.x.x

Thanks,,

2 REPLIES
New Member

IP Phone 6921 voice vlan

Very strage issue I am facing the same issue here. the odd part is it was working for over a year and over a weekend this started.

interface GigabitEthernet2/0/45

switchport mode access

switchport voice vlan 100

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

macro description cisco-phone

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

end

New Member

IP Phone 6921 voice vlan

I have solve this problem by upgrade firmware to SCCP69xx.9-2-2-6 for 6921 IP Phone.

809
Views
0
Helpful
2
Replies