Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

IP Phone couldnot get IP addresses from DHCP server!

Hi all,

We have a LAN campus using Cisco switches and a Nortel IP phone system. The IP Phones get their IP addresses from a DHCP server. Things were OK until we replaced the old 2950 switches with new 2960 switches: after replacing, the IP Phones couldnot get the IP addresses.

Could any one give me an explain for this situation?

Thanks and regards,

hoanghiep

9 REPLIES
Hall of Fame Super Bronze

Re: IP Phone couldnot get IP addresses from DHCP server!

Did you implement the same configuration at the switchports from the 2950 to the 2960?

Can you post a portion of the configuration?

Sames Vlans were created in the 2960?

Do the PCs get their IP address via DHCP ?

__

Edison.

New Member

Re: IP Phone couldnot get IP addresses from DHCP server!

Thanks for your concern,

The configuration in 2960 switches is the same as in the 2950 ones.

The PCs get the IP address via DHCP as normal. Things only went wrong with the IP Phones.

Couldnot understand this :(

regards,

hoanghiep

New Member

Re: IP Phone couldnot get IP addresses from DHCP server!

Hello dear,

I am not a voice guy but i'll do some guess work here. I believe that the IP phones send unicast requests to the DHCP server unlike computers, so with unicast u have something known as ARP, may be...well i am guessing the IP phone has a different mac address in it's cache i.e. the mac of the older switch..If config's fine then this could be the reason.

Rohit

New Member

Re: IP Phone couldnot get IP addresses from DHCP server!

Hi hoanghiep

did you try to delete the lease and see if the DHCP Server reserves a new IP for the phone?

Are you using trunks for the phones or are the phones on a dedicated port?

On a 3560 you have the posibility to configure the ports with the webtool. Is this posible on a 2960 as well and did you use this option or did you do a manual configuration.

Can you post a Portconfig and the uppermost part of "show run"

Silver

Re: IP Phone couldnot get IP addresses from DHCP server!

Have you got this working? I have the same issue. Actually, I have a core switch 3750 with 2960 trunked to it. Before the 2960s we used to have 3COM and everything was working well. When we changed to the 2960s the PCs get the correct DHCP subnet and VLAN but the phones never make it. We get the error Server not reachable on the phones.

I tried connecting the Phone directly to the core and same issue. They work only when connected to 3COM switches.

Any ideas,

Thanks,

New Member

Re: IP Phone couldnot get IP addresses from DHCP server!

I was having a similar issue today... I know with Cisco phones you have to set the port as a trunk along with stating the access vlan and the voice vlan... don't know how it works with Nortel though, you could give it a try at least.

Here is a sample of my config;

interface FastEthernet0/1

switchport access vlan 3

switchport voice vlan 2

switchport mode trunk

switchport trunk encapsulation dot1Q

New Member

Re: IP Phone couldnot get IP addresses from DHCP server!

Jd is correct.....i am having the whole setup like that n its working n even u can use native vlan command.

New Member

Re: IP Phone couldnot get IP addresses from DHCP server!

Hi,

just as an FYI, this type of configuration works for Nortel IP phones as well.

Steve

Silver

Re: IP Phone couldnot get IP addresses from DHCP server!

Hello,

The only way that worked was to setup the port asif it was a cisco IP phone:

interface FastEthernet0/1

switchport access vlan 3

switchport voice vlan 2

spanning-tree portfast

The phone registered successfully in the correct VLAN and the PC got the IP address and VLAN info correct as well.

Regards,

389
Views
4
Helpful
9
Replies
CreatePlease to create content