Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Ip routing on 3750

Hi,

When i enable ip routing on my cisco 3750. it becomes unreachable. I created l2 and l3 vlans with ip addresses

any idea?

J

5 REPLIES
Hall of Fame Super Blue

Re: Ip routing on 3750

Jorg

Perhaps you could post the config.

First thing to check is your routing. Does your 3750 know how to route back to the source IP addresses you are coming from.

Please supply some more details in terms of IP addressing, topology etc.

Jon

New Member

Re: Ip routing on 3750

Hi Jon

here is my config. I'm changing the config for a migration plan. Port config is already in place. All ports are configured in vlan 10 at this moment. I needed to deleted the port config to minimize output for this post.

The topolpgy is as follows. 1 switch 3750 as the core, 1 2950 and another connected to the 2950. the uplinks are trunk ports.

!

hostname aaa-bb250003

!

enable secret 5

enable password 7

!

no aaa new-model

switch 1 provision ws-c3750-24ts

ip subnet-zero

ip name-server 10.xx.1.3

!

errdisable recovery cause bpduguard

errdisable recovery cause link-flap

errdisable recovery interval 120

no file verify auto

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet1/0/2

description Naar werkstation

switchport access vlan 10

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

!

interface GigabitEthernet1/0/1

description Naar ws-c2950 in MER

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan10

ip address 10.xx.250.3 255.255.255.0

no ip route-cache

!

interface Vlan12

description Datacenter

ip address 10.xx.1.253 255.255.255.0

ip helper-address 10.xx.1.34

ip helper-address 10.yy.1.34

!

interface Vlan22

description Officevlan

ip address 10.xx.10.254 255.255.255.0

ip helper-address 10.yy.1.34

ip helper-address 10.xx.1.34

!

interface Vlan32

description VoIP

ip address 10.xx.30.254 255.255.255.0

ip helper-address 10.xx.1.34

ip helper-address 10.yy.1.34

!

interface Vlan42

description ILODRAC

ip address 10.xx.40.254 255.255.255.0

!

interface Vlan72

description studentenvlanA

ip address 10.xx.71.254 255.255.252.0

ip helper-address 10.xx.1.34

ip helper-address 10.yy.1.34

!

interface Vlan902

description Network Management

no ip address

!

ip default-gateway 10.xx.1.41

ip classless

ip http server

ip http secure-server

!

logging trap warnings

logging facility local6

!

control-plane

!

!

line con 0

exec-timeout 0 0

line vty 0 4

password 7

login

line vty 5 15

password 7

login

!

end

best regards

Re: Ip routing on 3750

Hi,

When you enable ip routing on L3 switch, this becomes L3 switch. on L3 switches you don't use Ip default gateway. You should remove this with

no ip default-gateway 10.xx.1.41

instead you will need to define

ip route 0.0.0.0 0.0.0.0 10.xx.1.41

and also if you are shutting down Vlan1 then you should define native valn on your trunk links. On the ports connecting to C2950.

for example

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

HTH

Shaheen

Purple

Re: Ip routing on 3750

Shahem is correct , remove the default gateway and change it to a default static route pointing to the same address.

New Member

Re: Ip routing on 3750

Hi,

I think i found it. I'm connecting through the site via an other site. The management address of the other switch is incorrect. So because i enabled routing and native vlan is not configured the route to management interface of the L3 switch wasn't reachable.

tommorow i'm on the site to enable routing and let you know. Anyway thanks for the support.

Best regards

J.

200
Views
10
Helpful
5
Replies
CreatePlease to create content