Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Silver

IP SINGLE CLASS /27

Router

-


interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 15

ip address 192.168.15.1 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

-


Swicth 0

-


interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport mode trunk

!

interface FastEthernet0/3

switchport access vlan 15

!

interface FastEthernet0/4

switchport access vlan 20

!

vlan 15

name SALES

!

vlan 20

name SUPPORT

-


Switch 2

-


interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 15

!

interface FastEthernet0/3

switchport access vlan 20

!

vlan 15

name SALES

!

vlan 20

name SUPPORT

-


PC0

-


IP: 192.168.15.2

mask:255.255.255.0

GW:192.168.15.1

PC1

-


IP: 192.168.20.2

mask:255.255.255.0

GW:192.168.20.1

PC2

-


IP: 192.168.15.3

mask:255.255.255.0

GW:192.168.15.1

PC3

-


IP: 192.168.20.3

mask:255.255.255.0

GW:192.168.20.1

how can i change this IP address from two networks to a single networking using /27?

---

Posted by WebUser Charalampos Skeleton C'trattou from Cisco Support Community App

1 ACCEPTED SOLUTION

Accepted Solutions
Green

IP SINGLE CLASS /27

Hi,

Reading your request I think you are aiming to use a /27 for
sales and a different /27 for Support

On your router - reconfigure like this:-

!
interface FastEthernet0/0.1
encapsulation dot1Q 15
no ip address
ip address 192.168.15.1 255.255.255.224
!
interface FastEthernet0/0.2
encapsulation dot1Q 20
no ip address
ip address 192.168.15.33 255.255.255.224
!
end


You will need to readdress your scopes in your
DHCP server if you use one.

Also readdress any static ip addressing your
PCs & printers etc.

Devices in Vlan 15

Ip addresses in the range 192.168.15.2-30
Mask 255.255.255.224
Defauly gateway 192.168.15.1

Devices in Vlan 20

Ip addresses in the range 192.168.15.34-62
Mask 255.255.255.224
Defauly gateway 192.168.15.33

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
2 REPLIES
Green

IP SINGLE CLASS /27

Hi,

Reading your request I think you are aiming to use a /27 for
sales and a different /27 for Support

On your router - reconfigure like this:-

!
interface FastEthernet0/0.1
encapsulation dot1Q 15
no ip address
ip address 192.168.15.1 255.255.255.224
!
interface FastEthernet0/0.2
encapsulation dot1Q 20
no ip address
ip address 192.168.15.33 255.255.255.224
!
end


You will need to readdress your scopes in your
DHCP server if you use one.

Also readdress any static ip addressing your
PCs & printers etc.

Devices in Vlan 15

Ip addresses in the range 192.168.15.2-30
Mask 255.255.255.224
Defauly gateway 192.168.15.1

Devices in Vlan 20

Ip addresses in the range 192.168.15.34-62
Mask 255.255.255.224
Defauly gateway 192.168.15.33

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Hall of Fame Super Silver

IP SINGLE CLASS /27

Alex

It is a possible interpretation of the question as being how to change from 2 networks with /24 to 2 networks with /27. But my reading of the original post suggests a different interpretation. I think that the original poster is asking how to combine into a single network which uses a /27.

If I have the correct interpretation then I would observe that the high level solution is fairly simple, though there may be a few complexities as they work through the process. Here is my suggestion of what needs to be done:

- multiple vlans require multiple networks. so if you want a single network then you need a single vlan.

- choose which vlan you will use.

- configure switch access ports in this vlan.

- remove the vlan that you will not be using.

- since there is a single vlan there is no need for switch ports. chane all ports currently configured as trunk to be access ports in the new vlan.

- with a single vlan/single network there is no need for vlan subinterfaces on the router. so remove the subinterfaces on the router.

- configure the router interface with an IP address and subnet mask for the new subnet.

- if there is DHCP to provide addressing information to clients then change the DHCP server to have a new scope for the new subnet. (and you can remove the old scopes)

HTH

Rick

100
Views
0
Helpful
2
Replies
CreatePlease login to create content