Cisco Support Community


Hello, can somebody help use to resolve this problem between IPSLA and static router ICMPECHO?.

We have a central site with a main router 7206VXR.

This router is connected to an IPVPN Cloud using MPLS routing so many remote sites can communicate with it.

There is a remote site ( / 24) that reach the central site through another carrier.

If we want to reach the remote site from the main router, we use the static route:

ip route, where is the switch where the remote site reach the central site.

This static route is announced to IPVPN Cloud using prefix-list, route-map and redistribute static at BGP routing protocol.

What we want is to denegate the announcement of this static route if the remote site ( / 24) is unreachable.

We are using the IP SLA to reach this result but the problem is that the address: does never goes DOWN.

If we keep this static route and use another like that: ip route always the first take precedence.

If we delete the static route: ip route the remote site is unreachable and we lost connection.

The commands we use are:

track 123 ip sla 1 reachability

ip route 240 track 123

ip sla 1
icmp-echo source-interface GigabitEthernet0/1
timeout 1000
threshold 2
frequency 3
ip sla schedule 1 life forever start-time now

ip prefix-list ARRIOLA seq 5 permit
ip prefix-list DEFAULT seq 5 permit
ip prefix-list DMZ seq 5 permit
ip prefix-list DMZ seq 10 permit
ip prefix-list DMZ seq 15 permit
ip prefix-list DMZ seq 20 permit
ip prefix-list TELMEX seq 5 permit

route-map ESTATICAS permit 10
match ip address prefix-list ARRIOLA
route-map ESTATICAS permit 15
match ip address prefix-list DMZ
route-map ESTATICAS permit 20
match ip address prefix-list DEFAULT
set community 6147:70 6147:100
route-map ESTATICAS permit 30
match ip address prefix-list TELMEX
set community 6147:90
route-map ESTATICAS permit 40
set community 6147:70

router bgp 65515
bgp log-neighbor-changes
timers bgp 10 30
neighbor remote-as 6147
neighbor description --- BGP principal con TDATA ---
neighbor update-source GigabitEthernet0/2
neighbor version 4
address-family ipv4
  redistribute static route-map ESTATICAS

Waiting your sooner answer.

Thanks very much.

Everyone's tags (1)
CreatePlease to create content