Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP SLA not functioning correctly.

I have a router that is currently using DHCP to obtain its IP addressing, however I would like to have the router register its DHCP address on DNS so it is reachable by name.  I have seen examples of using the HTTP get within IP SLA, however I am not getting the results that I need.  Here is the configuration of the SLA monitor.

ip sla 1
http get http://freedns.afraid.org/dynamic/update.php?<key>
frequency 3600
ip sla schedule 1 life forever start-time now

The problem I am having is that the HTTP get executes a PHP script that updates the IP.  The problem is I am not able to add the question mark (?) within the command as IOS traps this as an error of some sort.  Is there a away of formulating the command in such a way to include the question mark so the PHP script will execute to update the DNS its recieved from DHCP.

Regards,

Karim

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: IP SLA not functioning correctly.

Hi Karim,

Cisco have an answer for this.  Enter the command and just before you get to the ?, press CTRL+V and then enter the question mark.  This will prevent the IOS seeing it as a request for help.

See the notes against step 8 here: http://www.cisco.com/en/US/docs/ios/12_3/12_3y/12_3ya8/gt_ddns.html#wp1203122

Regards,

Stuart.

2 REPLIES
New Member

Re: IP SLA not functioning correctly.

Hi Karim,

Cisco have an answer for this.  Enter the command and just before you get to the ?, press CTRL+V and then enter the question mark.  This will prevent the IOS seeing it as a request for help.

See the notes against step 8 here: http://www.cisco.com/en/US/docs/ios/12_3/12_3y/12_3ya8/gt_ddns.html#wp1203122

Regards,

Stuart.

New Member

Re: IP SLA not functioning correctly.

Thank You!! That worked like a charm!!  after waiting for the update to occur, I looked at the SLA status and found no errors and a successful update on the DNS server.

Thanks

Karim

165
Views
0
Helpful
2
Replies
This widget could not be displayed.