Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ip summary-address eigrp

i just upgraded all of my switch links from l2 to l3 /30's and now my entire routing table is on all of the l3 switches. i ran the command ip summary-address eigrp 100 0.0.0.0 0.0.0.0 on the interface but i lose connection to the switch. I'm trying to just send the switches a default route instead of the entire routing table since they are in a hub and spoke configuration. any suggestions? The remote l3 3560 is NOT in stub

10 REPLIES
Hall of Fame Super Silver

Re: ip summary-address eigrp

Michael

I can not tell from your post whether you are configureing eigrp summary-address on the spoke switch or on the hub router. (it should be on the hub router) One of the potential issues with eigrp summary-address is that it puts a route to null0 into the routing table for the summary address. It does this as a way to prevent creating black holes. So when you use summary-address 0.0.0.0 0.0.0.0 it will put that route into your routing table and potentially replace a real default route. The best way to get around this is to specify an administrative distance for the null0 route higher than the default. I would suggest something like:

ip summary-address eigrp 100 0.0.0.0 0.0.0.0 250

HTH

Rick

Cisco Employee

Re: ip summary-address eigrp

Rick,

A great point with the discard route! That might very well be at the root of Michael's problem.

Best regards,

Peter

Cisco Employee

Re: ip summary-address eigrp

Hello Michael,

On which switches exactly did you exactly enter the "ip summary-address" command? Did you use it on more than one switch?

A command like this should not cause a loss of connectivity per se but if you are really losing connection to the switch then it might be that your routing tables either lose important routes or start to contain invalid information as a result of your summarization. Personally, I would focus on having a very close look on the contents of the routing tables after entering the summarization command. I suspect that simply some wrong or missing routing information is the cause of your problem.

Best regards,

Peter

New Member

Re: ip summary-address eigrp

My goal is to advertise only a default route to my "spoke" 3560s via EIGRP.

spoke 3560

!

interface GigabitEthernet0/52

no switchport

ip address 10.255.255.46 255.255.255.252

!

!

router eigrp 100

no auto-summary

network 10.110.0.0 0.0.255.255

network 10.255.255.44 0.0.0.3

network 192.168.248.0

network 192.168.249.0

!

Hub Config

!

interface GigabitEthernet2/9

no switchport

ip address 10.255.255.45 255.255.255.252

!

!

router eigrp 100

no auto-summary

network 10.255.255.0 0.0.0.255

network 10.0.0.0

network 192.168.6.0

network 192.168.12.0

network 192.168.253.0

!

I added ip summary-address eigrp 100 0.0.0.0 0.0.0.0 to the Hub P2P interface feeding the spoke site. Does it matter that the spoke 3560 isn't set as STUB?

Hall of Fame Super Silver

Re: ip summary-address eigrp

Michael

It should not matter whether the spoke is configured as stub or not, in terms of how the eigrp summary-address works. And I do not see how configuring it as stub or not would impact the problem that you are describing. But it is not clear to me if there is any reason to prevent configuring the spoke as an eigrp stub. And in hub and spoke networks it is usually advantageous to configure the spokes as stub.

It is not clear in what you are posting whether the hub is learning a default route. But if the hub is learning a default route from one of its neighbors, then the summary address as you are configuring it would replace the learned default route with the route from the summary-address. Try configuring the summary-address as I suggested and let us know if it resolves your issue.

HTH

Rick

New Member

Re: ip summary-address eigrp

so try configuring it with a high admin distance? I'm wanting the Spoke to learn a default route from the Hub. I just don't think the spoke router needs the entire routing table.

Hall of Fame Super Silver

Re: ip summary-address eigrp

Michael

I agree that the spoke usually does not need the entire routing table. So sending only a default route is generally a good thing.

Setting the administrative distance in the eigrp summary-address does not change what the hub advertises to the spoke. It only affects what happens in the routing table of the hub router.

HTH

Rick

New Member

Re: ip summary-address eigrp

eigrp stub....that fixed it!

Hall of Fame Super Silver

Re: ip summary-address eigrp

Michael

I am glad that configuring eigrp stub fixed your problem. Did you also add the administrative distance to the eigrp summary-address or was it only the eigrp stub that you configured?

HTH

Rick

New Member

Re: ip summary-address eigrp

i didn't configure the admin distance, i left it default. I only configured the spoke router as eigrp stub connected.

This is what i was wanting to see on my spoke router....

Gateway of last resort is 10.255.255.45 to network 0.0.0.0

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.12 is directly connected, Loopback0

C 192.168.249.0/24 is directly connected, Vlan249

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C 10.0.14.0/24 is directly connected, Vlan14

C 10.0.15.0/24 is directly connected, Vlan15

C 10.255.255.44/30 is directly connected, GigabitEthernet0/52

C 10.0.35.0/24 is directly connected, Vlan35

C 192.168.248.0/24 is directly connected, Vlan248

*****D* 0.0.0.0/0 [90/3072] via 10.255.255.45, 12:32:31, GigabitEthernet0/52

So on every L3 P2P port on my Core that connects to only one end point, i plan to inject a default route using the IP Summary-address command. I'm restructuring IPs so the local table is a little weird right now.

667
Views
9
Helpful
10
Replies