Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Telephony: port-security with voice vlan "Sticky"

Hello all,

I have the following :

Why does the Cisco 7960 phone NOT put a sticky mac address automatically under the switchport, just the PC does?

It seems to work, but am not sure why.

Also, I dont require "maximum macs" to be set to 3 do I? Like when you use Avaya?

Many thx indeed,

Ken

!

interface FastEthernet1/0/10

description IP Phone with desktop connected

switchport access vlan 10

switchport mode access

switchport voice vlan 20

switchport port-security

switchport port-security maximum 2

switchport port-security mac-address sticky

switchport port-security mac-address sticky aaaa.bbbb.cccc

no ip address

duplex full

speed 100

priority-queue out

no mdix auto

switch#sh mac-address-table int fa 1/0/10

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

10 aaaa.bbbb.cccc STATIC Fa1/0/10

20 dddd.eeee.ffff STATIC Fa1/0/10

Total Mac Addresses for this criterion: 2

switch#

1 ACCEPTED SOLUTION

Accepted Solutions

Re: IP Telephony: port-security with voice vlan "Sticky"

Hi Ken,

When a voice VLAN is configured on a secure port that is also configured as a sticky

secure port, all addresses seen on the voice VLAN are learned as dynamic secure addresses,

and all addresses seen on the access VLAN (to which the port belongs) are learned as

sticky secure addresses.?

So the IP Phone?s MAC address would not be learned as sticky address.

Port Security Configuration Guidelines:

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration

_guide_chapter09186a00802cb7c4.html#wp1038546

Hope that helps !

Regards,

~JG

Please rate helpful posts.

2 REPLIES

Re: IP Telephony: port-security with voice vlan "Sticky"

Hi Ken,

When a voice VLAN is configured on a secure port that is also configured as a sticky

secure port, all addresses seen on the voice VLAN are learned as dynamic secure addresses,

and all addresses seen on the access VLAN (to which the port belongs) are learned as

sticky secure addresses.?

So the IP Phone?s MAC address would not be learned as sticky address.

Port Security Configuration Guidelines:

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration

_guide_chapter09186a00802cb7c4.html#wp1038546

Hope that helps !

Regards,

~JG

Please rate helpful posts.

New Member

Re: IP Telephony: port-security with voice vlan "Sticky"

Hi there JG.

That is fantastic. many thx for your help. Thought I was going mad :))

Kindest regards,

Ken

310
Views
0
Helpful
2
Replies
CreatePlease to create content