Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPv6 DHCP Server configuration c3560

I am trying to get my c3560 L3 swtich to provide stateful IPv6 addressing to PC's and IP Phones. After reviewing many documents and configuring the swtich with an IPv6 DHCP lab example from Cisco. I am unable to get any device to actually retrieve and IPv6 address. Please review my config and offer some guidance.

Enabling debug ipv6 dhcp detail does not display any information from the console port when a PC or Phone tries to retrieve a DHCP prompting a timeout message on the endpoint.

hostname IPv6
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$xJQ9$84oBJIY8zPRlMjJZ4tYu..
enable password

!
no aaa new-model
clock timezone EST -5
system mtu routing 1500
ip subnet-zero
ip routing
!
!
ip multicast-routing distributed
no ip igmp snooping
ipv6 unicast-routing
ipv6 cef accounting prefix-length
ipv6 dhcp pool pool1
prefix-delegation 2001:DB8:1263::/48 0005000400F1A4D070D003
prefix-delegation pool pool1 lifetime 1800 60
address prefix 2001:1000::/64
link-address 2001:1001::/64
dns-server 2001:DB8:3000:3000::42
domain-name example.com
!
!
password encryption aes
!
crypto pki trustpoint TP-self-signed-1509365248
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1509365248
revocation-check none
rsakeypair TP-self-signed-1509365248
!
!
crypto pki certificate chain TP-self-signed-1509365248
certificate self-signed 01
  30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31353039 33363532 3438301E 170D3933 30333031 30303030
  35395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35303933
  36353234 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100D02A 0BD13711 1B6F96F0 7B389612 D057ED75 F3714047 CFC5E393 96E34524
  1C2BD980 BFBE8A03 345F8E61 1F32CB97 7283DF83 7DD733E2 0C353E30 20A0CD41
  68E8C7FB A42D41BF 46253C79 D5140833 AB2E3C44 5878E892 C0BAF8E3 6DD0E7BF
  C69F56A9 F1D7BAA2 AA41646F BF78B80B 1529EC6A 79D805A1 44CEB030 8DB91093
  F9EB0203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
  551D1104 10300E82 0C495042 4C55455F 49507636 2E301F06 03551D23 04183016
  801488D0 E9FF2AE5 5B88D0F9 9278C47C BDBBADAB 0C56301D 0603551D 0E041604
  1488D0E9 FF2AE55B 88D0F992 78C47CBD BBADAB0C 56300D06 092A8648 86F70D01
  01040500 03818100 C55EDDD3 48220B83 D5CA51D5 6CF8802B AEE7C3E5 BE8272DC
  1560BDF6 31B84A03 6927B499 3E4A4E3F 4E144DA2 BD7ED1A5 B18C5F10 FC6151B7
  59A53627 DE9587FA A9F4BE30 6073CB4B 9416971D B058CAEE F82C23FA 8DE3A884
  81BACA84 955CC4BD 84A3BBDE 5CBA3DA9 44535DFC 81A3AE4E FFC5A68B 4B8F3A57
  4BFBEB9B 4B52F120
  quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/1
  switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 200
switchport mode access
  spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 200
switchport mode access
spanning-tree portfast

---------------------------------------------------------------------------------

interface Vlan1
no ip address
shutdown
!
interface Vlan200
description Voice
no ip address
ipv6 address FE80::1 link-local
ipv6 dhcp server pool1
!
ip classless
ip http server
ip http secure-server
!
!
!
!
control-plane
!

================================================

IPv6#
*Mar  1 18:50:28.705: %SYS-5-CONFIG_I: Configured from console by console
IPv6#sh ipv6 interface
Vlan200 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1
  No Virtual link-local address(es):
  Description: Voice
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:2
    FF02::1:FF00:1
    FF05::1:3
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  Output features: Check hwidb
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 23968)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.
IPv6#

IPv6#sh ipv6 dhcp pool
DHCPv6 pool: pool1
  Static bindings:
    Binding for client 0005000400F1A4D070D003
      IA PD: IA ID not specified
        Prefix: 2001:DB8:1263::/48
                preferred lifetime 604800, valid lifetime 2592000
  Prefix pool: pool1
  Address allocation prefix: 2001:1000::/64 valid 172800 preferred 86400 (0 in use, 0 conflicts)
  Link-address prefix: 2001:1001::/64
               preferred lifetime 60, valid lifetime 1800
  DNS server: 2001:DB8:3000:3000::42
  Domain name: example.com
  Active clients: 0

Everyone's tags (2)
1317
Views
0
Helpful
0
Replies
CreatePlease to create content