Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IPV6 routing..

Hi,

We just received an ipv6 connection from a provider. We already are setup with a /126 between us on our ROUTER-A and them over a 1gb link. We can ping their side and they can ping us via ipv6 address.

Currently on the access router ROUTER-B we have individual servers in different vlans with ipv4 ips with gateways assigned in their vlan for them to connect.

1) I want to know how I can assign them an ipv6 /48 so they can use on their host machine in their vlan. We have already been allocated a /32 ipv6 block from ARIN.

Example:

interface vlan 1

ip address 10.10.10.1 255.255.255.0

ip address 10.10.11.1 255.255.255.0 secondary

and then the client would have 10.10.10.2 - 254 /24 and 10.10.12.-254 /24 on thier server.

If I wanted to do the same for ipv6, how would I do that? Would I just take the first address in the ipv6 /48 as I did in the ipv4 /24 above?

Example if I had ipv6 block: 2001:49f0:0000:0000:0000:0000:0000:0000

would it be:

interface vlan 1

ipv6 address 2001:49f0:0000:0000:0000:0000:0000:0001

ipv6 address 2001:49f0:0001:0000:0000:0000:0000:0001 secondary

2) I want to connect ROUTER-B that will have the vlan information for each server and the corresponding ipv6 addresses to ROUTER-A that has the direct ipv6 connection to the provider to RouterB.

How would I Put in a default IPV6 route so that ALL ipv6 traffic not local to Router-B to goto Router-A, which inturn would have a similar default route to the Provider?

if the link between the two is such:

Router-A

interface g1/1

ip address 10.10.20.1 255.255.255.252

ipv6 address 2001:49f0:0000:0000:0000:0000:0000:0001/126

Router-B

ipv6 route ipv6 route ::/0 2001:49f0:0000:0000:0000:0000:0000:0001

interface g1/1

ip address 10.10.20.2 255.255.255.252

ipv6 address 2001:49f0:0000:0000:0000:0000:0000:0002/126

Thanks you in advance for your help!

  • LAN Switching and Routing
4 REPLIES
New Member

Re: IPV6 routing..

anyone?

Cisco Employee

Re: IPV6 routing..

1) If your block was 2001:49f0::/32

then you could indeed do something like this:

interface vlan 1

ipv6 address 2001:49f0::1/48

ipv6 address 2001:49f0:1::1/48

2) You would need to use a different subnet between Router-A and B since 2001:49f0::/48 overlaps with 2001:49f0::/126. Could be as follow:

On Router-A

interface g1/1

ipv6 address 2001:49f0:ffff::1/126

ipv6 route 2001:49f0::/48 2001:49f0:ffff::2

On Router-B:

interface g1/1

ipv6 address 2001:49f0:ffff::2/126

ipv6 route ipv6 route ::/0 2001:49f0:ffff::1

Hope this helps,

New Member

Re: IPV6 routing..

1) if I did that to the vlans, then what would the clients put on their machines to have that block? Can you provide an example.

2) That sounds what I was going to do.. thanks.

Cisco Employee

Re: IPV6 routing..

1) ipv6 autoconfiguration would be used for that purpose. Refer to the following document for more information on ipv6 autoconfiguration:

http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_7-2/ipv6_autoconfig.html

Hope this helps,

233
Views
0
Helpful
4
Replies