Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPv6 With eui-64 over Frame-Relay

Hi Experts!

i have 2 routers connected togather via frame-relay link IPv4 and IPV6.AM OK with ipv4 but not with IPV6.have a look to the config plz:

R6::

interface Serial1/0

ip address 1.1.36.6 255.255.255.0

ip nat inside

ip virtual-reassembly

encapsulation frame-relay

ipv6 address 2001:ABC:123:36::/64 eui-64

serial restart-delay 0

no dce-terminal-timing-enable

frame-relay map ipv6 2001:ABC:123:36:20F:F7FF:FE68:6470 603

frame-relay map ip 1.1.36.3 603 broadcast

frame-relay map ip 1.1.36.6 603

frame-relay map ipv6 FE80:20F::F7FF:FE68:6470 603 broadcast

no frame-relay inverse-arp

end

R3:::

interface Serial1/0

ip address 1.1.36.3 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:ABC:123:36::/64 eui-64

serial restart-delay 0

no dce-terminal-timing-enable

frame-relay map ipv6 FE80::212:7FFF:FE28:7100 306 broadcast

frame-relay map ip 1.1.36.3 306

frame-relay map ip 1.1.36.6 306 broadcast

frame-relay map ipv6 2001:ABC:123:36:212:7FFF:FE28:0 306

no frame-relay inverse-arp

end

1)what this and in wich cases we need it:eui-64

2)what this map mean:frame-relay map ipv6 FE80::212:7FFF:FE28:7100 306 broadcast

3)2001:ABC:123:36:212:7FFF:FE28:0

from where this coming from:212:7FFF:FE28:0

many 10xs to ur explanations

8 REPLIES
Hall of Fame Super Bronze

Re: IPv6 With eui-64 over Frame-Relay

eui-64 will complete the IPv6 addresses with information from the interface MAC Address. Very useful on avoiding duplicate IPv6 addresses in a network as most MAC addresses tend to be unique per interface.

I don't recommend using it on frame-relay interface because of the frame-relay mapping. You need to go into the remote router and type show ipv6 int bri to find the whole MAC address and then use that information in your local router for the mapping. Way too many steps...

On the second question, you need to map the link-local address of the remote router in addition to the IPv6 address for dynamic routing protocols.

On the third question, the :212:7FFF:FE28:0 is the node address, usually derived from the interface MAC address.

New Member

Re: IPv6 With eui-64 over Frame-Relay

hi edison

10xs

could you plz configure this via Vlan access-list

VLAN Access Control

Configure an ACL with name “y” to obtain the following requirements:-

- Deny Web Traffic from 172.16.10.0/24 to Subnet 192.168.106.0

- Permit Web Traffic from 172.16.0.0/8 to Subnet 192.168.106.0

- Permit Any Other ip traffic from your Rack to Subnet 192.168.106.0

Do not Use deny Statements, use only PERMIT statements.

(192.168.106.0 is VLAN_200)

!

10xs

Re: IPv6 With eui-64 over Frame-Relay

1. Interface identifiers (IDs) in IPv6 addresses are used to identify a unique interface on a link and are sometimes referred to as the "host portion" of the IPv6 address.

For Ethernet, the interface ID is

based on the media access control (MAC) address of the interface, in a format called the extended universal identifier 64-bit (EUI-64) format. The EUI-64 format interface ID is derived from the 48-bit MAC address by inserting the hexadecimal number FFFE between

the organizationally unique identifier (OUI) field (the upper three bytes) and the vendor

code (the lower three bytes) of the MAC address. The U/L bit of the first byte is also inverted

2. Shows the frame-relay map where the IPv6 address FE80::212:7FFF:FE28:7100 is mapped to DLCI 306. Broadcast keyword allows the DLCI to forward broadcast and multicast packets, a necessity when using link state routing protocols like ospf

3. 212:7FFF:FE28:0 -- as in point#1 derived from the mac address and inserting FFFE to get the interface identifier

HTH

Narayan

Re: IPv6 With eui-64 over Frame-Relay

Not sure how the vlan acccess-list relates to the above post but i think the below config should work

ip access-list extended VLAN_ACL_drop

permit tcp 172.16.10.0 0.0.0.255 192.168.106.0 0.0.0.255 eq www

ip access-list extended VLAN_ACL_accept

permit tcp 172.16.0.0 0.255.255.255 192.168.106.0 0.0.0.255 eq www

permit ip any 192.168.106.0 0.0.0.255

vlan access-map Y 10

match ip address VLAN_ACL_drop

action drop

vlan access-map Y 20

match ip address VLAN_ACL_accept

action forward

vlan filter Y vlan-list

HTH

Narayan

New Member

Re: IPv6 With eui-64 over Frame-Relay

hi Narayan!

are you sure to this Entry::permit tcp 172.16.0.0 0.255.255.255 ???

10xs

New Member

Re: IPv6 With eui-64 over Frame-Relay

how we can convert it to normal access-list?

10xs a lot

Re: IPv6 With eui-64 over Frame-Relay

Ali,

It is a normal access-list

I used "TCP" and restricted only the www traffic. If you want you can use "ip" instead but this will block all access between the hosts

HTH

Narayan

New Member

Re: IPv6 With eui-64 over Frame-Relay

1) EUI-64 is a method used to automaticlly create unique host portion of IPv6 address (last 64 bits of IPv6 address). EUI-64 takes MAC address from router (Router has additional pool of MAC addresses in case if interface is not Ethernet interface) and inserts FFFE hex value into the middle of the MAC address.

2) It is link-local address (IPv4 has no equivalent to IPv6 link-local address). Link-local addresses always begins with prefix FE80::/10 and ends with EUI-64

3) It is ordinary unicast IPv6 address, 212:7FFF:FE28:0 is formed by EUI-64

209
Views
20
Helpful
8
Replies
CreatePlease to create content